register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3 - Engine, Transmission & Driveline

MazdaSpeed 3 - Engine, Transmission & Driveline Discussion of engine, tranny and drivelines.


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 12-21-2019, 06:23 PM   #1
 
The_big_dill's Avatar
 
Join Date: Dec 2018
Location: (Near)Toronto, ON
Posts: 38   (View Stats)
iTrader: (0)
Rep Power: 0
The_big_dill has a spectacular aura aboutThe_big_dill has a spectacular aura about
Thanks: 0
Thanked 3 Times in 3 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default Clutch problems

Hi all,

Recently had to replace my ACT clutch after 15k km of use. One of the fingers was loose on the pressure plate causing the clutch pedal to always be vibrating. ACT sent me a revised version of the same PP, FW and Clutch disk.

While I was in there I replaced with OEM pilot and throw out bearing as well as transmission (old one was popping out of second). Soon after my Clutch master was leaking, so that was replaced. Slave cylinder is still the old one. I used MT-90 fluid instead of the Ford stuff this time around.

Problem:

1. Idling, clutch pedal is steady, as soon as I start depressing the pedal to take up the slack, I feel the pedal start vibrating slightly (I imagine its the uneven PP fingers that I am feeling in the clutch pedal).

Research points me to people saying its a bent connecting rod - I highly doubt thats the case considering the connecting rods im using and the performance of the engine. Never the less, I will do the screwdriver test soon.

2. Sometimes I will hear a whining from the trans. when depressing the clutch, usually when engaging a gear, any gear (frequency of sound will change between gears). I can release the clutch and re-engage and the noise will disappear or remain the same, but it doesn't take too many attempts to re-create the problem. This is always true in the cold. I wanted to say the fluid has something to do with it, but since I can shut it up and re-create it on the spot, I am not so sure.

Any advice on any point?
__________________
2008.5|Engine rebuilt @232K KM - Mahle PowerPak 4032, Manley H beam, ARP head and main
CNT Long Catted|COBB SF+TIP|AT HPFP|CPE TMIC|K04|Corksport RMM|
EGR Delete|VTCS Delete
COBB APV3|Stage2 OTS Base+self tune
The_big_dill is offline   Reply With Quote
 Old 12-23-2019, 06:59 AM   #2
 
Jeff23spl's Avatar
 
Join Date: Sep 2013
Location: Quebec
Posts: 2,198   (View Stats)
iTrader: (0)
Rep Power: 0
Jeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the world
Thanks: 160
Thanked 589 Times in 470 Posts
Groans: 3
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

if you want to sleep better with idea of a bent rod, just take engine compression or measure piston height with a precision tool.

The trans could be noisy especially if you have solid mount but when i experienced a similar issue, it was with oem dual mass fw and destroyed transmission main bearing. because of loose fw, sometimes the clutch seated out of center a bit and was vibrating and when i did push again the clutch, it could seat better and stop shaking...(try and error) i keep it this way until it started to create vibration while under load....I replaced everything at once so i don't know which of the bearing or fw was creating the problem but the repair solved.
__________________
Mazda for life...or until i can afford something better...

2007 rusted Speed6... Forged with meth and a 3076 in progress...
1993 Ford Probe KLZE 143dB
2012 Mazda3 Gs-sky 6.5l/100 when transporting speed parts
1989 GM 6.2 diesel pickup
Wife drive 2010 CX7

2007 speed3 burned (i'm proud to ran 12.7s with it)

...Because French Canadian...

If you check for leaks and you didn't made a test under compressor pressure, you aren't done checking for leaks....
Jeff23spl is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch Problems Xanthos MazdaSpeed 3/6 - Troubleshoot/Diagnostics 11 06-20-2017 03:58 PM
Clutch Problems fermentj Gen2 MS3 General Discussion 15 06-14-2015 02:43 PM
clutch problems spokelse Gen2 MS3 General Discussion 1 01-16-2015 09:46 PM
clutch problems plz take a look cocoleveo7686 MazdaSpeed 6 - Engine, Transmission & Driveline 7 07-08-2013 02:44 PM
Clutch problems LV_Mazdaspeed06 MazdaSpeed 6 - Engine, Transmission & Driveline 2 02-28-2012 06:30 AM


All times are GMT -7. The time now is 11:39 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2019 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.23171 seconds with 21 queries