register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3 - Engine, Transmission & Driveline

MazdaSpeed 3 - Engine, Transmission & Driveline Discussion of engine, tranny and drivelines.


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 09-10-2019, 04:14 AM   #1
 
dmclngn811993's Avatar
 
Join Date: Sep 2019
Location: Vancouver Canada
Posts: 4   (View Stats)
iTrader: (0)
Rep Power: 0
dmclngn811993 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default Transmission Problems?

Hi all, I just recently traded my 2015 brz for a 2007 mazdaspeed 3 + cash ofcourse. Everything was smooth until my shifter felt weird and then my clutch pedal got stuck on the floor. Thought it was the slave clutch cylinder. Mechanic changed it but the shifter still feels weird. Asked the mechanic if he feels my shifter is not normal and he said it is. I asked him if he can check my tranny fluid, he then told me that the brake fluid AND the tranny fluid have the reservoir. So that's that. Went to a different mechanic, let them test drive the car, car wouldn't engage right away to Reverse, 1st, 3rd and 5th. He took a look at my transmission fluid and found a leak. Paid $400 for that and still the gears are not engaging. Went to another mechanic (Mister Transmission), had them look at it. They told me it could be the synchros or the shift fork. I told them to re bleed the slave because maybe there's air in the system which did they did and there was air in the system. They told me that the Master needs to be replaced too because it is leaking. Went to drive my car and now it's even worse. I have to shift 1st gear - neutral - 1st gear - neutral - 1st gear - neutral and then 1st gear and it will finally engage. As of now, I can't shift 3rd and 5th right away as they dont engage.

P.S. when the car is off, all the gears are engaging properly.

I have spent atleast $900 and still not fixed...

Help
dmclngn811993 is offline   Reply With Quote
 Old 09-11-2019, 05:26 AM   #2
 
dmclngn811993's Avatar
 
Join Date: Sep 2019
Location: Vancouver Canada
Posts: 4   (View Stats)
iTrader: (0)
Rep Power: 0
dmclngn811993 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Hey guys!

So i have an update. I removed my airfilter and figured out th culprit. Its the shifter cable. Everytime i put it on R, 1, 3 and 5, the cable flexes up. And also, i think the previous owner tried to mcgyver it with hockey tape so it stops the cable from flexing.

How much do u think the replacement will cost?

Thanks!
dmclngn811993 is offline   Reply With Quote
 Old 11-26-2019, 12:04 PM   #3
 
Anaphra's Avatar
 
Join Date: Dec 2017
Location: Chico CA for school. Originally From the Bay Area
Posts: 11   (View Stats)
iTrader: (0)
Rep Power: 0
Anaphra is an unknown quantity at this point
Thanks: 7
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Did you get this worked out? where was it bowing upward? In the engine bay bellow the intake/battery, or like in the cabin underneath the center console? the whole problem is sort of hard to imagine without pictures or a better description.

In terms of how much will this cost? I'm assuming you'll either need a new shift cable or like a retainer to hold the shifter cable in place. I'd personally start at the dealership and get a quote and a part number. From there check other sources and see if you can track down a reliable source to get one for cheap.
Anaphra is offline   Reply With Quote
 Old 11-26-2019, 02:41 PM   #4
 
Jeff23spl's Avatar
 
Join Date: Sep 2013
Location: Quebec
Posts: 2,192   (View Stats)
iTrader: (0)
Rep Power: 0
Jeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the world
Thanks: 160
Thanked 585 Times in 467 Posts
Groans: 3
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

you could probably get this used but compare it in case...

you can unplug it at the trany and see if the cable itself make resistance or if the mechanist is rusted or if a bracket missing. I'm not sure if my memory is right but i think there should be 2 brakets holding the cables on the trany case.
But it would be strange that a bad wire is just bad when the engine is running...it would feel the same resistance with engine off...
Is your clutch height and feel ok ? you got investigation around this a lot but if the clutch isn't slipping, the car isn't trying to move fwd in gear with clutch depressed and the contact happen correctly at mid travel (not almost on the floor) this part would be ok...

Most of the time, if the clutch is ok, and it only happen while the engine is running it is looking for bad synchros......

You can also take a look at the shifter itself and see if someone may have replaced a short shifter in a hurry to stock out the car but screwed something there...
the problem would be about synchros but i have seen bent fork or shifter

This car will never shift smoothly between 1 and 2 under heavy load and will probably remain a bit heavier than your Toyota as the transmission is designed to handle the extra torque but it should shift...
__________________
Mazda for life...or until i can afford something better...

2007 rusted Speed6... Forged with meth and a 3076 in progress...
1993 Ford Probe KLZE 143dB
2012 Mazda3 Gs-sky 6.5l/100 when transporting speed parts
1989 GM 6.2 diesel pickup
Wife drive 2010 CX7

2007 speed3 burned (i'm proud to ran 12.7s with it)

...Because French Canadian...

If you check for leaks and you didn't made a test under compressor pressure, you aren't done checking for leaks....
Jeff23spl is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission problems bigswiss MazdaSpeed 3 - Engine, Transmission & Driveline 7 01-21-2016 07:46 PM
transmission problems help PL ENDO 2010 MS3 - Engine, Transmission & Driveline 12 04-19-2013 04:22 AM
Transmission problems franciscoescn MSP - Engine, Transmission & Driveline 18 01-05-2012 10:40 AM
More transmission problems inthetwisties MazdaSpeed 3 - Engine, Transmission & Driveline 32 01-06-2011 10:28 PM
Transmission problems need help phantomspeed3 Mazdaspeed3/6 General Discussion 6 02-02-2009 03:21 PM


All times are GMT -7. The time now is 07:48 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2019 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.25665 seconds with 22 queries