register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Turbo Induction

MazdaSpeed 3/6 - Turbo Induction MazdaSpeed 3/6 - Turbo Induction - Have a turbo, intercooler, downpipe question? Anything turbo related belongs here!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Like Tree1Likes
  • 1 Post By Fstrnyou
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 11-30-2018, 05:23 PM   #1
 
ian209's Avatar
 
Join Date: Mar 2017
Posts: 17   (View Stats)
iTrader: (0)
Rep Power: 0
ian209 will become famous soon enoughian209 will become famous soon enough
Thanks: 2
Thanked 2 Times in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default 08 MS3 EBCS P0245 issue

Hey All,

Anyone have a picture of their EBCS or know if the factory connector is suppose to be 2 wire or 1 wire? I have the Corksport EBCS installed in my speed3 and it comes with a 2 wire connector, but my factory harness is only 1 wire. I'm also getting a P0245 when I scan for codes, but the CEL isn't on. My tuner just recently turned up the WGDC to 25% to supposedly yield 20PSI of boost, but I'm only getting around 16-17 PSI on my Corksport Turbo, which is around wastegate spring pressure. Any help would be appreciated! I don't have pictures quite yet, but I'll try to get some soon.

Also, if it suppose to be 2 wire on the factory harness, does someone have a wiring diagram/pinout for it?

Thanks,

Ian
ian209 is offline   Reply With Quote
 Old 11-30-2018, 05:36 PM   #2
 
SSinstaller's Avatar
 
Join Date: Mar 2008
Location: Jacksonville, NC
Posts: 3,901   (View Stats)
iTrader: (0)
Rep Power: 2438
SSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the world
Thanks: 807
Thanked 4,540 Times in 1,671 Posts
Groans: 55
Groaned at 17 Times in 12 Posts
Not Ranked  0 score     
Default

Attached Images
File Type: gif 136783403.gif (77.6 KB, 27 views)
__________________
Fully Built : Arias Pistons: Pauter Rods : ARP bolts: Ported Head: Cosworth BSD : Spec 3+ Clutch : Fidanza Flywheel : AWR Engine mounts 90duro : Custom TIP/Intake : Custom Blow Through 3.5" MAF : Custom FMIC : HKS SSQV VTA : Ported IM : Custom DP : Custom Exhaust : CPBoost Top Mount EM : Garrett GT3582R : PTP Turbo Blanket: Tial V44 EWG : Perrin EBCS : MrLilGuy/PTP HPFP : Ported fuel line : Ported Fuel Rail : Custom Ported Fuel Injectors : Kenny Bell Boost-a-Pump : HKS Twin Power DLI II : HKS M-Series Plugs : Cobb AP : AEM 3.5bar MAP :Koni Sport shocks : RPM Kspec Springs : TWM STS : TT Front Diff Mount : CPE Upper Diff Mount : Whiteline RSB : AWR Endlinks

Soon to be installed:
ST manifold w/ port injection : Raduim Engineering PCV Plate : Radium Engineering PCV valve : Radium Engineering Fuel filter : Aeromotive FPR : DCR VVT : TI Automotive F90000274 Fuel Pump : NX 15718 : Split Second AIC

SSinstaller is offline   Reply With Quote
The Following User Says Thank You to SSinstaller For This Useful Post:
ian209 (12-07-2018)
 Old 12-05-2018, 06:26 PM   #3
 
ian209's Avatar
 
Join Date: Mar 2017
Posts: 17   (View Stats)
iTrader: (0)
Rep Power: 0
ian209 will become famous soon enoughian209 will become famous soon enough
Thanks: 2
Thanked 2 Times in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Just checking if I'm tripping balls or not. The EBCS has a switched +12V going to one pin from the main relay with a fuse "ENG BB 5A." The other pin is from the PCM to the solenoid with presumably an active low PWM signal. Am I correct?
ian209 is offline   Reply With Quote
 Old 12-06-2018, 07:47 AM   #4
 
Jeff23spl's Avatar
 
Join Date: Sep 2013
Location: Quebec
Posts: 1,554   (View Stats)
iTrader: (0)
Rep Power: 298
Jeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the world
Thanks: 126
Thanked 440 Times in 343 Posts
Groans: 1
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

you mixed 2 connectors if the 1 remain for the ebcs has just 1 wire. In that car, i figured out Mazda made all connectors différents in the engine bay to avoid mixing them except these 2 and unfortunately both are at the same location to make it easy to be mixed...

You probably put the wrong one to the capacitor bolted on top plate above the EGR valve.

EBCS connector needs 2 wires. one is a constant +12v and the other one is the pulsed negative signal from the ECU.
__________________
Mazda for life...or until i can afford something better...

2007 rusted Speed6... in progress...
1993 Ford Probe KLZE 143dB
2012 Mazda3 Gs-sky 6.5l/100 when transporting speed parts
1989 GM 6.2 diesel pickup
Wife drive 2010 CX7

2007 speed3 burned (i'm proud to ran 12.7s with it)

...Because French Canadian...
Jeff23spl is offline   Reply With Quote
The Following User Says Thank You to Jeff23spl For This Useful Post:
ian209 (12-07-2018)
 Old 12-07-2018, 02:49 AM   #5
 
ian209's Avatar
 
Join Date: Mar 2017
Posts: 17   (View Stats)
iTrader: (0)
Rep Power: 0
ian209 will become famous soon enoughian209 will become famous soon enough
Thanks: 2
Thanked 2 Times in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Yep, you were right lol. The guys that installed my new Corksport Dankai 1 motor mixed up the connection for the EBCS and capacitor. What does that capacitor do btw?
ian209 is offline   Reply With Quote
 Old 12-07-2018, 06:12 AM   #6
 
Jeff23spl's Avatar
 
Join Date: Sep 2013
Location: Quebec
Posts: 1,554   (View Stats)
iTrader: (0)
Rep Power: 298
Jeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the world
Thanks: 126
Thanked 440 Times in 343 Posts
Groans: 1
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

i bet it is a filtering cap to reduce some signal noise but idk
__________________
Mazda for life...or until i can afford something better...

2007 rusted Speed6... in progress...
1993 Ford Probe KLZE 143dB
2012 Mazda3 Gs-sky 6.5l/100 when transporting speed parts
1989 GM 6.2 diesel pickup
Wife drive 2010 CX7

2007 speed3 burned (i'm proud to ran 12.7s with it)

...Because French Canadian...
Jeff23spl is offline   Reply With Quote
 Old 12-09-2018, 03:35 PM   #7
 
Fstrnyou's Avatar
 
Join Date: Jul 2016
Location: Near Charlotte NC
Posts: 2,080   (View Stats)
iTrader: (0)
Rep Power: 0
Fstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the world
Thanks: 46
Thanked 556 Times in 429 Posts
Groans: 21
Groaned at 6 Times in 5 Posts
Not Ranked  0 score     
Default

Be careful with your new tune now that the connector is fixed.
Jeff23spl likes this.
__________________
'06 MS6 GT-165k Miles(Forged@157,116)
Manley Pistons & Rods, King Bearings
Stock Head/Cams, Stock Int/Exh Manifolds
Versatuner, 3-bar MAP, ITV22, CP-e TMIC
CS Turbo/DP/RP/HPFP/BPV/R-DiffMount
White Widow F-DiffMount, Whiteline RSB
Rear Russian Bushings, Poly FSB Bushings
Magnaflow CBE, ACT 6-puck/Streetlite
JBR Tru-3.5/3-port EBCS/EGR-D
Damond RMM/PMM/OCC/PCV Plate
Other rides:
2002 Tacoma ExtCab 2.4L 5spd 2WD - 355k mile Speed support vehicle.
2004 Olds Alero ECOtec 2.2 - Broken (since Christmas 2015 and I really need to get rid of it)
History:
2008 GSX-R 1000 - Stolen (With several runs past 180, I'd probably be dead by now if it wasn't stolen. So in a way, I'm thankful.)
1988 RX-7 TII - Sold (Megasquirt, streetport, filter-on-turbo SRI, custom TBE, 20psi boost creep on OE turbo, OE TMIC on ice, 13.467 @ 105.44)
1985 Camaro - Sold (est. 265bhp 5.7 swap, Edelbrock intake & Hooker headers)
Fstrnyou is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
P0245 CEL Flameninja00 2010 MS3 - Troubleshoot/Diagnostics 10 01-26-2017 07:07 PM
p0401 and p0245 cocoleveo7686 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 15 12-10-2013 01:55 PM
P0245 CEL Zbrit00x Gen2 MS3 General Discussion 2 08-09-2012 09:46 PM
CLE P0245 ms6ms6 MazdaSpeed 6 - Engine, Transmission & Driveline 1 09-20-2011 11:26 PM
P0245, with MBC? 11cruzito11 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 3 12-20-2009 08:29 PM


All times are GMT -7. The time now is 05:28 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.26350 seconds with 24 queries