register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Turbo Induction

MazdaSpeed 3/6 - Turbo Induction MazdaSpeed 3/6 - Turbo Induction - Have a turbo, intercooler, downpipe question? Anything turbo related belongs here!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 11-05-2019, 06:10 PM   #1
 
Tmarkal's Avatar
 
Join Date: Nov 2019
Posts: 1   (View Stats)
iTrader: (0)
Rep Power: 0
Tmarkal is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Post Gen 1 Blows a lot of white smoke PCV Valve?

I keep it in the garage and have not driven it much. I start it every week. A few days ago I started the Mazda and let it get up to temp and idle for longer than usual like 30 minutes. A few days later I turned the car on and white smoke came pouring out of the exhaust. The engine sounded healthy and The car does not get driven often. I turned off the car and checked the oil fill and there was some smoke coming out of there as well. Oil in the intake as well. I have an oil catch can and that was not full either. Im not sure if the seals are bad (IDK how that would happen if the car is garage kept) or if it is a pcv valve issue (or something else) Any suggestions or theories.
Tmarkal is offline   Reply With Quote
 Old 11-06-2019, 07:24 AM   #2
 
MSMS3's Avatar
 
Join Date: Jun 2009
Posts: 2,738   (View Stats)
iTrader: (0)
Rep Power: 1107
MSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the world
Thanks: 1,436
Thanked 1,897 Times in 1,042 Posts
Groans: 154
Groaned at 47 Times in 31 Posts
Not Ranked  0 score     
Default

You might want to read the numerous “smoking turbo” threads. If it smokes at idle and not so much in normal driving, it may be blown turbo seals. Very common once the engine gets over 30,000 miles.

If compression is good, then your symptoms point to the K04 turbo.
__________________
2017 Audi Q5 3.0 T (supercharged) Stage 2+ EPL tune, JHM overdrive crank pulley, EPL supercharger pulley, ZF8 TCU tune, aFe/034 intake, modified air box. 480 hp.

Sunlight Silver '08 MS3 GT Mods: (Sold 1/25/2019 after 10+ years of ownership)
BNR Stage 1 (to fix smoking K04 turbo), TurboXS 3" Catless DP/RP "Stealthback" into stock CBE, Vibrant 3 inch Ultra Quiet Resonator in RP section, Magnaflow 3 1/2" exhaust tip, Mazdaspeed CAI w/air straightener and K&N conical filter, NGK 6510 Iridium IX one step colder plugs, Hypertech tune, Autotech HPFP internals, Stock BPV (works perfectly), Yokohama Advan Neova AD08R's (stock size on stock rims); Hawk HPS pads; SURE RMM; Grimmspeed EBCS (2 port mode), Bilstein B6's, SPC rear camber arms.
MSMS3 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
white smoke after e85 mix bshotts422 2010 MS3 - Troubleshoot/Diagnostics 123 04-20-2014 08:44 PM
white smoke Dslatch4 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 19 11-12-2013 10:06 AM
My 2007 CX-7 runs like crap, Backfires, Stalls, Blows Black Smoke (Solution Included) ottoblotto CX-7 > Issues & Troubleshooting 3 04-24-2011 10:40 PM
White Smoke Soriku1489 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 15 07-08-2010 05:25 PM
White smoke? PLEASE HELP Fallenvoices MazdaSpeed 3/6 - Troubleshoot/Diagnostics 13 01-06-2010 03:39 PM


All times are GMT -7. The time now is 05:05 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2019 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.23293 seconds with 21 queries