register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 6 - How-To's


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Like Tree6Likes
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 06-09-2015, 08:16 AM   #41
 
SURGESPEED6's Avatar
 
Join Date: Jul 2014
Posts: 6   (View Stats)
iTrader: (0)
Rep Power: 0
SURGESPEED6 will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

OK thats simple enought, it looks like you have all the other wires bunched up and not leading to anything, is that the case or am i missing something?

Originally Posted by blam1 View Post
It's ghetto looking. Don't judge.
Orange and Black
Yellow and Green
The other two are listed. Hope that helps.
SURGESPEED6 is offline   Reply With Quote
 Old 06-09-2015, 10:39 AM   #42
 
blam1's Avatar
 
Join Date: Nov 2011
Location: Garden Grove, CA
Posts: 359   (View Stats)
iTrader: (5)
Rep Power: 0
blam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the world
Thanks: 209
Thanked 167 Times in 111 Posts
Groans: 3
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

4 of the 5 wires are wired up. The brown one isn't. I only showed you a picture of the two (Orange and yellow) that were vague to me. You still have to wire up the red and black as instructed.

I didn't cut the wires shorter. I just tied them up and zipped them under the IC shroud. I'll cut and refit after my smog and I reinstall my mods.
__________________
FYHN except Odyssey's. Ody's are bad-ass

1996 Acura Integra HB Sold
1998 Acura Integra GSR Sedan Sold
2008 Honda Pilot Sold
2006 Honda Accord Sold
2008 Honda Odyssey
2007 MS3 Silver Sport

Cobb AP SRI TIP // CNT DP // JBR SSP Bushings Knob RSB // CPE TMM // SU TMIC // AT INTERNALS // MD OCC RMM // NGK // Bilstein B8 // Swift Springs // Evo 9 wheels // SPC camber arms

Freek tuned 91 and 3 gal E85
[SIGPIC][/SIGPIC]
blam1 is offline   Reply With Quote
 Old 06-09-2015, 11:30 AM   #43
 
SURGESPEED6's Avatar
 
Join Date: Jul 2014
Posts: 6   (View Stats)
iTrader: (0)
Rep Power: 0
SURGESPEED6 will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Im kind of a noob to this and dont want to mess anything up, could you possibly show me where the red and black wires wire up to?

Thanks
Originally Posted by blam1 View Post
4 of the 5 wires are wired up. The brown one isn't. I only showed you a picture of the two (Orange and yellow) that were vague to me. You still have to wire up the red and black as instructed.

I didn't cut the wires shorter. I just tied them up and zipped them under the IC shroud. I'll cut and refit after my smog and I reinstall my mods.
SURGESPEED6 is offline   Reply With Quote
 Old 06-09-2015, 11:48 AM   #44
 
blam1's Avatar
 
Join Date: Nov 2011
Location: Garden Grove, CA
Posts: 359   (View Stats)
iTrader: (5)
Rep Power: 0
blam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the worldblam1 is the leader of the world
Thanks: 209
Thanked 167 Times in 111 Posts
Groans: 3
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

the first part is easy. Cut the two wires that go into the Vacuum solenoid. It is on the intake manifold, under the tmic.

Just like the picture except Red Connects to green/black at the vacume solenoid(86) and Black Connects to black/red at the vacume soleniod(85)

I just put everything back together so that's the best you'll get. It's easier than it sounds.
__________________
FYHN except Odyssey's. Ody's are bad-ass

1996 Acura Integra HB Sold
1998 Acura Integra GSR Sedan Sold
2008 Honda Pilot Sold
2006 Honda Accord Sold
2008 Honda Odyssey
2007 MS3 Silver Sport

Cobb AP SRI TIP // CNT DP // JBR SSP Bushings Knob RSB // CPE TMM // SU TMIC // AT INTERNALS // MD OCC RMM // NGK // Bilstein B8 // Swift Springs // Evo 9 wheels // SPC camber arms

Freek tuned 91 and 3 gal E85
[SIGPIC][/SIGPIC]
blam1 is offline   Reply With Quote
 Old 06-09-2015, 01:50 PM   #45
 
SURGESPEED6's Avatar
 
Join Date: Jul 2014
Posts: 6   (View Stats)
iTrader: (0)
Rep Power: 0
SURGESPEED6 will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

OK that's better than anything i have found online, Thanks for all the help and putting up with the noob lol

Originally Posted by blam1 View Post
the first part is easy. Cut the two wires that go into the Vacuum solenoid. It is on the intake manifold, under the tmic.

Just like the picture except Red Connects to green/black at the vacume solenoid(86) and Black Connects to black/red at the vacume soleniod(85)

I just put everything back together so that's the best you'll get. It's easier than it sounds.
SURGESPEED6 is offline   Reply With Quote
The Following User Says Thank You to SURGESPEED6 For This Useful Post:
blam1 (06-09-2015)
 Old 06-20-2015, 07:30 AM   #46
 
RX7Racer46's Avatar
 
Join Date: Sep 2012
Location: Thornton, CO
Posts: 2   (View Stats)
iTrader: (0)
Rep Power: 0
RX7Racer46 will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Here are the wires you tap into. Anyone, correct me if I am wrong. Thanks.
Attached Images
File Type: jpg IMG_20150614_092939672_HDR.jpg (3.25 MB, 131 views)
File Type: jpg IMG_20150614_092948573_HDR.jpg (2.93 MB, 116 views)
File Type: jpg IMG_20150614_092957572_HDR.jpg (3.18 MB, 100 views)
File Type: jpg IMG_20150614_093009652.jpg (3.27 MB, 113 views)
RX7Racer46 is offline   Reply With Quote
The Following User Says Thank You to RX7Racer46 For This Useful Post:
kosti365 (05-27-2019)
 Old 06-22-2015, 08:50 AM   #47
 
SURGESPEED6's Avatar
 
Join Date: Jul 2014
Posts: 6   (View Stats)
iTrader: (0)
Rep Power: 0
SURGESPEED6 will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Thats exactly what i did. Started it up and no more CEL Thanks for all the help.
Originally Posted by RX7Racer46 View Post
Here are the wires you tap into. Anyone, correct me if I am wrong. Thanks.
SURGESPEED6 is offline   Reply With Quote
 Old 06-23-2015, 09:21 PM   #48
 
RX7Racer46's Avatar
 
Join Date: Sep 2012
Location: Thornton, CO
Posts: 2   (View Stats)
iTrader: (0)
Rep Power: 0
RX7Racer46 will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Originally Posted by SURGESPEED6 View Post
Thats exactly what i did. Started it up and no more CEL Thanks for all the help.
Glad to help! I'm doing this once my JMF manifold comes in. Can't wait! Thanks to everyone who helped out!
RX7Racer46 is offline   Reply With Quote
 Old 08-14-2015, 06:57 AM   #49
 
davros's Avatar
 
Join Date: Oct 2014
Location: Worcester MA
Posts: 1,021   (View Stats)
iTrader: (0)
Rep Power: 0
davros is the leader of the worlddavros is the leader of the worlddavros is the leader of the worlddavros is the leader of the worlddavros is the leader of the worlddavros is the leader of the worlddavros is the leader of the worlddavros is the leader of the worlddavros is the leader of the worlddavros is the leader of the worlddavros is the leader of the world
Thanks: 338
Thanked 232 Times in 189 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Clarification. ... the relay makes the ecu think everything is there and working correctly? So not giving a cel or mil.

We are only allowed one mil code in MA and my egr delete takes that place. For now. . . .

Hmmm $5 relay. Hours of enjoyment. ...

Sent from my SM-N900V using Tapatalk
__________________
2009 Metro Gray Mica Mazdaspeed 3
Cobb AP - HTP INTAKE - HKS BPV - GrimmSpeed EBCS - Autotech HPFP - ATP catless DP - JBR EGR full delete - Damon RMM PMM TMM- TR8/CX Piping - Damon Catch Can - FREEKTUNED
davros is offline   Reply With Quote
 Old 08-14-2015, 10:50 AM   #50
 
Bulgsta's Avatar
 
Join Date: Apr 2013
Location: Long Island, NY
Posts: 120   (View Stats)
iTrader: (1)
Rep Power: 0
Bulgsta has a reputation beyond reputeBulgsta has a reputation beyond reputeBulgsta has a reputation beyond reputeBulgsta has a reputation beyond reputeBulgsta has a reputation beyond reputeBulgsta has a reputation beyond reputeBulgsta has a reputation beyond reputeBulgsta has a reputation beyond reputeBulgsta has a reputation beyond reputeBulgsta has a reputation beyond reputeBulgsta has a reputation beyond repute
Thanks: 37
Thanked 77 Times in 41 Posts
Groans: 0
Groaned at 3 Times in 2 Posts
Not Ranked  0 score     
Default

Or do what I did. Just disable the codes in ATR and be happy. When inspection comes around plug the egr and the vacuum distributer in the plugs. Enable 2/4 codes so it sees there is an egr and the vacuum distributer and pass inspection. After that just unplug it all and delete the codes again
__________________
[SIGPIC][/SIGPIC]
2007 Mazdaspeed 6
GTX3076 - CPE- EX-mani w/ 44mm EWG - CPE Safe Seals - COBB APv3 - COBB Shifter Weight - DO Stage 2 Meth - PnP Intake Mani - Catless TBE - Corksport FMIC - Corksport Rear Diff Mount - Corksport OCC - AWR RRM, TMM, PMM - TT Front Engine Mount - TT Front Diff Mount - HTP 3.5 " - GFB 50/50 - AT internals - GrimSpeed ECBS - 3 Bar Map - Perm PCV plate - JBR BSD w/ baffle - JBR TIGS - Sure Shortcut - Tower Strut Bar - EGR Delete - EGR Valve Deleted - Shifter Bushings - H&R Springs - Koni Yellow Shocks - Stoptech D&S rotors - EBC Pads - Stainless Steel Brake Lines - Denso ITV 22 - Whiteline RSB - Guardian Angel
Bulgsta is offline   Reply With Quote
 Old 07-21-2016, 06:58 PM   #51
 
Ajbobtom's Avatar
 
Join Date: Jan 2016
Posts: 1   (View Stats)
iTrader: (0)
Rep Power: 0
Ajbobtom is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

So, I installed the dei relay as above. I've cleared the runner stuck closed code but am still getting stuck open and now a circuit high code. My diode is a 3W diode I got from RadioShack. Did any of you guys have this problem? Any suggestions?
Ajbobtom is offline   Reply With Quote
 Old 03-15-2017, 11:29 PM   #52
 
Mike4g64's Avatar
 
Join Date: Sep 2011
Location: Tucson, Az
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
Mike4g64 will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

hey guys, nice write up. I have bought the relay and diodes that were recommended and my shutter valve stuck open went away but now I got a high circuit code p2010. I have changed diodes and rewired many times. Any suggestions?
Mike4g64 is offline   Reply With Quote
 Old 04-29-2017, 08:40 AM   #53
 
SpeedThrills's Avatar
 
Join Date: May 2016
Location: Keene, New Hampshire
Posts: 172   (View Stats)
iTrader: (0)
Rep Power: 0
SpeedThrills has a reputation beyond reputeSpeedThrills has a reputation beyond reputeSpeedThrills has a reputation beyond reputeSpeedThrills has a reputation beyond reputeSpeedThrills has a reputation beyond reputeSpeedThrills has a reputation beyond reputeSpeedThrills has a reputation beyond reputeSpeedThrills has a reputation beyond reputeSpeedThrills has a reputation beyond reputeSpeedThrills has a reputation beyond reputeSpeedThrills has a reputation beyond repute
Thanks: 24
Thanked 51 Times in 37 Posts
Groans: 1
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

Did this a couple of days ago. Local Radioshack is going out of business so I got everything i needed for about $5. Worked like a charm, no CEL. Thanks for the help!
SpeedThrills is offline   Reply With Quote
 Old 04-30-2017, 06:49 PM   #54
 
SSinstaller's Avatar
 
Join Date: Mar 2008
Location: Jacksonville, NC
Posts: 3,986   (View Stats)
iTrader: (0)
Rep Power: 2467
SSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the world
Thanks: 810
Thanked 4,571 Times in 1,692 Posts
Groans: 60
Groaned at 17 Times in 12 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Originally Posted by Mike4g64 View Post
hey guys, nice write up. I have bought the relay and diodes that were recommended and my shutter valve stuck open went away but now I got a high circuit code p2010. I have changed diodes and rewired many times. Any suggestions?
Sounds like you may have the diode installed backwards.
__________________
Fully Built : Arias Pistons: Pauter Rods : ARP bolts: Ported Head: Cosworth BSD : Spec 3+ Clutch : Fidanza Flywheel : AWR Engine mounts 90duro : Custom TIP/Intake : Custom Blow Through 3.5" MAF : Custom FMIC : HKS SSQV VTA : Ported IM : Custom DP : Custom Exhaust : CPBoost Top Mount EM : Garrett GT3582R : PTP Turbo Blanket: Tial V44 EWG : Perrin EBCS : MrLilGuy/PTP HPFP : Ported fuel line : Ported Fuel Rail : Custom Ported Fuel Injectors : Kenny Bell Boost-a-Pump : HKS Twin Power DLI II : HKS M-Series Plugs : Cobb AP : AEM 3.5bar MAP :Koni Sport shocks : RPM Kspec Springs : TWM STS : TT Front Diff Mount : CPE Upper Diff Mount : Whiteline RSB : AWR Endlinks


SSinstaller is offline   Reply With Quote
 Old 08-05-2017, 11:43 AM   #55
rabble rabble
 
802MS3's Avatar
 
Join Date: Aug 2008
Location: Delawhere
Posts: 5,318   (View Stats)
iTrader: (1)
Rep Power: 3166
802MS3 is the leader of the world802MS3 is the leader of the world802MS3 is the leader of the world802MS3 is the leader of the world802MS3 is the leader of the world802MS3 is the leader of the world802MS3 is the leader of the world802MS3 is the leader of the world802MS3 is the leader of the world802MS3 is the leader of the world802MS3 is the leader of the world
Thanks: 9,400
Thanked 5,935 Times in 2,083 Posts
Groans: 221
Groaned at 103 Times in 56 Posts
Not Ranked  0 score     
Default

ugh that picture is gone. where does the diode go?

edit: nm tracked it down, uploaded to the forum.
Attached Images
File Type: png vtcs_bypass.png (2.5 KB, 460 views)
radbrad and davros like this.
__________________
'08 CWP MS3 w/ T3 3071r

Last edited by 802MS3; 08-05-2017 at 11:58 AM.
802MS3 is offline   Reply With Quote
 Old 12-11-2017, 01:40 PM   #56
 
6strngs's Avatar
 
Join Date: Nov 2017
Posts: 1   (View Stats)
iTrader: (0)
Rep Power: 0
6strngs is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Hey guys. I'm just did this, but used a 30A starter kill relay. Wired it up exactly as said (86 to green/black, 85 to black/red, 87a and 30 to the plunger) and I'm still getting p2004 stuck open and now a p2010 circuit high code. I've tried the diode both ways and same thing. What do I do now?
6strngs is offline   Reply With Quote
 Old 12-12-2017, 05:36 PM   #57
 
SSinstaller's Avatar
 
Join Date: Mar 2008
Location: Jacksonville, NC
Posts: 3,986   (View Stats)
iTrader: (0)
Rep Power: 2467
SSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the worldSSinstaller is the leader of the world
Thanks: 810
Thanked 4,571 Times in 1,692 Posts
Groans: 60
Groaned at 17 Times in 12 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Fixed the picture in the OP.

Originally Posted by 6strngs View Post
Hey guys. I'm just did this, but used a 30A starter kill relay. Wired it up exactly as said (86 to green/black, 85 to black/red, 87a and 30 to the plunger) and I'm still getting p2004 stuck open and now a p2010 circuit high code. I've tried the diode both ways and same thing. What do I do now?
P2010 is caused by the diode being installed backwards. Remove it entirely, and your mil should go away. Installed backwards it's no different than connecting the two wires together. It can damage the ECM, and will stop the relay from working..
__________________
Fully Built : Arias Pistons: Pauter Rods : ARP bolts: Ported Head: Cosworth BSD : Spec 3+ Clutch : Fidanza Flywheel : AWR Engine mounts 90duro : Custom TIP/Intake : Custom Blow Through 3.5" MAF : Custom FMIC : HKS SSQV VTA : Ported IM : Custom DP : Custom Exhaust : CPBoost Top Mount EM : Garrett GT3582R : PTP Turbo Blanket: Tial V44 EWG : Perrin EBCS : MrLilGuy/PTP HPFP : Ported fuel line : Ported Fuel Rail : Custom Ported Fuel Injectors : Kenny Bell Boost-a-Pump : HKS Twin Power DLI II : HKS M-Series Plugs : Cobb AP : AEM 3.5bar MAP :Koni Sport shocks : RPM Kspec Springs : TWM STS : TT Front Diff Mount : CPE Upper Diff Mount : Whiteline RSB : AWR Endlinks



Last edited by SSinstaller; 12-12-2017 at 05:53 PM.
SSinstaller is offline   Reply With Quote
 Old 06-20-2018, 04:13 PM   #58
 
HumbleGhost's Avatar
 
Join Date: Feb 2017
Posts: 18   (View Stats)
iTrader: (0)
Rep Power: 0
HumbleGhost has a little shameless behaviour in the past
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

Originally Posted by SSinstaller View Post
Fixed the picture in the OP.



P2010 is caused by the diode being installed backwards. Remove it entirely, and your mil should go away. Installed backwards it's no different than connecting the two wires together. It can damage the ECM, and will stop the relay from working..


Hi there,

I purchased the 8616 DEI relay after deciding to delete my VTCS when the plastic POS broke.

I also bought an assortment of diodes, can someone let me know which diode from this list will work best? I don't want to fuck something up royally here.
Does there need to be a diode at all? If so, what is the best way to tap into those lines with the diode? T-taps and connectors or just wrap and tape?


1N4148 switching signal Doide DO-35
1N4007 1A 1000V Rectifier Diode DO-41
1N5819 1A 40V SCHOTTKY DIODE DO-41
1N5399 1.5A 1000V 4.8W Rectifier Diode DO-15
FR107 Fast Recovery Diodes FR107 1A 1000V DO-41
FR207 2A 1000V Fast Recovery Diodes DO-41
1N5408 Diode Rectifier 3.0 amp 1000V DO-201AD
1N5822 40V 3A SCHOTTKY DIODE DO-201AD.
@SSinstaller;

Last edited by HumbleGhost; 06-21-2018 at 01:33 PM.
HumbleGhost is offline   Reply With Quote
Reply


LinkBacks (?)
LinkBack to this Thread: http://www.mazdaspeedforums.org/forum/f111/how-remove-mil-s-caused-deleting-vtcs-9150/
Posted By For Type Date
After VTCS Delete Code p2006 - Mazda3 Forums : The #1 Mazda 3 Forum This thread Refback 06-13-2015 11:38 PM
My list so far - Page 3 - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum This thread Pingback 07-25-2014 12:39 PM
VVT Relay to get rid of Code - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum This thread Pingback 09-10-2012 12:33 PM
Intake butterflies This thread Refback 08-15-2012 08:55 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install new bumper protector to remove Front License Plate Holes. FastAttack MazdaSpeed 3 - How-To's 20 12-19-2014 01:19 PM
How-To remove O2 sensors without messing them up mazdaspeedjay MazdaSpeed 3 - How-To's 38 07-14-2009 08:02 AM
Interesting Thread on the Effects of Braking caused by Grippier Tires/Lighter Wheels Crossbow MazdaSpeed 3/6 - Suspension & Brakes 32 12-16-2008 10:33 PM
PTP's CAT back exhaust system, soon to be TBE system. ptperformance Mazdaspeed3/6 General Discussion 56 10-05-2008 02:08 PM
NVIDIA Drivers Caused Lions Share of Early Vista Crashes Haltech Computers & Technology News 0 03-26-2008 02:10 PM


All times are GMT -7. The time now is 02:10 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2019 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.41455 seconds with 32 queries