register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
CX7FORUMS.ORG - 2007+ Mazda CX-7 Forums
> CX-7 > Engine, Transmission & Driveline


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 07-11-2018, 08:31 AM   #1
 
Guitarkidd's Avatar
 
Join Date: May 2011
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
Guitarkidd is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default 2011 - 90K Miles - Trans/Shifting Issue - Transmission or TCM

Hello,

I have a 2011 with 90K. This morning was the first time I felt anything wrong with this car and its transmission. From a stop or near stop it appeared to be starting from 2nd gear, and then would down shift into 1st upon acceleration. Not hard down shift, but obviously not normal, and then the car would go through the gears normally with no issues. Only when I cam to a stop or a near stop would it stay in 2nd and then drop into 1st upon accelerating.

When I got to work the AT light eventually came on with no check engine light. There is a very respectable transmission shop within walking distance. When they opened I went to the car to drive it over. My car would not go into reverse but would still go into drive.

I pushed the car out of the parking spot and drove it to the transmission shop. The car went into reverse upon the initial test drive and the issues of shifting were present, but then at another point, the manager lost reverse during the test drive.

The manager was telling me that he believes from just driving it that something internal is wrong and I'm probably looking at a replacement and or rebuild. The manager is going to do some research on potential TSB, customer satisfaction programs from Mazda, etc., but I doubt there is anything he will find.

However, some research has shown that other Mazdas with the same or similar power trains have had the same issues and have only needed the TCM flashed or replaced.

This car has never shown any issues shifting. I am the original owner and have had all maintenance done too.

Thought and suggestions would be appreciated.
Guitarkidd is offline   Reply With Quote
 Old 07-11-2018, 10:07 AM   #2
 
Db09ms3's Avatar
 
Join Date: Nov 2016
Location: AZ
Posts: 254   (View Stats)
iTrader: (0)
Rep Power: 0
Db09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond repute
Thanks: 313
Thanked 53 Times in 44 Posts
Groans: 58
Groaned at 4 Times in 4 Posts
Not Ranked  0 score     
Default

I'm confused. Your car is a Mazdaspeed 3, correct? If so, is the shifter coming out of 2nd and going into 1st? Easy to see due to it being a manual transmission only car.

From your description it sounds like you're driving an automatic regular Mazda3.
__________________
Stockish
Db09ms3 is offline   Reply With Quote
 Old 07-11-2018, 11:00 AM   #3
 
Guitarkidd's Avatar
 
Join Date: May 2011
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
Guitarkidd is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Originally Posted by Db09ms3 View Post
I'm confused. Your car is a Mazdaspeed 3, correct? If so, is the shifter coming out of 2nd and going into 1st? Easy to see due to it being a manual transmission only car.

From your description it sounds like you're driving an automatic regular Mazda3.
I'm sorry I'm confused why you're confused LOL... I posted this in the CX-7 forum because I have a 2011 CX-7... I am not sure why you are thinking I have a different vehicle.
Guitarkidd is offline   Reply With Quote
 Old 07-11-2018, 12:48 PM   #4
 
Db09ms3's Avatar
 
Join Date: Nov 2016
Location: AZ
Posts: 254   (View Stats)
iTrader: (0)
Rep Power: 0
Db09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond repute
Thanks: 313
Thanked 53 Times in 44 Posts
Groans: 58
Groaned at 4 Times in 4 Posts
Not Ranked  0 score     
Default

Ha! I'm dumb. Carry on sir!
__________________
Stockish
Db09ms3 is offline   Reply With Quote
 Old 07-11-2018, 05:43 PM   #5
 
Solarsurge's Avatar
 
Join Date: Apr 2016
Location: Richmond, VA
Posts: 502   (View Stats)
iTrader: (0)
Rep Power: 88
Solarsurge is the leader of the worldSolarsurge is the leader of the worldSolarsurge is the leader of the worldSolarsurge is the leader of the worldSolarsurge is the leader of the worldSolarsurge is the leader of the worldSolarsurge is the leader of the worldSolarsurge is the leader of the worldSolarsurge is the leader of the worldSolarsurge is the leader of the worldSolarsurge is the leader of the world
Thanks: 24
Thanked 108 Times in 84 Posts
Groans: 0
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

Originally Posted by Guitarkidd View Post
I'm sorry I'm confused why you're confused LOL... I posted this in the CX-7 forum because I have a 2011 CX-7... I am not sure why you are thinking I have a different vehicle.
Solarsurge is offline   Reply With Quote
The Following User Says Thank You to Solarsurge For This Useful Post:
Db09ms3 (07-11-2018)
 Old 07-11-2018, 05:59 PM   #6
 
Db09ms3's Avatar
 
Join Date: Nov 2016
Location: AZ
Posts: 254   (View Stats)
iTrader: (0)
Rep Power: 0
Db09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond reputeDb09ms3 has a reputation beyond repute
Thanks: 313
Thanked 53 Times in 44 Posts
Groans: 58
Groaned at 4 Times in 4 Posts
Not Ranked  0 score     
Default

Ha!
Attached Images
File Type: png True.png (904.0 KB, 2 views)
__________________
Stockish
Db09ms3 is offline   Reply With Quote
 Old 07-12-2018, 01:52 PM   #7
 
Carskick's Avatar
 
Join Date: May 2016
Location: Sarastoa, FL
Posts: 260   (View Stats)
iTrader: (0)
Rep Power: 0
Carskick has a reputation beyond reputeCarskick has a reputation beyond reputeCarskick has a reputation beyond reputeCarskick has a reputation beyond reputeCarskick has a reputation beyond reputeCarskick has a reputation beyond reputeCarskick has a reputation beyond reputeCarskick has a reputation beyond reputeCarskick has a reputation beyond reputeCarskick has a reputation beyond reputeCarskick has a reputation beyond repute
Thanks: 110
Thanked 56 Times in 46 Posts
Groans: 1
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

Originally Posted by Guitarkidd View Post
Hello,

I have a 2011 with 90K. This morning was the first time I felt anything wrong with this car and its transmission. From a stop or near stop it appeared to be starting from 2nd gear, and then would down shift into 1st upon acceleration. Not hard down shift, but obviously not normal, and then the car would go through the gears normally with no issues. Only when I cam to a stop or a near stop would it stay in 2nd and then drop into 1st upon accelerating.

When I got to work the AT light eventually came on with no check engine light. There is a very respectable transmission shop within walking distance. When they opened I went to the car to drive it over. My car would not go into reverse but would still go into drive.

I pushed the car out of the parking spot and drove it to the transmission shop. The car went into reverse upon the initial test drive and the issues of shifting were present, but then at another point, the manager lost reverse during the test drive.

The manager was telling me that he believes from just driving it that something internal is wrong and I'm probably looking at a replacement and or rebuild. The manager is going to do some research on potential TSB, customer satisfaction programs from Mazda, etc., but I doubt there is anything he will find.

However, some research has shown that other Mazdas with the same or similar power trains have had the same issues and have only needed the TCM flashed or replaced.

This car has never shown any issues shifting. I am the original owner and have had all maintenance done too.

Thought and suggestions would be appreciated.
I'm no expert on Auto Trannies, so take this with a grain of salt...

If the transmission feels and operates normal except for it's shift logic, then I'd suspect a electronics/computer problem. Rough/Bad shifts are more indicative of a mechanical problem. Loosing reverse could be either...
__________________
2009 Mazdaspeed 3 Sport (Original Owner)
Current Performance Mods: APv3 Freektune 93 & E-30 | JBR 3.0 SRI | ETS TMIC, SpeedDaddy TP | AT HPFP | Damond RMM | Southbend S2 Endurance Clutch/Fly | Stoptech Slotted Rotors | EBC RedStuff Pads | Enkei 18x8.5 PF01 | Continental EC Sport 245/40R18 | Koni STR.T Shocks | JBR Shifter Bushings
Stereo Mods: Pioneer AVH4100NEX | Phoenix Gold Fronts | Focal Rears | Polk 12" in Trunk Floor Enclosure | PPI 4x125W amp driving Fronts & Sub
Other Mods: Low Note Additional Horn
Mods Awaitting Install: JBR TMIC Red Boost Tubes | DM OCC w/VTA
Future Mods:DM PMM & TMM | Injector Seals | Whiteline Suspension Bushings | Built Block & BNR S3v2 if ZZB
Removed Mods: JBR 70A RMM
Carskick is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trans shifting issues.... DareDevilMS6 MazdaSpeed 6 - Engine, Transmission & Driveline 17 08-18-2018 10:18 PM
strange trans shifting pattern ottoblotto CX-7 > Issues & Troubleshooting 5 02-18-2011 09:08 PM
Rough shifting & Slipping Transmission? Circas313 MazdaSpeed 6 - Engine, Transmission & Driveline 12 01-26-2011 01:28 PM
shifting problems.. loose trans mount on an 08? 08_ms3_gt MazdaSpeed 3 - Engine, Transmission & Driveline 41 04-08-2009 07:11 PM


All times are GMT -7. The time now is 02:42 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.28500 seconds with 24 queries