register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Troubleshoot/Diagnostics

MazdaSpeed 3/6 - Troubleshoot/Diagnostics MazdaSpeed 3/6 - Troubleshoot/Diagnostics - Have a problem with the car? CEL Code? Want to discuss other issues? Come on in!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 04-16-2014, 01:08 PM   #1
 
15driley15's Avatar
 
Join Date: Jan 2013
Location: St. Charles, MO
Posts: 184   (View Stats)
iTrader: (0)
Rep Power: 0
15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world
Thanks: 148
Thanked 156 Times in 35 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default Car cranks, won't start

2006 ms6 100% stock. 113k.

Went into a gas station a couple days ago, came back, car wouldn't start. Did some reading thought it was an electrical issue, jumped the neutral safety switch, and got the car to start/run for about 45 seconds. To my dismay, the car dies. I find that the connection I made was no good, attempt to quickly repair it, but the car never started again.

So i tow the damn thing to my house, and crawl back up under the dash and legitimately bypass the NSS so that I know it's good. (Car cranks without use of the clutch pedal now) ...but the car will not start. I just changed spark plugs today. Car is behaving the same.

My next suspicion is fuel pump? Anyone have a way to potentially test an hpfp?

I need this thing running and I'm pretty frustrated.
__________________
2006 Velocity Red Mica Mazdaspeed6 GT #04425

Stocked out and hella slow...
15driley15 is offline   Reply With Quote
 Old 04-17-2014, 10:13 AM   #2
 
15driley15's Avatar
 
Join Date: Jan 2013
Location: St. Charles, MO
Posts: 184   (View Stats)
iTrader: (0)
Rep Power: 0
15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world15driley15 is the leader of the world
Thanks: 148
Thanked 156 Times in 35 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

Bump... Really could use suggestions here
__________________
2006 Velocity Red Mica Mazdaspeed6 GT #04425

Stocked out and hella slow...
15driley15 is offline   Reply With Quote
 Old 04-17-2014, 10:32 AM   #3
 
Koke382's Avatar
 
Join Date: Feb 2012
Location: Anaheim, Orange County
Posts: 4,361   (View Stats)
iTrader: (1)
Rep Power: 0
Koke382 is the leader of the worldKoke382 is the leader of the worldKoke382 is the leader of the worldKoke382 is the leader of the worldKoke382 is the leader of the worldKoke382 is the leader of the worldKoke382 is the leader of the worldKoke382 is the leader of the worldKoke382 is the leader of the worldKoke382 is the leader of the worldKoke382 is the leader of the world
Thanks: 8,921
Thanked 3,322 Times in 1,859 Posts
Groans: 32
Groaned at 39 Times in 21 Posts
Not Ranked  0 score     
Default

Wish i could help, hope u get it sorted out bud

Sent from my LG-LS980 using Tapatalk
__________________
2007 Mazdaspeed 3 GT
18x8.75 XXR 527 225/40/18r
COBB AP// Finkles hypnotic sexyness 50/50 e85// HTP 3.5 Whale Penis// HTP 51R battery box// JBR Adjustable SSP//JBR 88 RMM// Grimspeed 3 port EBCS// CX Racing FMIC// CNT Racing catless DP// AT internals// Lamin-x Fog light inserts// Stiffy Ingals Mtourque Mount// Asian tower brace(lol)// CNT Racing Catback// Turbo XS RFL BOV VTA FTMFW!!// Upgrated clutch// Drilled and sloted rotors (font and back)// UNDER THE KNIFE

New fucken miata build:

1993 Red Na6
Some suspension modz yo

1994 Caste White MX5 Miata - sold

1991 Smurf Blue miata - sooooooold
Coilovers// Other shit

Koke382 is offline   Reply With Quote
 Old 04-17-2014, 01:38 PM   #4
 
Spec's Avatar
 
Join Date: Aug 2012
Location: Houston, TX
Posts: 4,472   (View Stats)
iTrader: (4)
Rep Power: 0
Spec is the leader of the worldSpec is the leader of the worldSpec is the leader of the worldSpec is the leader of the worldSpec is the leader of the worldSpec is the leader of the worldSpec is the leader of the worldSpec is the leader of the worldSpec is the leader of the worldSpec is the leader of the worldSpec is the leader of the world
Thanks: 1,823
Thanked 4,945 Times in 2,142 Posts
Groans: 0
Groaned at 35 Times in 30 Posts
Not Ranked  0 score     
Default

Well, it's going to be spark, fuel, air. Fine out which one you don't have. You mentioned you changed your plugs. See if they're hitting.
__________________
Spec is offline   Reply With Quote
 Old 04-17-2014, 02:03 PM   #5
 
ihasmazda's Avatar
 
Join Date: Sep 2013
Location: Seattle WA
Posts: 1,011   (View Stats)
iTrader: (1)
Rep Power: 0
ihasmazda is the leader of the worldihasmazda is the leader of the worldihasmazda is the leader of the worldihasmazda is the leader of the worldihasmazda is the leader of the worldihasmazda is the leader of the worldihasmazda is the leader of the worldihasmazda is the leader of the worldihasmazda is the leader of the worldihasmazda is the leader of the worldihasmazda is the leader of the world
Thanks: 101
Thanked 372 Times in 211 Posts
Groans: 2
Groaned at 4 Times in 4 Posts
Not Ranked  0 score     
Default

what are the odds that it could be the in-tank fuel pump? i never hear about problems with them on these cars though, I'm just throwing something out there...

keep us posted on this, always good to know about issues and the resolution...
__________________
2007 Mazdaspeed 6 GT
2003 Ford Ranger XLT
ihasmazda is offline   Reply With Quote
 Old 04-19-2014, 07:57 AM   #6
 
CW42's Avatar
 
Join Date: Dec 2011
Location: Dartmouth, N.S., Canada
Posts: 216   (View Stats)
iTrader: (0)
Rep Power: 0
CW42 has a brilliant futureCW42 has a brilliant futureCW42 has a brilliant futureCW42 has a brilliant futureCW42 has a brilliant futureCW42 has a brilliant futureCW42 has a brilliant futureCW42 has a brilliant futureCW42 has a brilliant futureCW42 has a brilliant futureCW42 has a brilliant future
Thanks: 1
Thanked 37 Times in 23 Posts
Groans: 0
Groaned at 13 Times in 6 Posts
Not Ranked  0 score     
Default

I assume your lights and dash light up and you hear the various start up electrical noises? The same thing you're describing happened to me last week and it was the white wire that connects to the starter. This happens a lot from what I've read in here. It's the first thing I thought of when my car wouldn't start and that's exactly what it was. I'm not sure if it happens a lot on the 6 or not. It might be worth checking.
CW42 is offline   Reply With Quote
 Old 04-23-2014, 02:24 PM   #7
Daily Driver

 
Nitr0EngiE's Avatar
 
Join Date: Dec 2008
Location: Tampa, Fl
Posts: 2,614   (View Stats)
iTrader: (9)
Rep Power: 863
Nitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the world
Thanks: 576
Thanked 1,427 Times in 757 Posts
Groans: 52
Groaned at 82 Times in 51 Posts
Not Ranked  0 score     
Default

Originally Posted by CW42 View Post
I assume your lights and dash light up and you hear the various start up electrical noises? The same thing you're describing happened to me last week and it was the white wire that connects to the starter. This happens a lot from what I've read in here. It's the first thing I thought of when my car wouldn't start and that's exactly what it was. I'm not sure if it happens a lot on the 6 or not. It might be worth checking.
that starter remote wire does like to come lose i ended up zip tying that wire to the harness to make sure it stays on the starter, next time i get IM off i will replace the spade connector on the wire to one that holds stronger

you really need to get with someone who has an AP and check fuel pressure and see if there are any silent check engine lights hidden without triggering the light
Nitr0EngiE is offline   Reply With Quote
 Old 04-23-2014, 03:25 PM   #8
 
aviator79's Avatar
 
Join Date: Mar 2008
Location: W. Suffield, CT
Posts: 3,919   (View Stats)
iTrader: (11)
Rep Power: 0
aviator79 is the leader of the worldaviator79 is the leader of the worldaviator79 is the leader of the worldaviator79 is the leader of the worldaviator79 is the leader of the worldaviator79 is the leader of the worldaviator79 is the leader of the worldaviator79 is the leader of the worldaviator79 is the leader of the worldaviator79 is the leader of the worldaviator79 is the leader of the world
Thanks: 666
Thanked 1,695 Times in 1,061 Posts
Groans: 67
Groaned at 17 Times in 12 Posts
Not Ranked  0 score     
Default

From what he is saying the starter is turning but the car wont start. Listen for fuel pump under rear seat driver side. Take rear seat bottom out if have to, should be able to hear it. report back if you hear it or not.
__________________
MS6 - BNRs3 - Cobb AP - JBR Tru-3.0 - Spearco FMIC - MAC EBCS - Synapse BOV - DNP - CPE DP->MF - SU RRM - TTFMM - TT + CPE Diff Mounts - Mrlilguy HPFP - Projector HID fogs - TSX projector retrofit - LI jammers - Advan RZs w/ 245 PSSs - Koni - WL RSB
aviator79 is offline   Reply With Quote
 Old 04-23-2014, 04:51 PM   #9
 
Donut's Avatar
 
Join Date: Feb 2013
Location: Auckland, New Zealand
Posts: 131   (View Stats)
iTrader: (0)
Rep Power: 0
Donut is the leader of the worldDonut is the leader of the worldDonut is the leader of the worldDonut is the leader of the worldDonut is the leader of the worldDonut is the leader of the worldDonut is the leader of the worldDonut is the leader of the worldDonut is the leader of the worldDonut is the leader of the worldDonut is the leader of the world
Thanks: 217
Thanked 105 Times in 46 Posts
Groans: 11
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Yes try to listen for the fuel pump noise:
Check the fuse of fuel pump too, had a similiar problem with my RX-8 previously. Once I have replaced the fuse there has been no more issues.
__________________

2004 Mazda RX8 - Bone Stock - SOLD
2010 Mazda 3 MPS

K&N SRI | GFB BPV | Cobb TIH | Cobb AP v3 - Freektuned |CS Internals|OBX Cat Back + Test Pipe | JBR 70a RMM | JBR RSB|JBR EGR block off plate|JBR SSP + Solid Bushings |Denso ITV 22| Ultra Racing Front Strut Bar| Ultra Racing Rear Strut Bar | Bridgestone RE002 225/40/R18 Tyres|CS Brake Pads|H&R Lowering Springs| DBA T3 Slotted Rotors |Goodridge SS Braided Brake Lines
Non performance parts: 35% Tint | Blacked Emblems | Painted Wheels |JBR Heavy Shift Knob | CS Tow Plate |

[SIGPIC][/SIGPIC]
Donut is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ms6 cranks but wont start maniospeed6 Mazdaspeed3/6 General Discussion 4 03-26-2013 09:08 PM
Car cranks but doesn't start after valve clean InfamousSpeed6 Mazdaspeed3/6 General Discussion 11 11-29-2012 06:17 PM
GM cranks up no-frills car output in China Haltech Automotive News 0 11-18-2012 06:50 AM
Coda cranks up battery-car sales after California 'soft' start Haltech Automotive News 0 09-12-2012 11:40 AM
Toyota cranks up N.A. output Haltech Automotive News 0 08-12-2012 10:10 PM


All times are GMT -7. The time now is 05:42 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.29239 seconds with 27 queries