register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Troubleshoot/Diagnostics

MazdaSpeed 3/6 - Troubleshoot/Diagnostics MazdaSpeed 3/6 - Troubleshoot/Diagnostics - Have a problem with the car? CEL Code? Want to discuss other issues? Come on in!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Like Tree2Likes
  • 1 Post By WetzMS3
  • 1 Post By WetzMS3
Closed Thread
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 08-30-2015, 07:35 PM   #1
 
Jaxon's Avatar
 
Join Date: Oct 2014
Location: Vancouver
Posts: 31   (View Stats)
iTrader: (0)
Rep Power: 0
Jaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to behold
Thanks: 1
Thanked 15 Times in 9 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default cylinder misfires and KR

07 ms3
cobb fmic
autotech internals
cs turbo back catless
cs turbo inlet and 3' intake
forge bpv v2
damon motorsports occ
denso itv22
91 tune

plugs gapped to .028

I am experience a very high kr. Yesterday I did a 3-5 pull and got a misfire cylinder 1. I got home and pulled my plugs and they seemed to be alright.

Today I did a pull and experienced multiple cylinder misfires with high kr and a fucked up spark plug.

Now I am thinking injector seals, injectors, coils, timing chain? I am not too experienced with this and would like some help. Thank you

compression test reads 170-170-178-175

Attached Files
File Type: csv datalog4.csv (6.6 KB, 1 views)
__________________
zoom.

Last edited by Jaxon; 08-30-2015 at 08:43 PM.
Jaxon is offline  
 Old 09-02-2015, 01:48 PM   #2
 
Jaxon's Avatar
 
Join Date: Oct 2014
Location: Vancouver
Posts: 31   (View Stats)
iTrader: (0)
Rep Power: 0
Jaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to behold
Thanks: 1
Thanked 15 Times in 9 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

I put fresh plugs in, got a cyl 2 misfire.

I am having a ton of knock and ill post another log.
Attached Files
File Type: csv datalog6.csv (9.1 KB, 6 views)
__________________
zoom.
Jaxon is offline  
 Old 09-02-2015, 02:22 PM   #3
 
WetzMS3's Avatar
 
Join Date: Jul 2013
Location: Westchester, IL
Posts: 5,772   (View Stats)
iTrader: (0)
Rep Power: 4904
WetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the world
Thanks: 14,635
Thanked 9,203 Times in 3,608 Posts
Groans: 430
Groaned at 247 Times in 83 Posts
Not Ranked  0 score     
Default

Is this on the same tank of fuel or separate fill ups?

Have you verified mechanical timing to see if it possibly slipped?

Is the timing chain making odd sounds or feel loose?

A leakdown test could rule out or point to injector seals.
monkey.bones.007 likes this.
__________________
2013 MS3 Black Mica
SLUGGISH RUGGISH BONE

SLUNTWORKS SPEEDSHOP
WetzMS3 is offline  
 Old 09-02-2015, 02:49 PM   #4
 
aeMS3's Avatar
 
Join Date: Sep 2013
Location: Phoenix, Arizona
Posts: 33   (View Stats)
iTrader: (0)
Rep Power: 0
aeMS3 is a splendid one to beholdaeMS3 is a splendid one to beholdaeMS3 is a splendid one to beholdaeMS3 is a splendid one to beholdaeMS3 is a splendid one to beholdaeMS3 is a splendid one to behold
Thanks: 7
Thanked 13 Times in 11 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Check for vacuum leaks, clean maf sensor, stretch coil springs by hand, I think I've also read that the egr could cause this as well so might want to pull out and clean. Swap ignition coil from cylinder 2 with another and see if code follows
__________________
V-Dyno: 303WHP 353WTQ FREEKTUNE
Autotech: HPFP Internals
Cobb: V3 AP
Corksport: Stage 2 SRI, TIH, Eyelids
CP-E: 75 Duro RMM, TMIC
Forge: BPV
H&R: Lowering Springs
JBR: Stage 2 OCC, SSP, Counter Weight, Bushings, BPV Hose, Camber arms
NGK: One Step Colder Spark Plugs
OBX: Catless Turbo Back Exhaust
Torque Solution: EGR Delete Kit
Miro: 398 18x8.5 +35
Michelin: Pilot Super Sport 255/35r18
aeMS3 is offline  
 Old 09-02-2015, 05:44 PM   #5
 
Jaxon's Avatar
 
Join Date: Oct 2014
Location: Vancouver
Posts: 31   (View Stats)
iTrader: (0)
Rep Power: 0
Jaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to behold
Thanks: 1
Thanked 15 Times in 9 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

My vacuum is consistent at -9 at idle would that rule out a vacuum leak?
Timing chain isn't making any weird noises and doesn't feel abnormally lose, just a tad bit of play which I am assuming is normal?

I cleaned maf sensor and I am going to stretch coil springs this evening. Its pouring rain so I cant really do a proper run yet.
__________________
zoom.
Jaxon is offline  
 Old 09-02-2015, 06:59 PM   #6
 
WetzMS3's Avatar
 
Join Date: Jul 2013
Location: Westchester, IL
Posts: 5,772   (View Stats)
iTrader: (0)
Rep Power: 4904
WetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the worldWetzMS3 is the leader of the world
Thanks: 14,635
Thanked 9,203 Times in 3,608 Posts
Groans: 430
Groaned at 247 Times in 83 Posts
Not Ranked  0 score     
Default

Originally Posted by Jaxon View Post
My vacuum is consistent at -9 at idle would that rule out a vacuum leak?
Timing chain isn't making any weird noises and doesn't feel abnormally lose, just a tad bit of play which I am assuming is normal?

I cleaned maf sensor and I am going to stretch coil springs this evening. Its pouring rain so I cant really do a proper run yet.
Is it a stock motor? What's you pcv setup?

On a stock block, OEM pcv to catch can, that's low vacuum.

Sent from my XT1254 using Tapatalk
monkey.bones.007 likes this.
__________________
2013 MS3 Black Mica
SLUGGISH RUGGISH BONE

SLUNTWORKS SPEEDSHOP

Last edited by WetzMS3; 09-03-2015 at 06:05 AM.
WetzMS3 is offline  
 Old 09-03-2015, 05:41 PM   #7
 
Jaxon's Avatar
 
Join Date: Oct 2014
Location: Vancouver
Posts: 31   (View Stats)
iTrader: (0)
Rep Power: 0
Jaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to beholdJaxon is a splendid one to behold
Thanks: 1
Thanked 15 Times in 9 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Originally Posted by WetzMS3 View Post
Is it a stock motor? What's you pcv setup?

On a stock block, OEM pcv to catch can, that's low vacuum.

Sent from my XT1254 using Tapatalk
Yep stock motor.

catch can was installed before I bought the car, I am assuming its a stock pcv. to the dm cc.
__________________
zoom.
Jaxon is offline  
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL during road trip, random cylinder misfires? AveryPlaysBass 2010 MS3 - Engine, Transmission & Driveline 0 10-06-2014 09:06 AM
MS6 P0302 CEL, other misfires, stuttering. SirChodesly MazdaSpeed 3/6 - Troubleshoot/Diagnostics 16 08-28-2014 11:28 AM
P0300 Random / Multiple Cylinder Misfires txmedic83 CX-7 > Issues & Troubleshooting 9 08-13-2013 12:45 PM
How Toyota misfires with Chinese buyers Haltech Automotive News 0 11-04-2012 06:10 AM
multiple misfires detected after sea foam McKinley MazdaSpeed 3 - Engine, Transmission & Driveline 26 03-08-2012 07:55 AM


All times are GMT -7. The time now is 06:14 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.27702 seconds with 23 queries