register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Troubleshoot/Diagnostics

MazdaSpeed 3/6 - Troubleshoot/Diagnostics MazdaSpeed 3/6 - Troubleshoot/Diagnostics - Have a problem with the car? CEL Code? Want to discuss other issues? Come on in!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Like Tree1Likes
  • 1 Post By Djohns
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 09-13-2017, 06:13 PM   #1
 
Snyderg999's Avatar
 
Join Date: Sep 2017
Location: Near Pittsburgh
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
Snyderg999 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default Many Problems

Hello, i am new here and haven't ever posted but I also couldn't find a thread related to ALLL of the problems i am having presently. Currently my fog lights are not working, my Abs and TSC lights are constantly on, and the push butten start doesnt turn the car off like it should, it goes straight to ACC. Mode and i have to overide it. I have taken my vehicle to the dealership yesterday and they said that my rear shocks are bad and need replaced but otherwise couldn't figure out why the push button was acting like it was or why the abs and tsc was on. I am going back in about a week to have my shocks replaced and will ask again to have the abs scanned because i dont beleive they did so the first time but evem then i do not understand why the pish button or fog lights are acting up also. I also have checked all of the fuses and relays with no luck of finding an issue and i also cleaned all of the wheel speed sensors/abs sensors but also do mot know where to find any grounding wires to check them. If anyone has any ideas to check before i take it back, it would be much appriciated.
Snyderg999 is offline   Reply With Quote
 Old 09-13-2017, 06:20 PM   #2
 
Djohns's Avatar
 
Join Date: Dec 2013
Location: Plainfield, IL
Posts: 3,690   (View Stats)
iTrader: (3)
Rep Power: 1278
Djohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the world
Thanks: 1,662
Thanked 2,389 Times in 1,289 Posts
Groans: 99
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

Sounds to me like you may have a short somewhere. Did it randomly start doing this?
Oli likes this.
__________________
2010 black mica speed3
The go: Depo racing: downpipe (100 cell count), custom: FMIC. HTP: 3.5" intake, under route piping. JBR: shortshifter, RSB. Autotech: HPFP internals. Go fast bits: hybrid BPV, VMR: 18x8.5 V710s, Bridgestone: potenza re760 245/40/18, KW: v3 coilovers,SPC: camber arms, freektuned, Damond Motorsports: dual OCC, PMM, PCV plate, RMM, TMM, EGR delete, FoSt mani, Corksport: battery box(fuck this thing), injector seals, Cobb: EBCS, AP v3. AEM: methanol. Seibon: carbon fiber hood. UR: catback. Bosch: 3bar. BNR: s4, DNP: EWG manifold, Tial: 38mm mvs EWG.

The show: 5% tint all around, 50% tint windshield, rally armor mudflaps, Sony XAV64BT touchscreen headunit, katskin leather interior, CPE relocation plate, Maisonvi weighted shift knob, Corksport hoodscoop, black housing headlights.

Soon:built motor
Djohns is offline   Reply With Quote
 Old 09-13-2017, 06:25 PM   #3
 
Snyderg999's Avatar
 
Join Date: Sep 2017
Location: Near Pittsburgh
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
Snyderg999 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Yes, a couple months ago driving through the city. I do mot recal hitting any bumps or anything to ajar a semsor or amything of the sort when it happened thoough. Yet since then it has been a constant thing. I have also tried disconnecting the battery a handful of time to reset the sensors but to no avail.
Snyderg999 is offline   Reply With Quote
 Old 09-13-2017, 09:35 PM   #4
 
Djohns's Avatar
 
Join Date: Dec 2013
Location: Plainfield, IL
Posts: 3,690   (View Stats)
iTrader: (3)
Rep Power: 1278
Djohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the world
Thanks: 1,662
Thanked 2,389 Times in 1,289 Posts
Groans: 99
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

Paint a picture for me. It may help figure it out. Was it raining? Cold or hot day? In traffic? Was the car hot?
__________________
2010 black mica speed3
The go: Depo racing: downpipe (100 cell count), custom: FMIC. HTP: 3.5" intake, under route piping. JBR: shortshifter, RSB. Autotech: HPFP internals. Go fast bits: hybrid BPV, VMR: 18x8.5 V710s, Bridgestone: potenza re760 245/40/18, KW: v3 coilovers,SPC: camber arms, freektuned, Damond Motorsports: dual OCC, PMM, PCV plate, RMM, TMM, EGR delete, FoSt mani, Corksport: battery box(fuck this thing), injector seals, Cobb: EBCS, AP v3. AEM: methanol. Seibon: carbon fiber hood. UR: catback. Bosch: 3bar. BNR: s4, DNP: EWG manifold, Tial: 38mm mvs EWG.

The show: 5% tint all around, 50% tint windshield, rally armor mudflaps, Sony XAV64BT touchscreen headunit, katskin leather interior, CPE relocation plate, Maisonvi weighted shift knob, Corksport hoodscoop, black housing headlights.

Soon:built motor
Djohns is offline   Reply With Quote
 Old 09-14-2017, 03:11 AM   #5
 
Snyderg999's Avatar
 
Join Date: Sep 2017
Location: Near Pittsburgh
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
Snyderg999 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Around 70 degrees i would say, partly cloudy, not too much traffic, andthere was a slight breeze. I do not recall how het the car was though but i cant imagine it being too bad for the weather around it.
Snyderg999 is offline   Reply With Quote
 Old 09-14-2017, 08:33 AM   #6
 
Djohns's Avatar
 
Join Date: Dec 2013
Location: Plainfield, IL
Posts: 3,690   (View Stats)
iTrader: (3)
Rep Power: 1278
Djohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the world
Thanks: 1,662
Thanked 2,389 Times in 1,289 Posts
Groans: 99
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

Hm. Strange, it's not harsh conditions. I definitely still think you have a short somewhere that needs to be fixed.
__________________
2010 black mica speed3
The go: Depo racing: downpipe (100 cell count), custom: FMIC. HTP: 3.5" intake, under route piping. JBR: shortshifter, RSB. Autotech: HPFP internals. Go fast bits: hybrid BPV, VMR: 18x8.5 V710s, Bridgestone: potenza re760 245/40/18, KW: v3 coilovers,SPC: camber arms, freektuned, Damond Motorsports: dual OCC, PMM, PCV plate, RMM, TMM, EGR delete, FoSt mani, Corksport: battery box(fuck this thing), injector seals, Cobb: EBCS, AP v3. AEM: methanol. Seibon: carbon fiber hood. UR: catback. Bosch: 3bar. BNR: s4, DNP: EWG manifold, Tial: 38mm mvs EWG.

The show: 5% tint all around, 50% tint windshield, rally armor mudflaps, Sony XAV64BT touchscreen headunit, katskin leather interior, CPE relocation plate, Maisonvi weighted shift knob, Corksport hoodscoop, black housing headlights.

Soon:built motor
Djohns is offline   Reply With Quote
 Old 09-14-2017, 04:50 PM   #7
 
Snyderg999's Avatar
 
Join Date: Sep 2017
Location: Near Pittsburgh
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
Snyderg999 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Wpuld you happen to know where the grounding wires are located so i could check? Im unable to find anything about them anywhere
Snyderg999 is offline   Reply With Quote
 Old 09-14-2017, 04:51 PM   #8
 
Djohns's Avatar
 
Join Date: Dec 2013
Location: Plainfield, IL
Posts: 3,690   (View Stats)
iTrader: (3)
Rep Power: 1278
Djohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the world
Thanks: 1,662
Thanked 2,389 Times in 1,289 Posts
Groans: 99
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

I'll have to look when I'm out of class. There's a wiring diagram on here somewhere.
__________________
2010 black mica speed3
The go: Depo racing: downpipe (100 cell count), custom: FMIC. HTP: 3.5" intake, under route piping. JBR: shortshifter, RSB. Autotech: HPFP internals. Go fast bits: hybrid BPV, VMR: 18x8.5 V710s, Bridgestone: potenza re760 245/40/18, KW: v3 coilovers,SPC: camber arms, freektuned, Damond Motorsports: dual OCC, PMM, PCV plate, RMM, TMM, EGR delete, FoSt mani, Corksport: battery box(fuck this thing), injector seals, Cobb: EBCS, AP v3. AEM: methanol. Seibon: carbon fiber hood. UR: catback. Bosch: 3bar. BNR: s4, DNP: EWG manifold, Tial: 38mm mvs EWG.

The show: 5% tint all around, 50% tint windshield, rally armor mudflaps, Sony XAV64BT touchscreen headunit, katskin leather interior, CPE relocation plate, Maisonvi weighted shift knob, Corksport hoodscoop, black housing headlights.

Soon:built motor
Djohns is offline   Reply With Quote
 Old 09-14-2017, 05:55 PM   #9
 
Snyderg999's Avatar
 
Join Date: Sep 2017
Location: Near Pittsburgh
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
Snyderg999 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Thank you, anything at this point is appariciated.
Snyderg999 is offline   Reply With Quote
 Old 09-28-2017, 02:25 PM   #10
 
Djohns's Avatar
 
Join Date: Dec 2013
Location: Plainfield, IL
Posts: 3,690   (View Stats)
iTrader: (3)
Rep Power: 1278
Djohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the world
Thanks: 1,662
Thanked 2,389 Times in 1,289 Posts
Groans: 99
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

Did you ever get this figured out? I can't seem to find the wiring diagram on the forum, I'll have to check my computer when I get time.
__________________
2010 black mica speed3
The go: Depo racing: downpipe (100 cell count), custom: FMIC. HTP: 3.5" intake, under route piping. JBR: shortshifter, RSB. Autotech: HPFP internals. Go fast bits: hybrid BPV, VMR: 18x8.5 V710s, Bridgestone: potenza re760 245/40/18, KW: v3 coilovers,SPC: camber arms, freektuned, Damond Motorsports: dual OCC, PMM, PCV plate, RMM, TMM, EGR delete, FoSt mani, Corksport: battery box(fuck this thing), injector seals, Cobb: EBCS, AP v3. AEM: methanol. Seibon: carbon fiber hood. UR: catback. Bosch: 3bar. BNR: s4, DNP: EWG manifold, Tial: 38mm mvs EWG.

The show: 5% tint all around, 50% tint windshield, rally armor mudflaps, Sony XAV64BT touchscreen headunit, katskin leather interior, CPE relocation plate, Maisonvi weighted shift knob, Corksport hoodscoop, black housing headlights.

Soon:built motor
Djohns is offline   Reply With Quote
 Old 09-28-2017, 05:19 PM   #11
 
Snyderg999's Avatar
 
Join Date: Sep 2017
Location: Near Pittsburgh
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
Snyderg999 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Actually just yesterday i had figured everything out. I had taken it to the dealership a total of 4 times. 1st they gave me b.s. that my bad shocks were causing the abs light. When i went back after posting on this forum i asked for them to read the abs light because they didnt the first time and to check all of the grounds for shorts. Then i bought a service/repair manual which confirmed it was eitger short or one of tge sensors. When i picked it back up they told me my right rear abs sensor wasnt reading and that all of the wires were fine, didnt beleive them but i went to change it out myself and i found that the ground wire going into the conection that plugs into the sensor was completely torn out and was unrepairable. I took it back in a third time to see what they could do and just confirmed that they must have not checked all of the wires and couldnt find a connector. I ended up having to buy one to replace it and took it back in so they could handle it. After the repair the lighta had gone away tland the ignition is completely fine. Only thing wrong now is that my fog lights are not working still, but im starting with replacing my relay to see if it had just gone bad.
Snyderg999 is offline   Reply With Quote
 Old 09-28-2017, 07:24 PM   #12
 
5doorsoffury's Avatar
 
Join Date: Feb 2012
Location: bethpage ny
Posts: 871   (View Stats)
iTrader: (1)
Rep Power: 325
5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world
Thanks: 1,264
Thanked 493 Times in 269 Posts
Groans: 67
Groaned at 4 Times in 3 Posts
Not Ranked  0 score     
Default

Originally Posted by Snyderg999 View Post
Actually just yesterday i had figured everything out. I had taken it to the dealership a total of 4 times. 1st they gave me b.s. that my bad shocks were causing the abs light. When i went back after posting on this forum i asked for them to read the abs light because they didnt the first time and to check all of the grounds for shorts. Then i bought a service/repair manual which confirmed it was eitger short or one of tge sensors. When i picked it back up they told me my right rear abs sensor wasnt reading and that all of the wires were fine, didnt beleive them but i went to change it out myself and i found that the ground wire going into the conection that plugs into the sensor was completely torn out and was unrepairable. I took it back in a third time to see what they could do and just confirmed that they must have not checked all of the wires and couldnt find a connector. I ended up having to buy one to replace it and took it back in so they could handle it. After the repair the lighta had gone away tland the ignition is completely fine. Only thing wrong now is that my fog lights are not working still, but im starting with replacing my relay to see if it had just gone bad.
Sounds like that shop dosent know there thumb from there ass hole.
__________________
MECP
2012 BM
PTE 5858 Vband .82ar // Tial EWG // CPE Mani // 3" Turboback // JBR Under route hot pipe // MD ST mani+spacer with PI // Siemens 60lb Injectors // Splitsecond inj controller // JBR 88 duro RMM/TMM // MD PMM // TWM Full replacement shifter // JBR CC // Autotech FP Internals // SP63 SB/Manley rods SP63 pro pistons // Treadstone FMIC TR824 // FoMoCo Tranny Jizz // South Bend Clutch Stage 3 enduro// GFB Respons // FJ 4" intake // WMI 100% VPM1// Air Lift 1000 in rear
Rfinkle tune in progress

The Brooklyn beater: 2005 1.8 Auto Sentra

5doorsoffury is offline   Reply With Quote
 Old 09-28-2017, 07:39 PM   #13
 
Snyderg999's Avatar
 
Join Date: Sep 2017
Location: Near Pittsburgh
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
Snyderg999 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

No Kidding. Scary part is that was an actual mazda dealership service department dping all of the work.
Snyderg999 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Official: Fisker Q&A sheds light, lots of light, on Karma problems, lots of Karma problems Haltech Automotive News 0 08-23-2012 02:50 PM
AC problems~! LiEast MazdaSpeed 3 - Engine, Transmission & Driveline 0 06-09-2011 04:37 PM
AC problems help! LiEast MazdaSpeed 3/6 - Troubleshoot/Diagnostics 6 05-24-2011 07:55 PM
will these fit my car with no problems?? 18psiWhiteMS3 MazdaSpeed 3/6 - Wheels & Tires 5 06-11-2009 05:09 PM


All times are GMT -7. The time now is 05:18 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2014 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.32890 seconds with 22 queries