register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Troubleshoot/Diagnostics

MazdaSpeed 3/6 - Troubleshoot/Diagnostics MazdaSpeed 3/6 - Troubleshoot/Diagnostics - Have a problem with the car? CEL Code? Want to discuss other issues? Come on in!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 06-08-2018, 11:26 PM   #1
 
bkxtrakrisspy's Avatar
 
Join Date: Apr 2011
Location: Las Vegas
Posts: 6   (View Stats)
iTrader: (0)
Rep Power: 0
bkxtrakrisspy is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default MS6 replacement ac compressor issue

Short story, had a leak in the system. High pressure line was replaced and not 20 minutes after picking the car up the AC compressor gives it up. (This was like 2 weeks ago) Drop it off at another shop that my buddy owns, they replaced the entire ac compressor, drove it another 15 minutes, parked the car and i don't start it up again for 4-5 hours. Come back and ac is hot again, compressor doesn't kick on nor do the fans turn on. I swapped a relay and checked fuses but they all seem ok. Of course there is no pressure in the lines because nothing is kicking on. Ideas????

I've searched but I can't find anything like this, even tho I'm sure it's happened before.
bkxtrakrisspy is offline   Reply With Quote
 Old 06-09-2018, 06:09 AM   #2
 
kTaLgsTo's Avatar
 
Join Date: Dec 2017
Location: Idaho
Posts: 566   (View Stats)
iTrader: (0)
Rep Power: 121
kTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the world
Thanks: 84
Thanked 213 Times in 146 Posts
Groans: 10
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

have you had they system pressure tested again?
__________________
2011 MS3 Tech - 2008 Jeep Grand Cherokee CRD - 1989 Crown Vic LTD LX - 1985 Lincoln Town Car Signature
The key to happiness is owning a car ridiculously slower than your 'fast' car.
kTaLgsTo is offline   Reply With Quote
 Old 06-11-2018, 05:22 PM   #3
 
bkxtrakrisspy's Avatar
 
Join Date: Apr 2011
Location: Las Vegas
Posts: 6   (View Stats)
iTrader: (0)
Rep Power: 0
bkxtrakrisspy is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Update

So took it to the shop this morning and it was a bad O-Ring on one of the hoses leading to the compressor. Replaced, recharged and good to go!
bkxtrakrisspy is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HOW-TO: MS6 A/C Compressor Clutch & Bearing Replacement GroceryGtr MazdaSpeed 6 - How-To's 14 10-11-2018 09:26 AM
Yet another A/C compressor issue Inzane81 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 8 08-03-2016 01:25 PM
AC Compressor Replacement robander3 Mazdaspeed3/6 General Discussion 24 10-23-2014 01:46 PM
2008 mazdaspeed 3 AC compressor replacement notoriousdoa MazdaSpeed 3/6 - Troubleshoot/Diagnostics 2 07-06-2012 03:38 PM
Lucked out with A/C compressor replacement! btstarcher Mazdaspeed3/6 General Discussion 4 06-20-2012 08:26 PM


All times are GMT -7. The time now is 12:16 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.23657 seconds with 21 queries