register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Troubleshoot/Diagnostics

MazdaSpeed 3/6 - Troubleshoot/Diagnostics MazdaSpeed 3/6 - Troubleshoot/Diagnostics - Have a problem with the car? CEL Code? Want to discuss other issues? Come on in!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Like Tree1Likes
  • 1 Post By ThomasSpeed3
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 12-28-2013, 07:22 PM   #1
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default Rough idle/Vacuum issues

Ok so a few weeks ago my check engine light came on. I hooked up the AP read the code and it was a random misfire code P0300. I checked my coil packs, replaced spark plugs, and cleared code. couple days later it was back, only now when i start my car it hesitates, as well as idles rough at around 700 rpm. As i continue to monitor things i noticed that my vacuum was way off. at idle im at ~ -8 and i know the normal vac at idle should be around -22 or so. I've done all the checks for a vacuum leak, did a compression test, checked my crank position censor, cleaned my TB, checked my stock EBCS. i have not checked the purge valve yet, im not sure if that would be an issue.

mods: cobb SRI, cobb TIP, cobb BPV, was on cobb ots stage 1 93, now back on stage 0, until i get this figured out.

I have read the few threads i could find on similar problems but none of the solutions given seem to help.
ThomasSpeed3 is offline   Reply With Quote
 Old 12-28-2013, 09:53 PM   #2
 
rolanblack's Avatar
 
Join Date: Apr 2012
Location: irving,tx
Posts: 2,110   (View Stats)
iTrader: (5)
Rep Power: 0
rolanblack is the leader of the worldrolanblack is the leader of the worldrolanblack is the leader of the worldrolanblack is the leader of the worldrolanblack is the leader of the worldrolanblack is the leader of the worldrolanblack is the leader of the worldrolanblack is the leader of the worldrolanblack is the leader of the worldrolanblack is the leader of the worldrolanblack is the leader of the world
Thanks: 161
Thanked 881 Times in 626 Posts
Groans: 25
Groaned at 16 Times in 15 Posts
Not Ranked  0 score     
Default

might want to make sure your Air mass sensor is clean and placed flat. take a look at your spark plugs and make sure they are gapped properly. make sure your BPV is flush with the gasket it came with
rolanblack is offline   Reply With Quote
 Old 12-29-2013, 12:11 AM   #3
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

spark plugs are gapped to specs, checked the all the sensors today that would cause any sort of problems like this, and BPV is flat and flush. @rolanblack;

also have checked with carb cleaner for any leaks, even sprayed around the IM to check that gasket. me and @ccspeed3; have been trying to diagnose for 2 days now and still cant seem to get any sort of result or new information on where the leak could potentially be.
ThomasSpeed3 is offline   Reply With Quote
 Old 12-29-2013, 01:00 AM   #4
 
mituc's Avatar
 
Join Date: Mar 2009
Location: Iasi/Romania
Posts: 3,470   (View Stats)
iTrader: (0)
Rep Power: 1202
mituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the world
Thanks: 1,273
Thanked 2,107 Times in 1,215 Posts
Groans: 111
Groaned at 17 Times in 14 Posts
Not Ranked  0 score     
Default

Is your car using any oil? Did you take a picture of the spark plugs before you threw them?
__________________
2008 Cosmic Blue Mazda 3MPS
Bilstein B12 + CS Camber plates + Eibach camber arms, SSR Type-F, Michelin PS4 225/40/R18, Cobb RMM, StopTech Street Pads + Stoptech Slotted disks, SouthBend Enduro Stage3 clutch, genpu TMM + CS Insert, TheSpeedLine 2X Rear Cross Floor and Rear Middle Lower Strut bars, Tanabe 4 Point Under Brace, Whiteline Bumpsteeer corection kit
JBR Tru-3" + CS CAI Box, SU TMIC, Cobb XLE, NGK LTR7IX, UR v3 catted DP and res&catted TP, Cobb CatBack, GS EBCS, Autotech internals, GTX3071, CS 3.5BAR, Guardian Angel, CoolingMist WMI, VCTS Delete, stock ported IM
SP63 87.5mm 4032 9.5:1 pistons, Manley rods, CA625+ head studs, Clevite AL main bearings, King rod bearings, CP-e safe seals, DCR VVT, Koyorad radiator.
StratiVersaTuned FTW to 28PSI, self-tuned to 32PSI

2008 Icy Blue Mazda CX7 6 Speed Manual
SU TMIC, Autotech HPFP internals, Cobb XLE, Cobb EBCS
GTX2867R gen2, stock spark plugs, stock intake, stock cats and stock exhaust FTW
self-Versatuned to 22PSI

Last edited by mituc; 12-29-2013 at 02:51 AM.
mituc is offline   Reply With Quote
The Following User Says Thank You to mituc For This Useful Post:
rfinkle2 (12-29-2013)
 Old 12-29-2013, 01:55 PM   #5
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

i will upload picture of plugs when i get to my house, on my laptop right now. and oil seems to be ok, no signs of excessive use or loss of oil. ok on dipstick and oil pressure is normal. and i now seem to have a boost leak as well, car was holding boost at first but now has reduced about 5psi. @mituc;
tapatalk likes this.
ThomasSpeed3 is offline   Reply With Quote
The Following User Says Thank You to ThomasSpeed3 For This Useful Post:
tapatalk (12-30-2013)
 Old 12-29-2013, 02:10 PM   #6
 
btstarcher's Avatar
 
Join Date: May 2009
Location: Russellville, AR
Posts: 4,850   (View Stats)
iTrader: (3)
Rep Power: 1955
btstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the world
Thanks: 6,199
Thanked 3,518 Times in 1,760 Posts
Groans: 112
Groaned at 38 Times in 22 Posts
Not Ranked  0 score     
Default

You say gapped to spec; what spec? Also what plugs did you use?
__________________
JBR 3.5" whale penis intake, HTP polished battery tray, PnP stock intake manifold w/VCTS delete (by Kmac), Corksport TMIC, Forge V2 BPV, JBR TIG's, Kozmic EGR delete, Cobb AP, PTP HPFP internals, stock TBE w/gutted cats, JBR RMM, SU PMM and TMM, Koni Yellow Sport struts, Swift springs, Tri Point Engineering RSB, Whiteline Anti Lift Kit, PTP Injector Seals, GenPu transmission, Fidanza flywheel, 3 BAR MAP sensor, Posifab 10.5:1 CR 88mm sexy pistons, Molnar rods, sleeved block, PTP BSD

SnailTune in progress
btstarcher is offline   Reply With Quote
 Old 12-29-2013, 05:11 PM   #7
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

they are gapped at .029 and i used the autolite xp iridium @btstarcher;
ThomasSpeed3 is offline   Reply With Quote
 Old 12-29-2013, 05:15 PM   #8
 
btstarcher's Avatar
 
Join Date: May 2009
Location: Russellville, AR
Posts: 4,850   (View Stats)
iTrader: (3)
Rep Power: 1955
btstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the world
Thanks: 6,199
Thanked 3,518 Times in 1,760 Posts
Groans: 112
Groaned at 38 Times in 22 Posts
Not Ranked  0 score     
Default

Stock heat range I hope, and I'd still close that gap a little. I would definitely check for boost/vacuum leaks too.
__________________
JBR 3.5" whale penis intake, HTP polished battery tray, PnP stock intake manifold w/VCTS delete (by Kmac), Corksport TMIC, Forge V2 BPV, JBR TIG's, Kozmic EGR delete, Cobb AP, PTP HPFP internals, stock TBE w/gutted cats, JBR RMM, SU PMM and TMM, Koni Yellow Sport struts, Swift springs, Tri Point Engineering RSB, Whiteline Anti Lift Kit, PTP Injector Seals, GenPu transmission, Fidanza flywheel, 3 BAR MAP sensor, Posifab 10.5:1 CR 88mm sexy pistons, Molnar rods, sleeved block, PTP BSD

SnailTune in progress
btstarcher is offline   Reply With Quote
 Old 12-29-2013, 05:39 PM   #9
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

have been checking for leaks for 2 days :/ me and another local NATOR and we are both stumped, been searching through threads and google and nothing we try seems to fix or find the issue. @btstarcher;

but will close gap some! thank you.
ThomasSpeed3 is offline   Reply With Quote
 Old 12-29-2013, 06:01 PM   #10
 
btstarcher's Avatar
 
Join Date: May 2009
Location: Russellville, AR
Posts: 4,850   (View Stats)
iTrader: (3)
Rep Power: 1955
btstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the world
Thanks: 6,199
Thanked 3,518 Times in 1,760 Posts
Groans: 112
Groaned at 38 Times in 22 Posts
Not Ranked  0 score     
Default

Post a log of idle and some easy driving. Maybe a quick WOT but not a full pull.
__________________
JBR 3.5" whale penis intake, HTP polished battery tray, PnP stock intake manifold w/VCTS delete (by Kmac), Corksport TMIC, Forge V2 BPV, JBR TIG's, Kozmic EGR delete, Cobb AP, PTP HPFP internals, stock TBE w/gutted cats, JBR RMM, SU PMM and TMM, Koni Yellow Sport struts, Swift springs, Tri Point Engineering RSB, Whiteline Anti Lift Kit, PTP Injector Seals, GenPu transmission, Fidanza flywheel, 3 BAR MAP sensor, Posifab 10.5:1 CR 88mm sexy pistons, Molnar rods, sleeved block, PTP BSD

SnailTune in progress
btstarcher is offline   Reply With Quote
 Old 12-29-2013, 06:40 PM   #11
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

will do! ill try to do logs toight after the game. @btstarcher;
ThomasSpeed3 is offline   Reply With Quote
 Old 12-29-2013, 06:45 PM   #12
 
rfinkle2's Avatar
 
Join Date: Nov 2010
Location: Mullica Hill, NJ 08062
Posts: 14,536   (View Stats)
iTrader: (13)
Rep Power: 0
rfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the world
Thanks: 52,496
Thanked 33,219 Times in 10,050 Posts
Groans: 298
Groaned at 292 Times in 196 Posts
Not Ranked  0 score     
Default

I bet it is the purge valve.

p0455 and 2187 and how to troubleshoot a bad purge solenoid valve!
rfinkle2 is offline   Reply With Quote
 Old 12-29-2013, 07:00 PM   #13
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

if it was the purge valve would it be just stuck open or need replacing? @rfinkle2;

will also check that before i do logs.
ThomasSpeed3 is offline   Reply With Quote
 Old 12-29-2013, 07:39 PM   #14
 
rfinkle2's Avatar
 
Join Date: Nov 2010
Location: Mullica Hill, NJ 08062
Posts: 14,536   (View Stats)
iTrader: (13)
Rep Power: 0
rfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the worldrfinkle2 is the leader of the world
Thanks: 52,496
Thanked 33,219 Times in 10,050 Posts
Groans: 298
Groaned at 292 Times in 196 Posts
Not Ranked  0 score     
Default

Originally Posted by ThomasSpeed3 View Post
if it was the purge valve would it be just stuck open or need replacing? @rfinkle2;

will also check that before i do logs.
I think I remember hearing someone clean one, but I would probably replace if your car is relatively high mileage.
rfinkle2 is offline   Reply With Quote
 Old 12-29-2013, 08:21 PM   #15
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

ill check and if thats the case ill order a new one. i hope its something stupid like that...and that literally is one of the last things i have left to check.
ThomasSpeed3 is offline   Reply With Quote
 Old 01-01-2014, 04:25 PM   #16
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

Here are my logs.....had trouble finding a way to upload them cause i dont have MS Office.

Didnt know how to lable them, first time doing logs so no promises. tried to keep them short and to the point.
Attached Files
File Type: csv 1-1-14 ots1 ltft.csv (16.4 KB, 9 views)
File Type: csv 1-1-14 ots1 stft.csv (43.4 KB, 1 views)
File Type: csv 1-1-14 ots1 vac-boost.csv (40.2 KB, 16 views)
ThomasSpeed3 is offline   Reply With Quote
 Old 01-01-2014, 05:18 PM   #17
 
btstarcher's Avatar
 
Join Date: May 2009
Location: Russellville, AR
Posts: 4,850   (View Stats)
iTrader: (3)
Rep Power: 1955
btstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the world
Thanks: 6,199
Thanked 3,518 Times in 1,760 Posts
Groans: 112
Groaned at 38 Times in 22 Posts
Not Ranked  0 score     
Default

Boost leak. Something either disconnected or loose somewhere.

Oh and make sure you log STFT also; you left that out.
__________________
JBR 3.5" whale penis intake, HTP polished battery tray, PnP stock intake manifold w/VCTS delete (by Kmac), Corksport TMIC, Forge V2 BPV, JBR TIG's, Kozmic EGR delete, Cobb AP, PTP HPFP internals, stock TBE w/gutted cats, JBR RMM, SU PMM and TMM, Koni Yellow Sport struts, Swift springs, Tri Point Engineering RSB, Whiteline Anti Lift Kit, PTP Injector Seals, GenPu transmission, Fidanza flywheel, 3 BAR MAP sensor, Posifab 10.5:1 CR 88mm sexy pistons, Molnar rods, sleeved block, PTP BSD

SnailTune in progress

Last edited by btstarcher; 01-01-2014 at 05:18 PM. Reason: MSF Database - Automerged Doublepost
btstarcher is offline   Reply With Quote
 Old 01-01-2014, 05:59 PM   #18
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

will post that tomorrow @btstarcher; and ive been checking everything possible that could leak and i cant find anything. every hose has been checked, im stumped.
ThomasSpeed3 is offline   Reply With Quote
 Old 01-01-2014, 06:04 PM   #19
 
btstarcher's Avatar
 
Join Date: May 2009
Location: Russellville, AR
Posts: 4,850   (View Stats)
iTrader: (3)
Rep Power: 1955
btstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the world
Thanks: 6,199
Thanked 3,518 Times in 1,760 Posts
Groans: 112
Groaned at 38 Times in 22 Posts
Not Ranked  0 score     
Default

Manifold pressure at idle should be at around -11.5 psi, give-or-take. You're at around -8 and it fluctuates. Definitely vacuum leak. You didn't check everything.

Did you check your purge valve? Are you sure a hose somewhere doesn't have a hole in it?
__________________
JBR 3.5" whale penis intake, HTP polished battery tray, PnP stock intake manifold w/VCTS delete (by Kmac), Corksport TMIC, Forge V2 BPV, JBR TIG's, Kozmic EGR delete, Cobb AP, PTP HPFP internals, stock TBE w/gutted cats, JBR RMM, SU PMM and TMM, Koni Yellow Sport struts, Swift springs, Tri Point Engineering RSB, Whiteline Anti Lift Kit, PTP Injector Seals, GenPu transmission, Fidanza flywheel, 3 BAR MAP sensor, Posifab 10.5:1 CR 88mm sexy pistons, Molnar rods, sleeved block, PTP BSD

SnailTune in progress
btstarcher is offline   Reply With Quote
 Old 01-01-2014, 06:21 PM   #20
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

I checked the purge valve and it isnt broken or stuck open. I took off the TIP ans SRI and checked them and the BPV hose, also the hoses off the turbo are all good. I checked my BPV itself, checked all the hoses that have to do with boost/vacuum. I will go through everything again tomorrow for the 3rd time, and ill post some more logs. I have checked everything i know i should have checked, and checked everything i was told to check, and everything i have read to check. @btstarcher;
ThomasSpeed3 is offline   Reply With Quote
 Old 01-01-2014, 06:39 PM   #21
kby
 
kby's Avatar
 
Join Date: Nov 2010
Location: Long Island, NY
Posts: 653   (View Stats)
iTrader: (0)
Rep Power: 0
kby is the leader of the worldkby is the leader of the worldkby is the leader of the worldkby is the leader of the worldkby is the leader of the worldkby is the leader of the worldkby is the leader of the worldkby is the leader of the worldkby is the leader of the worldkby is the leader of the worldkby is the leader of the world
Thanks: 581
Thanked 340 Times in 192 Posts
Groans: 31
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

K, curious from your logs. Your a/c and defog are off right? Keep seeing knock and good vacuum at those amounts. Knock could be the a/c compresser kicking off.

also, That knock at wot can't be good.
kby is offline   Reply With Quote
 Old 01-01-2014, 06:40 PM   #22
 
btstarcher's Avatar
 
Join Date: May 2009
Location: Russellville, AR
Posts: 4,850   (View Stats)
iTrader: (3)
Rep Power: 1955
btstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the world
Thanks: 6,199
Thanked 3,518 Times in 1,760 Posts
Groans: 112
Groaned at 38 Times in 22 Posts
Not Ranked  0 score     
Default

You say you checked, but how? Did you build a boost-leak tester? Or just visually inspect everything? Or just take everything off and reinstall? Also do you have an oil catch can? Did you check the hose from the PCV valve to the IM? Also you may try swapping your BPV with a stock one, just in case.
__________________
JBR 3.5" whale penis intake, HTP polished battery tray, PnP stock intake manifold w/VCTS delete (by Kmac), Corksport TMIC, Forge V2 BPV, JBR TIG's, Kozmic EGR delete, Cobb AP, PTP HPFP internals, stock TBE w/gutted cats, JBR RMM, SU PMM and TMM, Koni Yellow Sport struts, Swift springs, Tri Point Engineering RSB, Whiteline Anti Lift Kit, PTP Injector Seals, GenPu transmission, Fidanza flywheel, 3 BAR MAP sensor, Posifab 10.5:1 CR 88mm sexy pistons, Molnar rods, sleeved block, PTP BSD

SnailTune in progress
btstarcher is offline   Reply With Quote
 Old 01-02-2014, 04:31 PM   #23
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

Getting stock bpv to swap to and a new purge valve just for shits. this Saturday going to take all hoses off and do super close inspection as well as do another boost leak test. Tomorrow going to swap out TIP, SRI, and BPV hose with another speeds that is running good to narrow things down fairly quickly with those specific parts. also getting all new clamps for everything just for peace of mind. the clamps on the car were from previous owner and work but replacing simply cause i want to.
ThomasSpeed3 is offline   Reply With Quote
 Old 01-02-2014, 06:14 PM   #24
 
Silverspec06's Avatar
 
Join Date: Aug 2012
Location: Calgary, Ab
Posts: 244   (View Stats)
iTrader: (0)
Rep Power: 0
Silverspec06 has much to be proud ofSilverspec06 has much to be proud ofSilverspec06 has much to be proud ofSilverspec06 has much to be proud ofSilverspec06 has much to be proud ofSilverspec06 has much to be proud ofSilverspec06 has much to be proud ofSilverspec06 has much to be proud ofSilverspec06 has much to be proud ofSilverspec06 has much to be proud of
Thanks: 73
Thanked 30 Times in 27 Posts
Groans: 0
Groaned at 5 Times in 4 Posts
Not Ranked  0 score     
Default

Originally Posted by btstarcher View Post
You say you checked, but how? Did you build a boost-leak tester? Or just visually inspect everything? Or just take everything off and reinstall? Also do you have an oil catch can? Did you check the hose from the PCV valve to the IM? Also you may try swapping your BPV with a stock one, just in case.
Silly question but if it was a boost leak, wouldn't his afr when he at wot be rich? from what Im seeing its tending on the lean side. no?

Also Im 403speed3
__________________
There are no problems that the liberal application of BOOST can't solve.
INSTALLED: COBB SRI//TiP||Turbosmart 50/50 BPV/BOV|| COBB AP||CNT RACING DP||Corksport 3" CBE||JBR FLAPS|| CP-E stage 2 Rmm|| Autotech CDFP Stage2 tune ||Godspeed FMIC|| Hawk HPS Pads|| Sure SSP|| NGK Step COLDER||

Intalling soon: CPE Triple Gauge pod|| Prosport Evo Gauges|| Ebay OCC With baffling mod.
Up next: EBC Rotors|| BNR S3 Turbah|| JBR balance shaft delete|| JBR 88a Pmm 80a TMM
Silverspec06 is offline   Reply With Quote
The Following User Says Thank You to Silverspec06 For This Useful Post:
btstarcher (01-02-2014)
 Old 01-02-2014, 06:30 PM   #25
 
btstarcher's Avatar
 
Join Date: May 2009
Location: Russellville, AR
Posts: 4,850   (View Stats)
iTrader: (3)
Rep Power: 1955
btstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the worldbtstarcher is the leader of the world
Thanks: 6,199
Thanked 3,518 Times in 1,760 Posts
Groans: 112
Groaned at 38 Times in 22 Posts
Not Ranked  0 score     
Default

That's right; I'm thinking vacuum leak, like maybe from PCV to intake manifold, or maybe a hose at the manifold somewhere leaking.
__________________
JBR 3.5" whale penis intake, HTP polished battery tray, PnP stock intake manifold w/VCTS delete (by Kmac), Corksport TMIC, Forge V2 BPV, JBR TIG's, Kozmic EGR delete, Cobb AP, PTP HPFP internals, stock TBE w/gutted cats, JBR RMM, SU PMM and TMM, Koni Yellow Sport struts, Swift springs, Tri Point Engineering RSB, Whiteline Anti Lift Kit, PTP Injector Seals, GenPu transmission, Fidanza flywheel, 3 BAR MAP sensor, Posifab 10.5:1 CR 88mm sexy pistons, Molnar rods, sleeved block, PTP BSD

SnailTune in progress
btstarcher is offline   Reply With Quote
 Old 01-02-2014, 06:55 PM   #26
 
ThomasSpeed3's Avatar
 
Join Date: Jul 2013
Location: Corpus Christi, TX
Posts: 84   (View Stats)
iTrader: (0)
Rep Power: 0
ThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to beholdThomasSpeed3 is a splendid one to behold
Thanks: 5
Thanked 15 Times in 11 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

Hopefully saturday i will get to the bottom of this...id really like to put the rest of my parts on already haha.
ThomasSpeed3 is offline   Reply With Quote
 Old 01-09-2014, 06:38 AM   #27
 
brettmurphy's Avatar
 
Join Date: Oct 2011
Posts: 5   (View Stats)
iTrader: (0)
Rep Power: 0
brettmurphy is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

What did it turn out to be? Bad hose?
brettmurphy is offline   Reply With Quote
 Old 06-06-2014, 07:24 AM   #28
 
BrandonRKD's Avatar
 
Join Date: Mar 2013
Location: Houston, TX
Posts: 417   (View Stats)
iTrader: (4)
Rep Power: 0
BrandonRKD is the leader of the worldBrandonRKD is the leader of the worldBrandonRKD is the leader of the worldBrandonRKD is the leader of the worldBrandonRKD is the leader of the worldBrandonRKD is the leader of the worldBrandonRKD is the leader of the worldBrandonRKD is the leader of the worldBrandonRKD is the leader of the worldBrandonRKD is the leader of the worldBrandonRKD is the leader of the world
Thanks: 119
Thanked 150 Times in 82 Posts
Groans: 1
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Originally Posted by ThomasSpeed3 View Post
Hopefully saturday i will get to the bottom of this...id really like to put the rest of my parts on already haha.
Any update on this?

I Tapped that
__________________
2006 WWP MS6
Cobb AP, SRI, TIP ▌CP-E HPFP, Safe Seals ▌CS TBE ▌TS BPV ▌Custom FMIC ▌NGK Colder Plugs ▌JBR TIG, EGR Blockoff ▌TB Coolant B/P ▌VTCS Delete ▌H&R Springs
FlowTuned By TiGraySpeed6
BrandonRKD is offline   Reply With Quote
 Old 06-05-2017, 04:48 PM   #29
 
StickySideDown's Avatar
 
Join Date: May 2017
Posts: 8   (View Stats)
iTrader: (0)
Rep Power: 0
StickySideDown is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

#OldThreadRevival
Was there ever a resolution to this? Or did you just give up...
StickySideDown is offline   Reply With Quote
Reply


LinkBacks (?)
LinkBack to this Thread: http://www.mazdaspeedforums.org/forum/f293/rough-idle-vacuum-issues-161713/
Posted By For Type Date
Rough idle/Vacuum issues - Mazdaspeed Forums This thread Refback 12-30-2013 11:14 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with rough idle, no boost after intall of bolt-ons 08ms3stock4now MazdaSpeed 3/6 - Troubleshoot/Diagnostics 14 02-15-2013 10:28 AM
vacuum at idle? chintastic Gen2 MS3 General Discussion 13 11-16-2012 04:13 PM
Report: Scion FR-S, Subaru BRZ rough idle issues require ECU reflash Haltech Automotive News 0 10-05-2012 09:00 AM
Rough Idle and KR fearturtle03 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 14 05-27-2011 10:38 AM
sometimes rough idle....?? MSP611 MazdaSpeed 6 - Engine, Transmission & Driveline 12 07-14-2010 03:32 PM


All times are GMT -7. The time now is 02:42 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.45259 seconds with 30 queries