register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Troubleshoot/Diagnostics

MazdaSpeed 3/6 - Troubleshoot/Diagnostics MazdaSpeed 3/6 - Troubleshoot/Diagnostics - Have a problem with the car? CEL Code? Want to discuss other issues? Come on in!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 01-05-2018, 04:40 PM   #1
 
Badger_'s Avatar
 
Join Date: Dec 2012
Location: Ann Arbor, MI
Posts: 1,572   (View Stats)
iTrader: (0)
Rep Power: 0
Badger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the world
Thanks: 890
Thanked 694 Times in 372 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default Stalling at cold start, p2187, high fuel trims, hesitation/sputter

TL;DR
-Cold starts car dies 1-3 times before running.
-Severe hesitation and sputtering under 3,000rpms when engine cold.
-Hesitation when accelerating/cruising under 3,000rpms any temp
-P2187 - too lean at idle
-Ltft really high at 20+
-Stft really high at 20+
-Based on logs my average AFRs are lean. (average 15-16)
-Posted logs

-------------------------------------

I’ve been putting off starting a new thread, but here we go.

Cold starts (like really cold -10 to +10F) car doesn’t want to stay running after start. Car starts and then dies 5-10 seconds after. This will happen 1-3 times before the car will stay running, but it has always eventually stayed running. If I try to give it a little gas to increase rpms the car dies instantly.

Massive hesitation and sputtering for the first few miles after first start of the day. Increasing throttle does nothing and car struggles to move. Once rpms are about 2900+ the car drives just fine. Logs look like It leans out quite a bit during that time. I will attach logs.

Slight random hesitation while driving after car is warmed up. While accelerating and cruising alike. Seems to be getting worse and appears to really only happen (noticeably) under 2900 rpms.

Car throws p2187 for lean at idle. Ltfts and idle are between 19.xx-20.xx. Stupid high. Sometimes stft+ltft is above 30. AFRs don’t seem super lean. Most of the time it actually reads rich at idle at around 14.41-14.55. Sometimes it creeps up to 15.3-16 (which is lean, true), but usually goes back down to 14.7, 14.55, 14.41 sometimes even 13.9 within 30 or so seconds. I have attached an idle log.

I’ve check for boost leaks twice with no luck. I recently (a couple of thousand miles ago) replaced my MAF sensor because the old one was corroding on the inside. That was also giving me a lean idle code (can’t remember if it was the same as this one) and the car was hesitating similarly to this, with the addition of hard acceleration hesitation.

I just replaced the purge valve today. Made no difference.

I replaced the fuel pressure relief valve about 8 months ago, saw my fuel pressure drop instead of climb after shutting the car off. That was fixed.

Mod list:
Injen sri (used to be a cai, but I cut it down)
Corksport tip
JBR boost and bpv hoses
Thermal insulating TB and IM gaskets
Autotech hpfp
Corksport test pipe
Custom 3” exhaust with 8” glasspack (essentially straight pipe) ADDED AFTER TUNE
Freektune Ots+ tune (same tune for years)

Also to note, I had the TB coolant bypass installed for nearly two years (also cleaned the TB, EGR, and valves at the same time) and about a week ago my TB froze up (it was in the single digits to the -xx *F). I removed the bypass. TB hasn’t stuck again.

No significant change in gas mileage. 14-18 city and 21-25 combined.

I know that was a lot to read, but I would be very interested in any thoughts from you guys.

Things that I am questioning:
Spill valve?
Pcv valve?
Upstream O2 sensor?
Bad MAF?
Bad accel pedal position sensor?
Just too damn cold?

This is my 6th year with this car in winter and the first time I’ve had this problem, so I’m not convinced weather is the only factor here. Somethings fucky.

Car still hauls ass. I posted a 3rd gear to 4th pull (not WOT, but to about 18psi boost).

Attached Files
File Type: csv 3rd to 4th Pull.csv (6.7 KB, 1 views)
File Type: csv 40mph Cruising.csv (21.7 KB, 0 views)
File Type: csv Highway Cruising.csv (21.2 KB, 0 views)
File Type: csv Hesitation 1.csv (7.7 KB, 1 views)
File Type: csv Hesitation 2.csv (9.1 KB, 0 views)
File Type: csv Hesitation 3.csv (18.2 KB, 0 views)
File Type: csv Idle Log.csv (29.2 KB, 0 views)
File Type: csv Extreme Hesititation - Very Cold.csv (76.7 KB, 1 views)
__________________
2007 MS3

Injen SRI | CS TIP | CS TP | 3" TP-Back Straight Pipe | AT Internals
All Mounts | Koni Oranges | Eibach Springs | Moog Endlinks
Thermal Insulating Gaskets | TB Coolant Bypass
AP V3 | FreekTune | Russian Dashcam Mod


Last edited by Badger_; 01-05-2018 at 05:25 PM.
Badger_ is offline   Reply With Quote
 Old 01-05-2018, 04:41 PM   #2
 
Badger_'s Avatar
 
Join Date: Dec 2012
Location: Ann Arbor, MI
Posts: 1,572   (View Stats)
iTrader: (0)
Rep Power: 0
Badger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the world
Thanks: 890
Thanked 694 Times in 372 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Looking at the hesitation logs, it looks like the pedal position jumps to 0 when I know I did not lift off the pedal. Is this indicative of a bad pedal assembly? This would explain the hesitation, but not really anything else.
__________________
2007 MS3

Injen SRI | CS TIP | CS TP | 3" TP-Back Straight Pipe | AT Internals
All Mounts | Koni Oranges | Eibach Springs | Moog Endlinks
Thermal Insulating Gaskets | TB Coolant Bypass
AP V3 | FreekTune | Russian Dashcam Mod

Badger_ is offline   Reply With Quote
 Old 01-06-2018, 06:38 AM   #3
 
5doorsoffury's Avatar
 
Join Date: Feb 2012
Location: bethpage ny
Posts: 965   (View Stats)
iTrader: (1)
Rep Power: 0
5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world
Thanks: 1,272
Thanked 540 Times in 302 Posts
Groans: 72
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

Well i see 0 wgdc then out of nowhere it jumps to th 60s for a few cells... stupid lean when low load and 9s when on the gas. It sounds like a big boost leak. Sucking air in during vacume and blowing it out under boost. Do a boost leak test again. Check the bpv and the egr they are both a place for air to leave the system.
__________________
MECP
2012 BM
PTE 5858 Vband .82ar // Tial EWG // CPE Mani // 3" Turboback // JBR Under route hot pipe // MD ST mani+spacer with PI // Siemens 60lb Injectors // Splitsecond inj controller // JBR 88 duro RMM/TMM // MD PMM // TWM Full replacement shifter // JBR CC // Autotech FP Internals // SP63 SB/Manley rods SP63 pro pistons // Treadstone FMIC TR824 // FoMoCo Tranny Jizz // South Bend Clutch Stage 3 enduro// GFB Respons // FJ 4" intake // WMI 100% VPM1 // Air Lift 1000 in rear // N2MB WOT BOX
Rfinkle tune in progress

The Brooklyn beater: 2005 1.8 Auto Sentra

5doorsoffury is offline   Reply With Quote
The Following User Says Thank You to 5doorsoffury For This Useful Post:
Badger_ (01-09-2018)
 Old 01-06-2018, 07:52 AM   #4
 
Badger_'s Avatar
 
Join Date: Dec 2012
Location: Ann Arbor, MI
Posts: 1,572   (View Stats)
iTrader: (0)
Rep Power: 0
Badger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the world
Thanks: 890
Thanked 694 Times in 372 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Thanks for the response, Iíll check them both again.


Sent from my iPhone using Tapatalk
__________________
2007 MS3

Injen SRI | CS TIP | CS TP | 3" TP-Back Straight Pipe | AT Internals
All Mounts | Koni Oranges | Eibach Springs | Moog Endlinks
Thermal Insulating Gaskets | TB Coolant Bypass
AP V3 | FreekTune | Russian Dashcam Mod

Badger_ is offline   Reply With Quote
 Old 01-06-2018, 03:45 PM   #5
 
torquemaniac's Avatar
 
Join Date: Jun 2012
Location: Montreal, QC
Posts: 713   (View Stats)
iTrader: (0)
Rep Power: 0
torquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the world
Thanks: 919
Thanked 735 Times in 258 Posts
Groans: 0
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

Watch for leak at the manifold gasket...especially with PTFE thermal insulating gasket (tehy can deform and leak)
__________________
2011 CX-7 AWD 2.3 turbo
Ported Holset HY35 // Custom top mount EM // Tial MV-S 38mm // Custom DP and catback // L2A intercooler // 3-port EBCS // 3.25 Blow-thru MAF // Aquamist HFS-4 v.2 direct port injection // Eagle rods // Forge BPV v.2 // Crankcase evac system // Autotech HPFP // Custom RMM insert // TB coolant bypass // Full EGR delete // 3.5 bar MAP // Launch control with anti-lag // Derale remote transmission cooler // Upgraded transmission boost valve // Shimmed transmission accumulators // Adjusted transmission clutch control valve // Digital overboost protection system // Custom firewall heatshield // JKS rear spoiler // Painted VC and IM // BSD // Custom vent pod with boost and meth gauge // Tuned with Versatuner

Coming soon : Composite ram-air intake // Hood with heat extraction vent

"When the turbo spins the bull$hit ends" BOOST the replacement for displacement
torquemaniac is offline   Reply With Quote
The Following User Says Thank You to torquemaniac For This Useful Post:
Badger_ (01-09-2018)
 Old 01-06-2018, 09:22 PM   #6
 
Badger_'s Avatar
 
Join Date: Dec 2012
Location: Ann Arbor, MI
Posts: 1,572   (View Stats)
iTrader: (0)
Rep Power: 0
Badger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the world
Thanks: 890
Thanked 694 Times in 372 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Good advice, thanks.


Sent from my iPhone using Tapatalk
__________________
2007 MS3

Injen SRI | CS TIP | CS TP | 3" TP-Back Straight Pipe | AT Internals
All Mounts | Koni Oranges | Eibach Springs | Moog Endlinks
Thermal Insulating Gaskets | TB Coolant Bypass
AP V3 | FreekTune | Russian Dashcam Mod

Badger_ is offline   Reply With Quote
 Old 01-07-2018, 08:26 PM   #7
 
Badger_'s Avatar
 
Join Date: Dec 2012
Location: Ann Arbor, MI
Posts: 1,572   (View Stats)
iTrader: (0)
Rep Power: 0
Badger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the world
Thanks: 890
Thanked 694 Times in 372 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Did another boost leak test tonight and found a leaking weld on my turbo inlet. I welded the hole shut and re-tested. No more leak.

Took the car for a drive and saw negative ltfts (other than -0.16) for the first time in months. -3.42%. Im still seeing +18-20 ltfts under some conditions, but Iím hoping it just wants more miles....

Iím not 100% convinced, but it feels good finding a leak, fixing it, and seeing some sort of instant result. Weíll see if it wants to die/stutter tomorrow morning.

Terrible photo, but look at the bubbles.
IMG_2261.JPG
__________________
2007 MS3

Injen SRI | CS TIP | CS TP | 3" TP-Back Straight Pipe | AT Internals
All Mounts | Koni Oranges | Eibach Springs | Moog Endlinks
Thermal Insulating Gaskets | TB Coolant Bypass
AP V3 | FreekTune | Russian Dashcam Mod

Badger_ is offline   Reply With Quote
 Old 01-08-2018, 07:35 AM   #8
 
Badger_'s Avatar
 
Join Date: Dec 2012
Location: Ann Arbor, MI
Posts: 1,572   (View Stats)
iTrader: (0)
Rep Power: 0
Badger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the world
Thanks: 890
Thanked 694 Times in 372 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Update: car started right up this morning without wanting to stall. Also, no hesitation. Fuel trims are still high.


Sent from my iPhone using Tapatalk
__________________
2007 MS3

Injen SRI | CS TIP | CS TP | 3" TP-Back Straight Pipe | AT Internals
All Mounts | Koni Oranges | Eibach Springs | Moog Endlinks
Thermal Insulating Gaskets | TB Coolant Bypass
AP V3 | FreekTune | Russian Dashcam Mod

Badger_ is offline   Reply With Quote
 Old 01-08-2018, 10:17 AM   #9
 
Thor Hammer's Avatar
 
Join Date: Jun 2015
Location: Santa Cruz, CA.
Posts: 1,495   (View Stats)
iTrader: (0)
Rep Power: 286
Thor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the world
Thanks: 825
Thanked 470 Times in 364 Posts
Groans: 143
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

Do you see + trims at idle or while cruising? If at idle there could be a vacuum leak at the intake manifold or elsewhere.

Could also be the ECU needs more time to re-learn the trims.
__________________
2007 MS6- H&R Coilovers/ C-PE Catted DP/Corksport HPFP Internals/ AEM CAI/ ETS TMIC/ CPE Austenite Dual CBE/ CPE TIH/ Synapse Synchronic/ Freektuned/ AP Short Shifter/ AWR RMM and OEM TMM with CS Inserts/ Southbend Stage 2 Endurance/Stop Tech Slotted Rear and DBA T3 4000 Series Front with EBC Reds/CPE xFlex Rear Diff Mount/ Whiteline Rear Sway Bar/DSS Level 2.9 Rear Axles

Waiting for Install: BNR S3/HTP 3.5 Intake/Damond OCC/ CS Injector Seals/ WMI/MAPerformance Rev3 Intake Manifold
Thor Hammer is offline   Reply With Quote
The Following User Says Thank You to Thor Hammer For This Useful Post:
Badger_ (01-09-2018)
 Old 01-08-2018, 10:59 AM   #10
 
Badger_'s Avatar
 
Join Date: Dec 2012
Location: Ann Arbor, MI
Posts: 1,572   (View Stats)
iTrader: (0)
Rep Power: 0
Badger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the world
Thanks: 890
Thanked 694 Times in 372 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Originally Posted by Thor Hammer View Post
Do you see + trims at idle or while cruising? If at idle there could be a vacuum leak at the intake manifold or elsewhere.



Could also be the ECU needs more time to re-learn the trims.

Highest positive values are during idle. It was ~20, but went down to 19 today while driving. My stfts look a little more sane, so it looks as if the car likes being driven. Cruising on highway fluctuates from -3.26, -0.16, and +17.xx. I only drive like 10-15 miles a day (all city), so thatís not helping the car learn any faster. Going to go for a longer drive later this evening.

About the idle ltft values. Last night after I took it for a drive post hole plug I let it sit and idle for about 25 minutes. Ltfts went down from +20 to +8, but when back to +20 at idle after driving about 5 miles.


Sent from my iPhone using Tapatalk
__________________
2007 MS3

Injen SRI | CS TIP | CS TP | 3" TP-Back Straight Pipe | AT Internals
All Mounts | Koni Oranges | Eibach Springs | Moog Endlinks
Thermal Insulating Gaskets | TB Coolant Bypass
AP V3 | FreekTune | Russian Dashcam Mod

Badger_ is offline   Reply With Quote
 Old 01-09-2018, 12:00 PM   #11
 
Thor Hammer's Avatar
 
Join Date: Jun 2015
Location: Santa Cruz, CA.
Posts: 1,495   (View Stats)
iTrader: (0)
Rep Power: 286
Thor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the world
Thanks: 825
Thanked 470 Times in 364 Posts
Groans: 143
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

Time to check for vacuum leaks.
__________________
2007 MS6- H&R Coilovers/ C-PE Catted DP/Corksport HPFP Internals/ AEM CAI/ ETS TMIC/ CPE Austenite Dual CBE/ CPE TIH/ Synapse Synchronic/ Freektuned/ AP Short Shifter/ AWR RMM and OEM TMM with CS Inserts/ Southbend Stage 2 Endurance/Stop Tech Slotted Rear and DBA T3 4000 Series Front with EBC Reds/CPE xFlex Rear Diff Mount/ Whiteline Rear Sway Bar/DSS Level 2.9 Rear Axles

Waiting for Install: BNR S3/HTP 3.5 Intake/Damond OCC/ CS Injector Seals/ WMI/MAPerformance Rev3 Intake Manifold
Thor Hammer is offline   Reply With Quote
 Old 01-11-2018, 07:43 AM   #12
 
Badger_'s Avatar
 
Join Date: Dec 2012
Location: Ann Arbor, MI
Posts: 1,572   (View Stats)
iTrader: (0)
Rep Power: 0
Badger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the world
Thanks: 890
Thanked 694 Times in 372 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Fuel trims continue to decrease. Ltfts have moved from +20 to +17.78 while cruising, which is still high, but stfts during this time are usually negative. Idle ltfts continue to drop. Currently at +12.23 (down from 20+) with stfts in the negatives. Accelerating ltfts are -3.28.

Car starts every time without dying and I havenít any hesitations.

I only put about 60 miles on it since fixing the leak.


Sent from my iPhone using Tapatalk
__________________
2007 MS3

Injen SRI | CS TIP | CS TP | 3" TP-Back Straight Pipe | AT Internals
All Mounts | Koni Oranges | Eibach Springs | Moog Endlinks
Thermal Insulating Gaskets | TB Coolant Bypass
AP V3 | FreekTune | Russian Dashcam Mod

Badger_ is offline   Reply With Quote
 Old 01-11-2018, 07:55 AM   #13
 
Fstrnyou's Avatar
 
Join Date: Jul 2016
Location: Near Charlotte NC
Posts: 1,624   (View Stats)
iTrader: (0)
Rep Power: 256
Fstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the world
Thanks: 41
Thanked 432 Times in 324 Posts
Groans: 16
Groaned at 5 Times in 4 Posts
Not Ranked  0 score     
Default

I believe disconnecting the battery can reset fuel trims.
__________________
2006 MS6 GT - 152k Miles
Versatuner, 3-bar MAP, ITV22's
CS Turbo/DP/RP/HPFP/BPV/R-DiffMount
White Widow F-DiffMount, Whiteline RSB
Russian Bushings in Back, Magnaflow CBE
JBR Tru-3.5/3-port EBCS/EGR-D
Damond RMM/PMM/Stage 2 OCC
Puppy Power tuning temporarily suspended.
Forged build ongoing. Manley H-Tuff & 2618, King Bearings

Other rides:
2002 Tacoma ExtCab 2.4L 5spd 2WD - 355k mile Parts Getter
2004 Olds Alero ECOtec 2.2 - Broken (since Christmas 2015)
History:
2008 GSX-R 1000 - Stolen (With several runs past 180, I'd probably be dead by now if it wasn't stolen. So, in a way, I'm thankful.)
1988 RX-7 TII - Sold (Megasquirt, streetport, filter-on-turbo SRI, custom TBE, 20psi boost creep on OE turbo, OE TMIC on ice, 13.467 @ 105.44) apex seals said buh bye!
1985 Camaro - Sold (est. 265bhp 5.7 swap, Edelbrock intake & Hooker headers)
Fstrnyou is offline   Reply With Quote
 Old 01-13-2018, 01:10 PM   #14
 
Badger_'s Avatar
 
Join Date: Dec 2012
Location: Ann Arbor, MI
Posts: 1,572   (View Stats)
iTrader: (0)
Rep Power: 0
Badger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the worldBadger_ is the leader of the world
Thanks: 890
Thanked 694 Times in 372 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

This car really hates the cold. It ran great and trims looked good in the 30+ degree weather. We had a couple of 40-50 degree days here in Ann Arbor, MI and the car liked it a lot. Yesterday after work it died upon start up and was hesitating....temp was 16F outside. I'm going to bench the car for now and drive my beater in the bitter cold. Fingers crossed for a short winter...

Still need to look for a vacuum leak, but I'm taking a week or two or three off of working on the car. too frustrating. It's making me want to sell it.
__________________
2007 MS3

Injen SRI | CS TIP | CS TP | 3" TP-Back Straight Pipe | AT Internals
All Mounts | Koni Oranges | Eibach Springs | Moog Endlinks
Thermal Insulating Gaskets | TB Coolant Bypass
AP V3 | FreekTune | Russian Dashcam Mod

Badger_ is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stumbling, hesitation, numb gas peddle, Fuel trims crazy, Lean, P2187. brainbot1 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 2 01-05-2018 05:27 PM
Sputter/Hesitation U2064 P2177 P2187 P2097 KFL989 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 24 03-26-2014 06:35 PM
High fuel trims at idle sdg_3mps MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection 32 07-28-2012 06:51 AM
High pitched squeal on cold start curlyface MazdaSpeed 3/6 - Troubleshoot/Diagnostics 6 06-05-2012 11:40 AM
hypertech cold start high idle cuse' boost1 MazdaSpeed 3/6 - ECU Computer Tuning 19 06-13-2011 07:37 AM


All times are GMT -7. The time now is 08:25 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHNô Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.34008 seconds with 25 queries