register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Troubleshoot/Diagnostics

MazdaSpeed 3/6 - Troubleshoot/Diagnostics MazdaSpeed 3/6 - Troubleshoot/Diagnostics - Have a problem with the car? CEL Code? Want to discuss other issues? Come on in!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 11-04-2019, 12:19 PM   #1
 
grammates's Avatar
 
Join Date: Aug 2019
Posts: 5   (View Stats)
iTrader: (0)
Rep Power: 0
grammates is an unknown quantity at this point
Thanks: 2
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default Weird idle in neutral and TERRIBLE gas mileage 08

Sorry if it isnít all correctly worded or not in the right section Iím fairly new
I have an 08 speed 3 with around 75k miles
CAI one cat one test pipe, rmm, HPFP and a tune
Recently my car has been acting very weird and having horrible gas mileage. I had just recently fixed the PCV valve and I keep getting a gross leak code and a too lean at idle code. Iím not too sure why but I continue to get those. Now my car when Iím driving say going 40 and take it out of gear and put it into Neutral and itís still idling at like 1300-1700 and then wonít really drop too normal rpms until I fully stop. Itís like itís shifting through the gears on the way down as if it was an auto? Any help would be appreciated I read about it and it said it could be the IAC or a vacuum leak!


Sent from my iPhone using Tapatalk
grammates is offline   Reply With Quote
 Old 11-05-2019, 03:11 PM   #2
 
MSMS3's Avatar
 
Join Date: Jun 2009
Posts: 2,738   (View Stats)
iTrader: (0)
Rep Power: 1107
MSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the world
Thanks: 1,436
Thanked 1,897 Times in 1,042 Posts
Groans: 154
Groaned at 47 Times in 31 Posts
Not Ranked  0 score     
Default

Post the exact code numbers, please.

Also can you post a log demonstrating the condition?

Have you done any work on the car recently? Any repairs or changes of parts?

What CAI? What tune?
__________________
2017 Audi Q5 3.0 T (supercharged) Stage 2+ EPL tune, JHM overdrive crank pulley, EPL supercharger pulley, ZF8 TCU tune, aFe/034 intake, modified air box. 480 hp.

Sunlight Silver '08 MS3 GT Mods: (Sold 1/25/2019 after 10+ years of ownership)
BNR Stage 1 (to fix smoking K04 turbo), TurboXS 3" Catless DP/RP "Stealthback" into stock CBE, Vibrant 3 inch Ultra Quiet Resonator in RP section, Magnaflow 3 1/2" exhaust tip, Mazdaspeed CAI w/air straightener and K&N conical filter, NGK 6510 Iridium IX one step colder plugs, Hypertech tune, Autotech HPFP internals, Stock BPV (works perfectly), Yokohama Advan Neova AD08R's (stock size on stock rims); Hawk HPS pads; SURE RMM; Grimmspeed EBCS (2 port mode), Bilstein B6's, SPC rear camber arms.
MSMS3 is offline   Reply With Quote
 Old 11-05-2019, 03:19 PM   #3
Police - Grammarhead
 
Vansquish's Avatar
 
Join Date: Sep 2009
Location: Metro Detroit, MI
Posts: 7,134
iTrader: (1)
Rep Power: 3726
Vansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the world
Thanks: 8,705
Thanked 7,002 Times in 2,803 Posts
Groans: 1,906
Groaned at 45 Times in 26 Posts
Default

When you're sitting at a stop, does the idle speed bounce around? If so, then you probably have a vacuum leak. Given that you have a few airflow modifications on the car, any one of them *could* be the culprit.

However, I would recommend looking at the last things you touched in the engine bay. If the PCV valve isn't seated properly, or the PCV hose isn't hooked up properly at either the PCV end or the intake manifold, you will have a gross vacuum leak. The car won't run properly, and you will get terrible fuel economy (I did this once, so I'm familiar with the condition).
__________________
Having trouble finding something on MSF? Use MS3Shadow's search tool:SEARCH MSF HERE!

Vansquish is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Terrible Gas Mileage - Please Help DRS211 CX-7 > Issues & Troubleshooting 43 09-16-2013 08:30 PM
Neutral trans noise at idle 06Speed6 MazdaSpeed 6 - Engine, Transmission & Driveline 21 08-20-2013 07:42 PM
Weird idle mrdouble99 MazdaSpeed 3 - Engine, Transmission & Driveline 53 07-30-2013 12:41 PM
Terrible gas mileage 210 miles per tank at most! MR2Speed MazdaSpeed 3/6 - Troubleshoot/Diagnostics 89 06-26-2013 11:55 AM
Terrible, Horrible, No Good, Very Bad gas mileage CaptainCrunch MazdaSpeed 3/6 - Troubleshoot/Diagnostics 22 09-28-2012 07:09 PM


All times are GMT -7. The time now is 05:07 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2019 Cymru Internet Services LLC | FYHNô Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.23798 seconds with 22 queries