register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection

MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection Have a CDFP fuel pump question? Do you want to add Nitrous or Water Injection to your Mazdaspeed 3/6 ? Please come on in!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 01-12-2015, 01:11 PM   #1
 
-Six-'s Avatar
 
Join Date: May 2010
Posts: 14   (View Stats)
iTrader: (0)
Rep Power: 0
-Six- has a little shameless behaviour in the past
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default CDFP issues

Just yesterday experienced a sudden loss of fuel pressure that has persisted since, running at 60-75psi under all conditions; idle/throttle. Key on, pressure does rise to at least 400psi, but did not wait longer than that. I assumed possible stuck spill valve and proceeded to disassemble, clean, and reassemble/install. Unfortunately no improvement/change seen. Vehicle regularly runs straight 93 octane, but has seen 2 gallons of E85 at fill up on two occasions (one recently, but can not recall if that is what is in current tank). The spill valve did not appear to be terribly dirty, maybe a light yellow film at most.

My next suspicion is the solenoid has failed perhaps, or the internals failed (they were upgraded, but shall remain nameless so as not to wrongly tarnish a company for something as of yet unknown. Just looking to see if anyone had any firsthand experience with this, and also wanted to see if there is a source for purchasing the spill valve only, as it looks as though Mazda sells whole cdfp assembly only?

Edit: 2006 Mazdaspeed6 if anyone was questioning.

Thanks guys.
-Six- is offline   Reply With Quote
 Old 01-20-2015, 09:11 PM   #2
 
-Six-'s Avatar
 
Join Date: May 2010
Posts: 14   (View Stats)
iTrader: (0)
Rep Power: 0
-Six- has a little shameless behaviour in the past
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Update, if anyone cared. I replaced the hpfp/cdfp with OE pump after swapping over the CorkSport internals that were in the original pump. Once installed, everything is once again working well.

The pump that was on there, was original and had about 96k miles on it. Might be food for thought for anyone considering upgrades to high mileage pumps, may want to consider replacing entire pump. (Unfortunately, as of now, no one I could find sells a replacement spill valve solenoid.)

Last edited by -Six-; 06-12-2015 at 06:22 PM.
-Six- is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford issues six recalls covering 101,000 vehicles for multiple issues Haltech Automotive News 0 07-08-2014 01:50 PM
do i need a CDFP? rangers4094 MazdaSpeed 3 - Engine, Transmission & Driveline 7 09-13-2011 04:51 PM
AP and cdfp tsb? booya620
Cobb Access Port/Maps
6 11-04-2008 02:55 PM


All times are GMT -7. The time now is 08:47 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2019 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.24046 seconds with 20 queries