register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection

MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection Have a CDFP fuel pump question? Do you want to add Nitrous or Water Injection to your Mazdaspeed 3/6 ? Please come on in!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 12-04-2011, 08:05 PM   #1
 
burntmushu's Avatar
 
Join Date: May 2011
Posts: 128   (View Stats)
iTrader: (1)
Rep Power: 0
burntmushu has a reputation beyond reputeburntmushu has a reputation beyond reputeburntmushu has a reputation beyond reputeburntmushu has a reputation beyond reputeburntmushu has a reputation beyond reputeburntmushu has a reputation beyond reputeburntmushu has a reputation beyond reputeburntmushu has a reputation beyond reputeburntmushu has a reputation beyond reputeburntmushu has a reputation beyond reputeburntmushu has a reputation beyond repute
Thanks: 3
Thanked 51 Times in 28 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default installed cpe hpfp running lean code 2187

besides my vvt problem the car wasn't throwing any other codes. and during my last tear down on trying to get the vvt in the right position i replaced the hpfp to a cpe. thought i had a vacuum leak but everything is good. but i'm running lean. i tore down the car again today to try and realign the vvt and double checked the vacuums while i was tearing it down. anyone have the same problems? any ideAs?
burntmushu is offline   Reply With Quote
 Old 12-23-2011, 11:30 AM   #2
 
410ms3's Avatar
 
Join Date: Aug 2011
Location: Abingdon, Maryland
Posts: 91   (View Stats)
iTrader: (0)
Rep Power: 0
410ms3 has a brilliant future410ms3 has a brilliant future410ms3 has a brilliant future410ms3 has a brilliant future410ms3 has a brilliant future410ms3 has a brilliant future410ms3 has a brilliant future410ms3 has a brilliant future410ms3 has a brilliant future410ms3 has a brilliant future410ms3 has a brilliant future
Thanks: 55
Thanked 35 Times in 25 Posts
Groans: 0
Groaned at 4 Times in 2 Posts
Not Ranked  0 score     
Default

I was throwing the same code but not running lean at idle or any other situations. Checked vacuums and intercooler piping and couplers and found out that my purge valve was stuck open causing the car to throw a lean idle code. Im not sure if its the same for your car but that was my issue. Hope this helped a lil.
410ms3 is offline   Reply With Quote
The Following User Says Thank You to 410ms3 For This Useful Post:
rfinkle2 (12-23-2011)
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Spark Plugs = 2187 code? sallyspeed3 MazdaSpeed 3/6 - ECU Computer Tuning 2 10-08-2011 08:22 PM
Am I running too lean? BudUMfan MazdaSpeed 3/6 - ECU Computer Tuning 21 03-02-2010 03:47 PM
Running Lean W/FFS Realgib3
Cobb ATR Support
108 10-13-2009 12:41 PM
Running Lean? Praelior MazdaSpeed 6 - Engine, Transmission & Driveline 20 08-12-2009 05:47 AM
Running lean? Meder MazdaSpeed 3/6 - Troubleshoot/Diagnostics 4 01-14-2009 07:03 PM


All times are GMT -7. The time now is 02:08 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2019 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.23820 seconds with 21 queries