register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection

MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection Have a CDFP fuel pump question? Do you want to add Nitrous or Water Injection to your Mazdaspeed 3/6 ? Please come on in!


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 05-14-2014, 01:43 PM   #1
 
sriser66's Avatar
 
Join Date: May 2009
Location: Gainesville, GA
Posts: 380   (View Stats)
iTrader: (4)
Rep Power: 0
sriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the world
Thanks: 175
Thanked 372 Times in 201 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default Wierd Fuel Pressure Problem/ Rich at Idle

First of all, this post is going to be long and it does have logs to prove what I have seen 2 times now in the last month. I am beginning to think this car hates me. Here goes. After I got gas 2 times now, the car is extremely rich and dumping gas into the engine till the point of almost stalling out.

I have done a compression and leakdown test, both are good. The compression test came back at 170 across the board. I have replaced the upper o2 sensor in within the last 6 months, the purge valve and checked for boost and exhaust leaks.

I am currently being tuned by atvfreek, but I do not want to burden him with finding the answer. He has helped quite a bit on this journey and I know he is a busy man. When I get up to speed, the AFR stays at about 14.7, but if I let off the gas it goes right back to 9.6 or lower. I have to add that it only happens for about 5 miles and only when I get gas. Other times I start the car it does just fine. It is driving me crazy.

I have searched the forums and online and can not find anything remotely related to the issue. All the issues I see are not at all related. Here are the logs and I appreciate any suggestions. Here is a list of mods: GTX3071R, Turbosmart BPV, Grimmspeed EBCS, Autotech internals, CP-e TMIC, Ebay downpipe, Matt Damond Catch Can, NGK LTR7IX-11, HTP 3" Intake and TIP, Cobb AP, AWR RMM, Devils own Stage 1 70/30 Meth, EGR delete.
Attached Files
File Type: csv datalog1.csv (6.6 KB, 6 views)
File Type: csv datalog2.csv (38.9 KB, 4 views)
File Type: csv datalog3.csv (8.0 KB, 2 views)
File Type: csv datalog4.csv (18.0 KB, 1 views)
__________________


2006 MS6- GTX3071R, Freek Tuned, HKS BOV, Grimmspeed EBCS, Autotech internals, CP-e TMIC, Ebay downpipe, Matt Damond Catch Can, Densos ITV-22, HTP 3" Intake and TIP, Cobb AP v3, EGR delete, Throttle body coolant bypass, JBR 80 Duro RMM, JBR 80 Duro PMM, Devils own Stage 2 70/30 Meth, CP-e Safe Seals, Koni Yellows.

13.6 1/4 time on self tuned GTX3071r, still tuning in process.

383hp on dynojet with 198,000 miles on original clutch and original engine!!!!!!!!

Freektune for the win!!
sriser66 is offline   Reply With Quote
 Old 05-14-2014, 02:00 PM   #2
Daily Driver

 
Nitr0EngiE's Avatar
 
Join Date: Dec 2008
Location: Tampa, Fl
Posts: 2,614   (View Stats)
iTrader: (9)
Rep Power: 861
Nitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the worldNitr0EngiE is the leader of the world
Thanks: 576
Thanked 1,427 Times in 757 Posts
Groans: 52
Groaned at 82 Times in 51 Posts
Not Ranked  0 score     
Default

leaky injector, this is my first guess
Nitr0EngiE is offline   Reply With Quote
 Old 05-14-2014, 03:05 PM   #3
 
mituc's Avatar
 
Join Date: Mar 2009
Location: Iasi/Romania
Posts: 3,470   (View Stats)
iTrader: (0)
Rep Power: 1202
mituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the worldmituc is the leader of the world
Thanks: 1,273
Thanked 2,107 Times in 1,215 Posts
Groans: 111
Groaned at 17 Times in 14 Posts
Not Ranked  0 score     
Default

These rich at idle threads keep popping up lately. I wonder wtf is going on. However, som of the guys with this problem managed to figure it out:

(SOLVED!!!!!!!!!)help me solve this AFR at idle!!

But this doesn't necessarily mean you have the same root problem, only similar symptoms. In that thread have been asked questions and advice given about what to check and look for. Take a look.
__________________
2008 Cosmic Blue Mazda 3MPS
Bilstein B12 + CS Camber plates + Eibach camber arms, SSR Type-F, Michelin PS4 225/40/R18, Cobb RMM, StopTech Street Pads + Stoptech Slotted disks, SouthBend Enduro Stage3 clutch, genpu TMM + CS Insert, TheSpeedLine 2X Rear Cross Floor and Rear Middle Lower Strut bars, Tanabe 4 Point Under Brace, Whiteline Bumpsteeer corection kit
JBR Tru-3" + CS CAI Box, SU TMIC, Cobb XLE, NGK LTR7IX, UR v3 catted DP and res&catted TP, Cobb CatBack, GS EBCS, Autotech internals, GTX3071, CS 3.5BAR, Guardian Angel, CoolingMist WMI, VCTS Delete, stock ported IM
SP63 87.5mm 4032 9.5:1 pistons, Manley rods, CA625+ head studs, Clevite AL main bearings, King rod bearings, CP-e safe seals, DCR VVT, Koyorad radiator.
StratiVersaTuned FTW to 28PSI, self-tuned to 32PSI

2008 Icy Blue Mazda CX7 6 Speed Manual
SU TMIC, Autotech HPFP internals, Cobb XLE, Cobb EBCS
GTX2867R gen2, stock spark plugs, stock intake, stock cats and stock exhaust FTW
self-Versatuned to 22PSI
mituc is offline   Reply With Quote
 Old 05-14-2014, 05:01 PM   #4
 
sriser66's Avatar
 
Join Date: May 2009
Location: Gainesville, GA
Posts: 380   (View Stats)
iTrader: (4)
Rep Power: 0
sriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the world
Thanks: 175
Thanked 372 Times in 201 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

Thanks for the info. I will check it out and I never thought of the injectors getting stuck. It just seems so random that it only happens when I get gas.

Sent from my SCH-I535 using Tapatalk
__________________


2006 MS6- GTX3071R, Freek Tuned, HKS BOV, Grimmspeed EBCS, Autotech internals, CP-e TMIC, Ebay downpipe, Matt Damond Catch Can, Densos ITV-22, HTP 3" Intake and TIP, Cobb AP v3, EGR delete, Throttle body coolant bypass, JBR 80 Duro RMM, JBR 80 Duro PMM, Devils own Stage 2 70/30 Meth, CP-e Safe Seals, Koni Yellows.

13.6 1/4 time on self tuned GTX3071r, still tuning in process.

383hp on dynojet with 198,000 miles on original clutch and original engine!!!!!!!!

Freektune for the win!!
sriser66 is offline   Reply With Quote
 Old 05-14-2014, 05:13 PM   #5
 
Enki's Avatar
 
Join Date: Nov 2008
Location: Tucson, AZ
Posts: 7,539   (View Stats)
iTrader: (4)
Rep Power: 9884
Enki is the leader of the worldEnki is the leader of the worldEnki is the leader of the worldEnki is the leader of the worldEnki is the leader of the worldEnki is the leader of the worldEnki is the leader of the worldEnki is the leader of the worldEnki is the leader of the worldEnki is the leader of the worldEnki is the leader of the world
Thanks: 7,218
Thanked 19,287 Times in 4,841 Posts
Groans: 189
Groaned at 40 Times in 36 Posts
Not Ranked  0 score     
Default

Protip: Don't top off the tank. Pull your evap line and see if it reeks of fuel; that's probably your problem.
__________________




http://www.mazdaspeedforums.org/forum/signaturepics/sigpic1981_1.gif
Enki is offline   Reply With Quote
 Old 05-16-2014, 08:52 AM   #6
 
Tubescorcher's Avatar
 
Join Date: Jun 2012
Location: Blackwood, NJ
Posts: 52   (View Stats)
iTrader: (1)
Rep Power: 0
Tubescorcher is the leader of the worldTubescorcher is the leader of the worldTubescorcher is the leader of the worldTubescorcher is the leader of the worldTubescorcher is the leader of the worldTubescorcher is the leader of the worldTubescorcher is the leader of the worldTubescorcher is the leader of the worldTubescorcher is the leader of the worldTubescorcher is the leader of the worldTubescorcher is the leader of the world
Thanks: 6
Thanked 110 Times in 14 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

I had same thing happen twice in the last two fill ups!! I didn't log it. After gassing car. I go to start it dies. When it does start AFR's go from normal 14.5 down to 9. Rough idol. Didn't throw a CEL. After letting car run 30 seconds then stopping and restarting it goes back to normal. Never happened before.
Tubescorcher is offline   Reply With Quote
 Old 05-17-2014, 02:25 PM   #7
 
sriser66's Avatar
 
Join Date: May 2009
Location: Gainesville, GA
Posts: 380   (View Stats)
iTrader: (4)
Rep Power: 0
sriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the worldsriser66 is the leader of the world
Thanks: 175
Thanked 372 Times in 201 Posts
Groans: 0
Groaned at 1 Time in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

I got gas again yesterday and did not top off the tank and it did the same thing. It is really weird. I also checked my exhaust bolts and we are good there.

Sent from my SCH-I535 using Tapatalk
__________________


2006 MS6- GTX3071R, Freek Tuned, HKS BOV, Grimmspeed EBCS, Autotech internals, CP-e TMIC, Ebay downpipe, Matt Damond Catch Can, Densos ITV-22, HTP 3" Intake and TIP, Cobb AP v3, EGR delete, Throttle body coolant bypass, JBR 80 Duro RMM, JBR 80 Duro PMM, Devils own Stage 2 70/30 Meth, CP-e Safe Seals, Koni Yellows.

13.6 1/4 time on self tuned GTX3071r, still tuning in process.

383hp on dynojet with 198,000 miles on original clutch and original engine!!!!!!!!

Freektune for the win!!
sriser66 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem after problem: Running rich & Fuel cuts wherewuat 2010 MS3 - Troubleshoot/Diagnostics 30 01-30-2014 01:13 PM
Low Idle & WOT Fuel Pressure Fix khopwood77 2010 MS3 - Troubleshoot/Diagnostics 3 06-18-2013 12:45 PM
Low fuel pressure at idle event MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection 53 07-02-2012 12:03 AM
60psi fuel pressure at idle! CCC MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection 31 10-04-2011 05:28 AM
Low Fuel Pressure but Rich A/F Ratio akbrazil 2010 MS3 - ECU Computer Tuning 16 04-26-2011 05:04 AM


All times are GMT -7. The time now is 01:32 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.28633 seconds with 25 queries