register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> MazdaSpeed 3 - How-To's

MazdaSpeed 3 - How-To's MazdaSpeed 3 - How-To's - Want help out fellow owners? Post How-To's to simplify future installations for others.


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Like Tree2Likes
  • 1 Post By 08mzr
  • 1 Post By Tomas
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 02-05-2019, 04:42 PM   #1
 
raven4life's Avatar
 
Join Date: Oct 2018
Posts: 5   (View Stats)
iTrader: (0)
Rep Power: 0
raven4life is an unknown quantity at this point
Thanks: 4
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default No heat at idle

My car warms up from a cold start but when I drive and come to a stop cold air comes out but if I rev it or drive the heat is hot also the lower radiator hose is cold


Sent from my iPhone using Tapatalk
raven4life is offline   Reply With Quote
 Old 02-05-2019, 08:17 PM   #2
 
08mzr's Avatar
 
Join Date: Nov 2014
Location: Chicago, IL
Posts: 641   (View Stats)
iTrader: (0)
Rep Power: 0
08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world
Thanks: 105
Thanked 187 Times in 135 Posts
Groans: 11
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

In my expirence, 90% of the time is low coolant, 5% is air in the system because of a leak or recent cooling system repair, and 5% other.
Start with checking coolant level and be sure the system is properly bled a d that you have no leaks.
If it was a thermostat issue you would have poorish heat while driving.
With most owners never exchanging coolant as they're supposed to, replacing the thermostat is good maintenance, but dont expect it to fix you're issue.
raven4life likes this.
__________________
2008 Metro Gray Mica Speed 3-SOLD
Corksport SRI
Corksport TIP
JBR 80 duro RMM
Cobb AP v3
Autotech internals
CX Racing FMIC
SPC rear camber arms
Hawk HPS pads front and rear
FREEKTUNE OTS+
1998 Civic - SOLD
2011 Speed3 200k+ miles Stock -Daily
08mzr is offline   Reply With Quote
 Old 02-05-2019, 08:36 PM   #3
 
raven4life's Avatar
 
Join Date: Oct 2018
Posts: 5   (View Stats)
iTrader: (0)
Rep Power: 0
raven4life is an unknown quantity at this point
Thanks: 4
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Neutral  -1 score     
Default

How would I bleed the system? And also the coolant reservoir is at the max amount


Sent from my iPhone using Tapatalk
raven4life is offline   Reply With Quote
 Old 02-06-2019, 04:44 AM   #4
 
08mzr's Avatar
 
Join Date: Nov 2014
Location: Chicago, IL
Posts: 641   (View Stats)
iTrader: (0)
Rep Power: 0
08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world08mzr is the leader of the world
Thanks: 105
Thanked 187 Times in 135 Posts
Groans: 11
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

Have you had to add any coolant to it?
Bleeding is usually done by just letting the car run up to operating temp with the reservoir/radiator cap off. After it's up to operating temp let it run for a little while longer, revving it to 1500rpm during the warm up and running process helps circulate coolant.
After letting it run I like to turn the car off and let it sit without the cap on it until it cools and then repeat the process. I have had air escape a lot during the cool down proccess.
Some people like to jack the car up on just the side with the reservoir, but this is up to you.
__________________
2008 Metro Gray Mica Speed 3-SOLD
Corksport SRI
Corksport TIP
JBR 80 duro RMM
Cobb AP v3
Autotech internals
CX Racing FMIC
SPC rear camber arms
Hawk HPS pads front and rear
FREEKTUNE OTS+
1998 Civic - SOLD
2011 Speed3 200k+ miles Stock -Daily
08mzr is offline   Reply With Quote
The Following User Says Thank You to 08mzr For This Useful Post:
raven4life (02-07-2019)
 Old 02-07-2019, 10:45 AM   #5
 
Thor Hammer's Avatar
 
Join Date: Jun 2015
Location: Santa Cruz, CA.
Posts: 1,833   (View Stats)
iTrader: (0)
Rep Power: 0
Thor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the world
Thanks: 999
Thanked 606 Times in 467 Posts
Groans: 209
Groaned at 5 Times in 5 Posts
Not Ranked  0 score     
Default

Originally Posted by raven4life View Post
My car warms up from a cold start but when I drive and come to a stop cold air comes out but if I rev it or drive the heat is hot also the lower radiator hose is cold


Sent from my iPhone using Tapatalk
You may have a faulty thermostat that's sticking. Or like stated, low coolant. I would drain and fill with new coolant, bleed, and go. Do not open the cap when the engine is hot as the system is under positive pressure!
__________________
2007 MS6- H&R Coilovers/ C-PE Catted DP/Corksport HPFP Internals/ AEM CAI/ ETS TMIC/ CPE Austenite Dual CBE/ CPE TIH/ Synapse Synchronic/ Freektuned/ AP Short Shifter/ AWR RMM and OEM TMM with CS Inserts/ Southbend Stage 2 Endurance/Stop Tech Slotted Rear and DBA T3 4000 Series Front with EBC Reds/CPE xFlex Rear Diff Mount/ Whiteline Rear Sway Bar/DSS Level 2.9 Rear Axles
Thor Hammer is offline   Reply With Quote
The Following User Says Thank You to Thor Hammer For This Useful Post:
raven4life (02-07-2019)
 Old 02-07-2019, 10:52 AM   #6
 
raven4life's Avatar
 
Join Date: Oct 2018
Posts: 5   (View Stats)
iTrader: (0)
Rep Power: 0
raven4life is an unknown quantity at this point
Thanks: 4
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

I haven’t added any coolant and never took the cap off. Just started to happen with it was -30 outside


Sent from my iPhone using Tapatalk
raven4life is offline   Reply With Quote
 Old 02-07-2019, 12:03 PM   #7
Bob Ross Fanclub
 
Tomas's Avatar
 
Join Date: Jan 2009
Location: SEFL
Posts: 3,785   (View Stats)
iTrader: (8)
Rep Power: 4303
Tomas is the leader of the worldTomas is the leader of the worldTomas is the leader of the worldTomas is the leader of the worldTomas is the leader of the worldTomas is the leader of the worldTomas is the leader of the worldTomas is the leader of the worldTomas is the leader of the worldTomas is the leader of the worldTomas is the leader of the world
Thanks: 4,519
Thanked 8,187 Times in 2,338 Posts
Groans: 0
Groaned at 35 Times in 20 Posts
Not Ranked  0 score     
Default

At -30F I am not sure the thermostat will ever open. You know how cold that is nigga? Fuuuuuu.
raven4life likes this.
__________________

MAKE LOVE TO THE CANVAS
Tomas is offline   Reply With Quote
The Following 3 Users Say Thank You to Tomas For This Useful Post:
Db09ms3 (02-25-2019), raven4life (02-07-2019), Thor Hammer (02-07-2019)
 Old 02-07-2019, 01:09 PM   #8
 
Jeff23spl's Avatar
 
Join Date: Sep 2013
Location: Quebec
Posts: 1,770   (View Stats)
iTrader: (0)
Rep Power: 0
Jeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the world
Thanks: 133
Thanked 474 Times in 372 Posts
Groans: 2
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

to bleed it, you can lift the front higher than the back while doing the above instruction to help the bubbles to get out.

It can also be your heater core that is plugged with deposit when someone never replace the coolant. A flush with cleaning product may help but when it is too late, it means a core replacement....
Some leak fixing stuff is terrible at blocking heater core and some other part of the system...Never use that.

In the other hand, you may monitor your coolant temp, it takes a lot more time to heat up a car with a -30deg C outside...And when the turbo is used, you quickly feel the heat generated....

Our thermostat are likely to bloc at some opening position a bit more than usual. If you monitor an unstable temperature, it may return a bad TH. During very cold days, it is likely to get up to temp and then drop a bit while slowing down 1 or 2 times but if it keep going up and down when the car is up to temp for a long while, your TH is bad.....

I would start with a new TH, a coolant flush and new coolant perfectly bleeded. Then if it isn't better, i would investigate into a core replacement but it is usually a pita...
__________________
Mazda for life...or until i can afford something better...

2007 rusted Speed6... in progress...
1993 Ford Probe KLZE 143dB
2012 Mazda3 Gs-sky 6.5l/100 when transporting speed parts
1989 GM 6.2 diesel pickup
Wife drive 2010 CX7

2007 speed3 burned (i'm proud to ran 12.7s with it)

...Because French Canadian...
Jeff23spl is online now   Reply With Quote
The Following User Says Thank You to Jeff23spl For This Useful Post:
raven4life (02-07-2019)
 Old 02-07-2019, 01:30 PM   #9
 
MSMS3's Avatar
 
Join Date: Jun 2009
Posts: 2,393   (View Stats)
iTrader: (0)
Rep Power: 1047
MSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the worldMSMS3 is the leader of the world
Thanks: 1,240
Thanked 1,799 Times in 958 Posts
Groans: 135
Groaned at 46 Times in 30 Posts
Not Ranked  0 score     
Default

Originally Posted by 08mzr View Post
Have you had to add any coolant to it?
Bleeding is usually done by just letting the car run up to operating temp with the reservoir/radiator cap off. After it's up to operating temp let it run for a little while longer, revving it to 1500rpm during the warm up and running process helps circulate coolant.
After letting it run I like to turn the car off and let it sit without the cap on it until it cools and then repeat the process. I have had air escape a lot during the cool down proccess.
Some people like to jack the car up on just the side with the reservoir, but this is up to you.
OP just do this outlined above. I call it "burping" the air out of the system. Same thing.

I just had to increase antifreeze to water concentration for winter. I was selling the car (my baby) to someone in a more frigid climate. I run a higher water ratio most of the year. I drained out about a gallon from the plastic plug in the bottom left side of the radiator and then began adding pure antifreeze and testing until I got the ratio to 50-50.

I left the cap off the reservoir, it did a lot, I mean a lot of burping of air before I got it all out. Had to leave it running quite a while with the cap off until the coolant level normalized. Turned it off, let it sit, watched the reservoir and then restarted it and ran it some more. As more and more air escaped I slowly topped off with a 50-50 solution until it stabilized at the proper level.

You may just have air in the system. Good time for a drain and flush if it's never been done, anyway.

Good luck.
__________________
2017 Audi Q5 3.0 T (supercharged) Stage 2, EPL tune, JHM overdrive crank pulley, ZF8 TCU tune, aFe/034 intake, modified air box. 430 hp.

Sunlight Silver '08 MS3 GT Mods: (Sold 1/25/2019 after 10 years of ownership)
BNR Stage 1 (to fix smoking K04 turbo), TurboXS 3" Catless DP/RP "Stealthback" into stock CBE, Vibrant 3 inch Ultra Quiet Resonator in RP section, Magnaflow 3 1/2" exhaust tip, Mazdaspeed CAI w/air straightener and K&N conical filter, NGK 6510 Iridium IX one step colder plugs, Hypertech tune, Autotech HPFP internals, Stock BPV (works perfectly), Yokohama Advan Neova AD08R's (stock size on stock rims); Hawk HPS pads; SURE RMM; Grimmspeed EBCS (2 port mode), Bilstein B6's, SPC rear camber arms.
MSMS3 is offline   Reply With Quote
 Old 02-19-2019, 05:27 PM   #10
 
raven4life's Avatar
 
Join Date: Oct 2018
Posts: 5   (View Stats)
iTrader: (0)
Rep Power: 0
raven4life is an unknown quantity at this point
Thanks: 4
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default No heat at idle

So I replaced the thermostat a couple days ago and the heat worked but my temps would go up on the high way and when I slow down/stop it goes down about 20 degrees. And just last night I got cold air at idle again


Sent from my iPhone using Tapatalk
raven4life is offline   Reply With Quote
 Old 02-25-2019, 07:29 AM   #11
 
Jeff23spl's Avatar
 
Join Date: Sep 2013
Location: Quebec
Posts: 1,770   (View Stats)
iTrader: (0)
Rep Power: 0
Jeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the world
Thanks: 133
Thanked 474 Times in 372 Posts
Groans: 2
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

have you bleeded it again after running for a while with the front leveled ?

I bet your belt was spinning fine around the pump so if the air is gone and TH is new, the only part remaining is a plugged heater core...

I would give few more try at bleeding it with enough temperature.
I cost nothing while replacing the heater core is a pita...
__________________
Mazda for life...or until i can afford something better...

2007 rusted Speed6... in progress...
1993 Ford Probe KLZE 143dB
2012 Mazda3 Gs-sky 6.5l/100 when transporting speed parts
1989 GM 6.2 diesel pickup
Wife drive 2010 CX7

2007 speed3 burned (i'm proud to ran 12.7s with it)

...Because French Canadian...
Jeff23spl is online now   Reply With Quote
 Old 02-25-2019, 04:32 PM   #12
 
raven4life's Avatar
 
Join Date: Oct 2018
Posts: 5   (View Stats)
iTrader: (0)
Rep Power: 0
raven4life is an unknown quantity at this point
Thanks: 4
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

It was good for a couple days after I bled it then again it happened today so I bled it and it’s good again. Also when my car is up in temp I see slight steam coming from the top of the rad could that be a hole? My coolant level hasn’t moved since


Sent from my iPhone using Tapatalk
raven4life is offline   Reply With Quote
 Old 02-26-2019, 09:17 AM   #13
 
Jeff23spl's Avatar
 
Join Date: Sep 2013
Location: Quebec
Posts: 1,770   (View Stats)
iTrader: (0)
Rep Power: 0
Jeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the worldJeff23spl is the leader of the world
Thanks: 133
Thanked 474 Times in 372 Posts
Groans: 2
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

sometimes you have some drops when filling the rad and it makes that but vanish after few days of driving. If it is dry outside and it keep smoking, yest you may have a leaking rad.
__________________
Mazda for life...or until i can afford something better...

2007 rusted Speed6... in progress...
1993 Ford Probe KLZE 143dB
2012 Mazda3 Gs-sky 6.5l/100 when transporting speed parts
1989 GM 6.2 diesel pickup
Wife drive 2010 CX7

2007 speed3 burned (i'm proud to ran 12.7s with it)

...Because French Canadian...
Jeff23spl is online now   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
My 2008 Speed 3 will not hold an idle and rides rough at low rpm and low idle Dgms3 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 17 11-23-2016 02:42 PM
MS6 no heat mattymogue MazdaSpeed 3/6 - Troubleshoot/Diagnostics 10 01-02-2013 06:43 PM
NO HEAT? avento MazdaSpeed 3/6 - Troubleshoot/Diagnostics 2 11-02-2012 08:45 PM


All times are GMT -7. The time now is 09:16 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.34179 seconds with 25 queries