register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3 MZR Gen2 Forums (2010-2013)
> 2010 MS3 - Troubleshoot/Diagnostics


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 01-11-2019, 01:39 PM   #1
 
Sergiospeed3's Avatar
 
Join Date: Jan 2019
Posts: 9   (View Stats)
iTrader: (0)
Rep Power: 0
Sergiospeed3 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default p0171 system lean and overboosting?

I Have a gen2 speed3. Have had it for about a year and it is only my second car. I am very new to the mechanical aspects of cars, but am very much interested and want to learn the ins and out of my car. My car is all stock with the exception of a cobb intake with a cobb turbo inlet hose and a synapse engineering bypass valve.
So I got the code p0171 system lean and I noticed around the same time my car started overboosting. I checked for leaks around the intake and couldn't find anything, but the bypass valve hose was pretty worn out so I replaced it. And for good measure I decided to clean the maf sensor. Well that didn't help. I did take it to a mechanic and he did a smoke test and claimed to have found leaks in the exhaust, turbo, and catalytic converter. And said he would have to replace all those gaskets. I attached pictures of the diagnosis and parts. Sounds like bogus to me though, that coincidentally all those started giving me a problem at the same time. Also the turbo overboosting to me says that the problem might be around the turbo area. If I drive a few miles without boosting my cel goes off and only goes on as soon as I boost. My boosts climbs to max psi almost immediately as I enter boost. I've done some research and have found that this can be a waste gate problem. But if that was the case shouldn't there be more codes than just a p0171. I plan on removing the TMIC tomorrow and checking around the waste gate area. Just wondering if any of you have had similar problems. I have searched the forums and can't find anyone with an overboosting and p0171 problem. Also don't have money for accessport at the moment by I do plan on buying one later on this year.
Attached Images
File Type: jpg Speed3 diagnosis.jpg (1.93 MB, 3 views)
File Type: jpg Speed3 parts.jpg (1.78 MB, 3 views)
Sergiospeed3 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random P0171 Code: System Too Lean (Bank 1) infeKteDx 2010 MS3 - Engine, Transmission & Driveline 91 09-28-2018 02:18 PM
P0171 code after TIH Install - Lean AFR at Idle char181 2010 MS3 - Troubleshoot/Diagnostics 5 11-10-2014 08:58 PM
P0171 - Lean boatis 2010 MS3 - Troubleshoot/Diagnostics 10 02-26-2014 05:14 PM


All times are GMT -7. The time now is 02:23 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.22930 seconds with 21 queries