register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3 MZR Gen2 Forums (2010-2013)
> 2010 MS3 - Troubleshoot/Diagnostics


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Like Tree1Likes
  • 1 Post By Thor Hammer
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 11-10-2017, 04:08 PM   #1
 
tmaiorca's Avatar
 
Join Date: May 2015
Location: NJ
Posts: 189   (View Stats)
iTrader: (0)
Rep Power: 0
tmaiorca is a glorious beacon of lighttmaiorca is a glorious beacon of lighttmaiorca is a glorious beacon of lighttmaiorca is a glorious beacon of lighttmaiorca is a glorious beacon of lighttmaiorca is a glorious beacon of light
Thanks: 67
Thanked 10 Times in 8 Posts
Groans: 1
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default Sway Bar Bushing Noise

I've had a pretty bad annoying clunking/rattling sound coming for the rear for quite some time, so I decided to replace my sway bar end links with MevoTech ones since the OEM ones were shot.

Unfortunately, the clunking has gotten worse and its driving me insane. I suspect it is the sway bar bushings, but what do you guys think? On the most level roads without and cracks/potholes, the noise is extremely loud.

Link to vid (really starts to be present at 10 seconds): https://www.youtube.com/watch?v=Tt8pV6--A5E
__________________
RIP 2006 MS6:: CP-E CAI // 3" CP-E TIP // SU Turbosmart BPV // M2 3" Catless DP // Cobb AP v2 //CP-E Rear Motor Mount // JBR SSP //JBR OCC // 1" Springs // EGR Unplugged // JBR Coolant Bypass // JBR TIG

2010 Genpu:: JBR SRI // JBR TIH // SU Turbosmart Full Recirc BPV // Cobb AP v2 // S-OTS Tuned // RallyArmor UR
tmaiorca is offline   Reply With Quote
 Old 01-12-2018, 06:26 AM   #2
 
Rygar's Avatar
 
Join Date: Nov 2014
Posts: 21   (View Stats)
iTrader: (0)
Rep Power: 0
Rygar is an unknown quantity at this point
Thanks: 3
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Did you replace the bushings?

Mine sounds like this and from some internet sleuthing the likely culprit is the sway bar bushings. I have OEM replacements but haven't done the work yet.

When it gets particularly cold (around -5°C or less) the clunking turns into squeaking.
__________________
2010 Mazdaspeed3
1998 Lancer Evolution
Rygar is offline   Reply With Quote
 Old 01-12-2018, 06:43 AM   #3
 
kTaLgsTo's Avatar
 
Join Date: Dec 2017
Location: Idaho
Posts: 86   (View Stats)
iTrader: (0)
Rep Power: 9
kTaLgsTo is a splendid one to beholdkTaLgsTo is a splendid one to beholdkTaLgsTo is a splendid one to beholdkTaLgsTo is a splendid one to beholdkTaLgsTo is a splendid one to beholdkTaLgsTo is a splendid one to beholdkTaLgsTo is a splendid one to behold
Thanks: 8
Thanked 16 Times in 16 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Sounds like your end links aren't tight to me....
__________________
2011 MS3 Tech - 2008 Jeep Grand Cherokee CRD - 1988 Crown Vic LTD LX - 1985 Lincoln Town Car Signature
The key to happiness is owning a car ridiculously slower than your 'fast' car.
kTaLgsTo is online now   Reply With Quote
 Old 01-12-2018, 07:24 AM   #4
 
Rygar's Avatar
 
Join Date: Nov 2014
Posts: 21   (View Stats)
iTrader: (0)
Rep Power: 0
Rygar is an unknown quantity at this point
Thanks: 3
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Originally Posted by kTaLgsTo View Post
Sounds like your end links aren't tight to me....
That's also been a common thing I've read in relation to these noises/bushing blame.
__________________
2010 Mazdaspeed3
1998 Lancer Evolution
Rygar is offline   Reply With Quote
 Old 01-12-2018, 10:55 AM   #5
 
Thor Hammer's Avatar
 
Join Date: Jun 2015
Location: Santa Cruz, CA.
Posts: 1,232   (View Stats)
iTrader: (0)
Rep Power: 225
Thor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the worldThor Hammer is the leader of the world
Thanks: 612
Thanked 363 Times in 293 Posts
Groans: 84
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

Originally Posted by Rygar View Post
Did you replace the bushings?

Mine sounds like this and from some internet sleuthing the likely culprit is the sway bar bushings. I have OEM replacements but haven't done the work yet.

When it gets particularly cold (around -5°C or less) the clunking turns into squeaking.
If you spray some lubricant into the bushings they will quiet down. It works for me and many others.
Rygar likes this.
__________________
2007 MS6- H&R Coilovers/ C-PE Catted DP/Corksport HPFP Internals/ AEM CAI/ ETS TMIC/ CPE Austenite Dual CBE/ CPE TIH/ Synapse Synchronic/ Freektuned/ AP Short Shifter/ AWR RMM and OEM TMM with CS Inserts/ Southbend Stage 2 Endurance/Stop Tech Slotted Rear and DBA T3 4000 Series Front with EBC Reds/CPE xFlex Rear Diff Mount/ Whiteline Rear Sway Bar/DSS Level 2.9 Rear Axles

Waiting for Install: Damond OCC/ CS Injector Seals/ WMI/
Thor Hammer is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Easy OEM Front Sway Bar Bushing Replacement spl 2010 MS3 - Suspension & Brakes 7 12-30-2017 07:42 PM
How-To: MS6 Front Sway Bar Bushing TiGraySpeed6 MazdaSpeed 6 - How-To's 44 08-23-2017 09:16 AM
How-To: Front Sway Bar Bushing replacement w/o dropping subframe DeadWayt MazdaSpeed 3 - How-To's 62 06-15-2016 01:11 PM
MS6 driver-side sway bar bushing removal wdautrem MazdaSpeed 3/6 - Suspension & Brakes 16 06-01-2012 10:44 PM


All times are GMT -7. The time now is 07:12 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2014 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.24835 seconds with 23 queries