register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> Mazdaspeed3/6 General Discussion


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 09-13-2017, 10:12 AM   #1
 
1324Kyle's Avatar
 
Join Date: May 2015
Posts: 58   (View Stats)
iTrader: (0)
Rep Power: 0
1324Kyle is on a distinguished road
Thanks: 14
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 8 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default BOV Boost Leak (Video) Help Please!

I have a boost leak and tried the blowing smoke into the engine method and seems to have worked for me. Below I included a video of the smoke coming out of what seems to be the connection between the BOV and the tube. I'm assuming I either need a new gasket or a new BOV.

https://youtu.be/BpttOMAOvDc

https://imgur.com/a/unBtV

Also, does anyone know if there needs to be an O-ring or something, the first time I drove the car, 15 minutest after I bought it, the BOV literally blew off while driving (about two years ago) and when I went to put it back on there was only the gasket and the actual BOV. It's a HKS BOV by the way.
I'm assuming this wouldn't make a difference although because I've been driving it hard and fine for the past year and 11 months till this boost leak started.

Thanks
1324Kyle is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boost leak testing, possibly Wastegate/Actuator leak AgentWh0 2010 MS3 - Troubleshoot/Diagnostics 0 08-04-2015 12:29 PM
Not hitting boost targets, not boost leak ADHDAdditiv MazdaSpeed 3/6 - Troubleshoot/Diagnostics 28 07-18-2014 02:18 PM
Not hitting Stage 2 boost targets (boost leak?) Bubba Ho-Tep 2010 MS3 - ECU Computer Tuning 15 04-26-2012 08:25 PM
Vacuum leak, but no boost leak? vbt101 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 23 04-18-2010 01:06 PM


All times are GMT -7. The time now is 10:51 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2014 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.23098 seconds with 20 queries