register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> Mazdaspeed3/6 General Discussion


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 03-13-2019, 10:56 PM   #1
 
th3_heis3nberg's Avatar
 
Join Date: Sep 2016
Location: good ol Belle Plaine, MN
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
th3_heis3nberg is an unknown quantity at this point
Thanks: 5
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default codes p2188 and p0234 please help

so today while driving my car it was running a bit sluggish and when i went into boost it would just die off. after awhile the check engine light came on saying i had overboost issues and fuel was running too rich at idle. the car is pretty much stock besides a tmm and a cobb cai. the car sits at 105k can anyone please tell me whats going on? i can provide more info if someones willing to help.
th3_heis3nberg is offline   Reply With Quote
 Old 03-14-2019, 06:27 AM   #2
MSF's Punishing Member
 
Pu Manchu's Avatar
 
Join Date: Apr 2011
Posts: 2,911   (View Stats)
iTrader: (7)
Rep Power: 2759
Pu Manchu is the leader of the worldPu Manchu is the leader of the worldPu Manchu is the leader of the worldPu Manchu is the leader of the worldPu Manchu is the leader of the worldPu Manchu is the leader of the worldPu Manchu is the leader of the worldPu Manchu is the leader of the worldPu Manchu is the leader of the worldPu Manchu is the leader of the worldPu Manchu is the leader of the world
Thanks: 5,139
Thanked 5,271 Times in 1,832 Posts
Groans: 541
Groaned at 179 Times in 116 Posts
Not Ranked  0 score     
Default

could be a ton of things... losing air after its metered, bad maf, bad injector. the cheapest thing to do is clean your maf and check all hoses.
__________________
94 M
06 MS6
Pu Manchu is offline   Reply With Quote
 Old 03-16-2019, 11:22 AM   #3
 
th3_heis3nberg's Avatar
 
Join Date: Sep 2016
Location: good ol Belle Plaine, MN
Posts: 7   (View Stats)
iTrader: (0)
Rep Power: 0
th3_heis3nberg is an unknown quantity at this point
Thanks: 5
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

I figured out what the problem was when i put in my auto tech HPFP internals. The HPFP itself somehow cleared the rich idle code. Could have been some unsecure fittings or hoses but whatever it was it did the job! I also found that my TIH was very loose and after the install I had no codes about overbooost!
th3_heis3nberg is offline   Reply With Quote
 Old 03-16-2019, 11:33 AM   #4
Police - Grammarhead
 
Vansquish's Avatar
 
Join Date: Sep 2009
Location: Metro Detroit, MI
Posts: 5,420
iTrader: (1)
Rep Power: 3635
Vansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the worldVansquish is the leader of the world
Thanks: 8,495
Thanked 6,870 Times in 2,696 Posts
Groans: 1,841
Groaned at 45 Times in 26 Posts
Default

You have an aftermarket intake and exhaust on the car. The car breathes better than it would have when it was stock.

The tune you are currently using is hitting a boost and/or load limit and cutting power because of the lowered restriction in your intake and exhaust systems. You need a tune that accounts for the increased air and exhaust flow volumes.
__________________
Having trouble finding something on MSF? Use MS3Shadow's search tool:SEARCH MSF HERE!

Vansquish is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
p0300 and p0234 after exhaust? cocoleveo7686 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 6 11-24-2014 12:28 PM
my friends car caught two codes code p2006&p2188 impact-blue MazdaSpeed 3/6 - Troubleshoot/Diagnostics 6 11-04-2013 06:22 PM
P0234 advice? Swinger13 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 0 10-21-2012 08:25 PM
P0234 Overboost nybe0010 2010 MS3 - Troubleshoot/Diagnostics 5 10-10-2012 08:00 AM


All times are GMT -7. The time now is 02:07 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.24894 seconds with 22 queries