register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> Mazdaspeed3/6 General Discussion


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 09-11-2017, 12:37 PM   #1
 
darkmx-6's Avatar
 
Join Date: Jun 2010
Posts: 34   (View Stats)
iTrader: (0)
Rep Power: 89
darkmx-6 is on a distinguished road
Thanks: 7
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 2 Times in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default EGR code Not going away, brandnew EGR valve

Hello everyone, I followed the how to for the EGR code like 3 times. I also bought a new egr off of rockauto.com
Used Techron fuel treatment and a friend suggested a bottle of rubbing alcohol (tired on different tanks of gas).
I've done all this and still have No Change...

Well now I have a misfire code too...

I think it may be clogged somewhere between the EGR valve and the exhaust manifold.

Someone suggested in the discussion after the how to that It could be gummed up intake valves.

That doesn't seem related to me but at this point I'm willing to try almost anything.

I know I can clear it with Access Point, but I need to pass inspection.

I hate EGRs, those things are the worst to try and fix, doesn't matter what car they are from.

Any Ideas would be helpful I'm thinking of tearing it apart tonight and driving the truck to work.

Any other ideas or anyone else come accross this?
darkmx-6 is offline   Reply With Quote
 Old 09-11-2017, 02:55 PM   #2
 
tom10122's Avatar
 
Join Date: May 2016
Location: Long Valley, NJ
Posts: 76   (View Stats)
iTrader: (0)
Rep Power: 21
tom10122 is just really nicetom10122 is just really nicetom10122 is just really nicetom10122 is just really nicetom10122 is just really nice
Thanks: 13
Thanked 8 Times in 8 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

I've had this resolved with a bottle of startron fuel treatment actually, misfire came first though, then the code for the egr. Put in enough to treat 512 gallons

Sent from my XT1565 using Tapatalk
tom10122 is offline   Reply With Quote
The Following User Says Thank You to tom10122 For This Useful Post:
darkmx-6 (09-12-2017)
 Old 09-12-2017, 05:03 AM   #3
 
GroceryGtr's Avatar
 
Join Date: Nov 2015
Location: Rochester Hills, MI
Posts: 293   (View Stats)
iTrader: (0)
Rep Power: 78
GroceryGtr is the leader of the worldGroceryGtr is the leader of the worldGroceryGtr is the leader of the worldGroceryGtr is the leader of the worldGroceryGtr is the leader of the worldGroceryGtr is the leader of the worldGroceryGtr is the leader of the worldGroceryGtr is the leader of the worldGroceryGtr is the leader of the worldGroceryGtr is the leader of the worldGroceryGtr is the leader of the world
Thanks: 0
Thanked 107 Times in 76 Posts
Groans: 0
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

if you just unplug it do you get any additional codes? You could pull the pipe that connects it to the IM. Its a pita to do but that would be the only area that could clog...and that would be unlikely to begin with. Its a pretty big pipe. can you list all the current codes you're getting?
__________________
"Sarcasm and shit talking are two different things. MSF offers the best advice, just delivered by sarcastic pricks, with your best interest in mind." -ThePedigree13

Silver 06 MS6 - DD stealth build - no show, all go....
'12 Abarth Challenge Car - very loud, very fast, very inconvenient to drive on the street...
GroceryGtr is offline   Reply With Quote
The Following User Says Thank You to GroceryGtr For This Useful Post:
darkmx-6 (09-12-2017)
 Old 09-12-2017, 06:47 AM   #4
 
darkmx-6's Avatar
 
Join Date: Jun 2010
Posts: 34   (View Stats)
iTrader: (0)
Rep Power: 89
darkmx-6 is on a distinguished road
Thanks: 7
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 2 Times in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

just those two codes, misfire multiple cylinders and EGR low flow.

I did take out the pipe and checked the intake manifold, then cleaned everything. It did have some build up but not enough to block it.

I have yet to clean the valves though.

I'll read the codes again tonight and see what I have.

After I clean the valves and it doesn't work I'll disconnect the EGR valve and see what codes I get.

Last edited by darkmx-6; 09-12-2017 at 06:56 AM. Reason: adding more info.
darkmx-6 is offline   Reply With Quote
 Old 09-12-2017, 07:06 AM   #5
 
darkmx-6's Avatar
 
Join Date: Jun 2010
Posts: 34   (View Stats)
iTrader: (0)
Rep Power: 89
darkmx-6 is on a distinguished road
Thanks: 7
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 2 Times in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

Originally Posted by tom10122 View Post
I've had this resolved with a bottle of startron fuel treatment actually, misfire came first though, then the code for the egr. Put in enough to treat 512 gallons

Sent from my XT1565 using Tapatalk
How many bottles did you use? I found 1 bottle for 48 gallons. Are there larger bottles than that?
darkmx-6 is offline   Reply With Quote
 Old 09-12-2017, 07:08 AM   #6
 
tom10122's Avatar
 
Join Date: May 2016
Location: Long Valley, NJ
Posts: 76   (View Stats)
iTrader: (0)
Rep Power: 21
tom10122 is just really nicetom10122 is just really nicetom10122 is just really nicetom10122 is just really nicetom10122 is just really nice
Thanks: 13
Thanked 8 Times in 8 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Originally Posted by darkmx-6 View Post
How many bottles did you use? I found 1 bottle for 48 gallons. Are there larger bottles than that?
There are bigger bottles that treat 512 gallons, I always bought them at a marine store. The bigger bottles are really for boats

Sent from my XT1565 using Tapatalk
tom10122 is offline   Reply With Quote
The Following User Says Thank You to tom10122 For This Useful Post:
darkmx-6 (09-12-2017)
 Old 09-12-2017, 06:48 PM   #7
 
darkmx-6's Avatar
 
Join Date: Jun 2010
Posts: 34   (View Stats)
iTrader: (0)
Rep Power: 89
darkmx-6 is on a distinguished road
Thanks: 7
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 2 Times in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

Was not able to take the intake off.
I have two codes though, misfire code is gone now.

the regular
P0401 Insufficient EGR Flow

and a new one

P0113 IAT Sensor 1 Circuit High Input

at least the misfire is gone I hope?

I'll disconnect the EGR tonight and drive it tomorrow.

Last edited by darkmx-6; 09-12-2017 at 09:03 PM.
darkmx-6 is offline   Reply With Quote
 Old 09-12-2017, 09:20 PM   #8
 
darkmx-6's Avatar
 
Join Date: Jun 2010
Posts: 34   (View Stats)
iTrader: (0)
Rep Power: 89
darkmx-6 is on a distinguished road
Thanks: 7
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 2 Times in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

Originally Posted by tom10122 View Post
There are bigger bottles that treat 512 gallons, I always bought them at a marine store. The bigger bottles are really for boats

Sent from my XT1565 using Tapatalk
Just ordered one off ebay for almost $30 should be here next week.
darkmx-6 is offline   Reply With Quote
 Old 09-13-2017, 03:58 PM   #9
 
Djohns's Avatar
 
Join Date: Dec 2013
Location: Plainfield, IL
Posts: 3,509   (View Stats)
iTrader: (3)
Rep Power: 1240
Djohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the world
Thanks: 1,620
Thanked 2,319 Times in 1,244 Posts
Groans: 81
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

Clean your maf, then clear the code to see if it comes back. Sometimes you can fix the issue but the code will remain until you clear it since it's saved.
__________________
2010 black mica speed3
The go: Depo racing: downpipe (100 cell count), custom: FMIC. HTP: 3.5" intake, under route piping. JBR: shortshifter, RSB. Autotech: HPFP internals. Go fast bits: hybrid BPV, VMR: 18x8.5 V710s, Bridgestone: potenza re760 245/40/18, KW: v3 coilovers,SPC: camber arms, freektuned, Damond Motorsports: dual OCC, PMM, PCV plate, RMM, TMM, EGR delete, FoSt mani, Corksport: battery box(fuck this thing), injector seals, Cobb: EBCS, AP v3. AEM: methanol. Seibon: carbon fiber hood. UR: catback. Bosch: 3bar. BNR: s4, DNP: EWG manifold, Tial: 38mm mvs EWG.

The show: 5% tint all around, 50% tint windshield, rally armor mudflaps, Sony XAV64BT touchscreen headunit, katskin leather interior, CPE relocation plate, Maisonvi weighted shift knob, Corksport hoodscoop, black housing headlights.

Soon:built motor
Djohns is offline   Reply With Quote
 Old 09-13-2017, 05:12 PM   #10
 
darkmx-6's Avatar
 
Join Date: Jun 2010
Posts: 34   (View Stats)
iTrader: (0)
Rep Power: 89
darkmx-6 is on a distinguished road
Thanks: 7
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 2 Times in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

as far as the EGR goes it's been cleared many times and keeps coming back I'll clear the codes tonight and start taking off the intake manifold so I can clean the intake valves.

May not be related But I'm sure it needs it the car has 175,000 miles
darkmx-6 is offline   Reply With Quote
 Old 09-13-2017, 05:16 PM   #11
 
Djohns's Avatar
 
Join Date: Dec 2013
Location: Plainfield, IL
Posts: 3,509   (View Stats)
iTrader: (3)
Rep Power: 1240
Djohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the world
Thanks: 1,620
Thanked 2,319 Times in 1,244 Posts
Groans: 81
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

Yea those valves definitely need to be cleaned. I still think it's possible that the EGR tube is clogged.
__________________
2010 black mica speed3
The go: Depo racing: downpipe (100 cell count), custom: FMIC. HTP: 3.5" intake, under route piping. JBR: shortshifter, RSB. Autotech: HPFP internals. Go fast bits: hybrid BPV, VMR: 18x8.5 V710s, Bridgestone: potenza re760 245/40/18, KW: v3 coilovers,SPC: camber arms, freektuned, Damond Motorsports: dual OCC, PMM, PCV plate, RMM, TMM, EGR delete, FoSt mani, Corksport: battery box(fuck this thing), injector seals, Cobb: EBCS, AP v3. AEM: methanol. Seibon: carbon fiber hood. UR: catback. Bosch: 3bar. BNR: s4, DNP: EWG manifold, Tial: 38mm mvs EWG.

The show: 5% tint all around, 50% tint windshield, rally armor mudflaps, Sony XAV64BT touchscreen headunit, katskin leather interior, CPE relocation plate, Maisonvi weighted shift knob, Corksport hoodscoop, black housing headlights.

Soon:built motor
Djohns is offline   Reply With Quote
 Old 09-13-2017, 05:33 PM   #12
 
darkmx-6's Avatar
 
Join Date: Jun 2010
Posts: 34   (View Stats)
iTrader: (0)
Rep Power: 89
darkmx-6 is on a distinguished road
Thanks: 7
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 2 Times in 1 Post
(Thread Starter)
Not Ranked  0 score     
Default

The tube it's self is not clogged I ran a wire through it, oven cleaner, foaming engine degreaser, tap water with pressure and compressed air. everything flowed right through it.

I'm about to take off the intake so taking the tube off again will be easy,but I'm sure it's not clogged.

I'll check it again though.
darkmx-6 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
valve guides? valve seal? valve stem? WHAT IS BLOWN?!?!?! eroler1 Gen2 MS3 General Discussion 32 12-29-2016 02:29 AM
TPMS code U0127 and ABS code B1318 Z32_MS3 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 19 05-12-2015 05:34 AM
Intake Valve Cleaning using valve overlap and DI injection window shift Vansquish MazdaSpeed 3/6 - ECU Computer Tuning 33 05-06-2014 06:00 PM
P0401 code just got my mazdaspeed 3 and this code popped up Steezyms3 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 12 04-23-2014 01:20 PM


All times are GMT -7. The time now is 09:31 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2014 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.28240 seconds with 23 queries