register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3/6 MZR Gen1 Forums (2006-2009)
> Mazdaspeed3/6 General Discussion


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Like Tree2Likes
  • 1 Post By darkmx-6
  • 1 Post By Fstrnyou
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 06-11-2018, 07:03 PM   #1
 
ProjectMPS's Avatar
 
Join Date: May 2018
Posts: 1   (View Stats)
iTrader: (0)
Rep Power: 0
ProjectMPS is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default New motor - Will crank, but not start

I bought a 2007 Mazda Speed 3 in the winter with a shot motor. The past 2 months have been very busy swapping in a new motor. The motor is from 2012 Mazda Speed 3 (used motor with about 90,000KM). From my knowledge there are not too many differences between the 2 motors.I replaced anything that was worn or broken: new clutch, new spark plugs, fresh fluids etc. I am using the transmission only the long block is newer it is a used motor. The motor turns over but doesn't spark. I have fuel. I have to check for spark.

I moved any parts I needed that the motor didn't come with from the old longblock to the new one.

The engine is cranking but won't start. It is throwing a P0335 - crankshaft positioning sensor circuit fault. I don't know what else to test.

If you need any other information please leave a message!
ProjectMPS is offline   Reply With Quote
 Old 06-12-2018, 05:13 AM   #2
 
kTaLgsTo's Avatar
 
Join Date: Dec 2017
Location: Idaho
Posts: 563   (View Stats)
iTrader: (0)
Rep Power: 118
kTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the world
Thanks: 84
Thanked 211 Times in 145 Posts
Groans: 10
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

Assuming the engine is in tip top shape, check all of your grounds, missing ground straps/wires can really eff you up.
__________________
2011 MS3 Tech - 2008 Jeep Grand Cherokee CRD - 1989 Crown Vic LTD LX - 1985 Lincoln Town Car Signature
The key to happiness is owning a car ridiculously slower than your 'fast' car.
kTaLgsTo is offline   Reply With Quote
 Old 06-12-2018, 05:24 AM   #3
 
Fstrnyou's Avatar
 
Join Date: Jul 2016
Location: Near Charlotte NC
Posts: 1,729   (View Stats)
iTrader: (0)
Rep Power: 273
Fstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the world
Thanks: 42
Thanked 461 Times in 347 Posts
Groans: 17
Groaned at 5 Times in 4 Posts
Not Ranked  0 score     
Default

I would think a CPS fault will trigger a no-start safety measure in the ECU. How would it know when to fire the coils if the ECU doesn't know where the crank is?
__________________
2006 MS6 GT - 158k Miles (Forged @ 157,116)
Manley 88mm Pistons & H-Tuff Rods, King Bearings
Stock Head/Cams, Stock Int/Exh Manifolds
Versatuner, 3-bar MAP, ITV22's, CP-e TMIC
CS Turbo/DP/RP/HPFP/BPV/R-DiffMount
White Widow F-DiffMount, Whiteline RSB
Russian Bushings in Back, Poly FSB Bushings, Magnaflow CBE
JBR Tru-3.5/3-port EBCS/EGR-D
Damond RMM/PMM/Stage 2 OCC/PCV Plate
AWR TMM on stand-by
Other rides:
2002 Tacoma ExtCab 2.4L 5spd 2WD - 355k mile Parts Getter
2004 Olds Alero ECOtec 2.2 - Broken (since Christmas 2015)
History:
2008 GSX-R 1000 - Stolen (With several runs past 180, I'd probably be dead by now if it wasn't stolen. So, in a way, I'm thankful.)
1988 RX-7 TII - Sold (Megasquirt, streetport, filter-on-turbo SRI, custom TBE, 20psi boost creep on OE turbo, OE TMIC on ice, 13.467 @ 105.44) apex seals said buh bye!
1985 Camaro - Sold (est. 265bhp 5.7 swap, Edelbrock intake & Hooker headers)
Fstrnyou is offline   Reply With Quote
 Old 06-12-2018, 08:43 AM   #4
 
5doorsoffury's Avatar
 
Join Date: Feb 2012
Location: bethpage ny
Posts: 998   (View Stats)
iTrader: (1)
Rep Power: 0
5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world5doorsoffury is the leader of the world
Thanks: 1,281
Thanked 562 Times in 315 Posts
Groans: 73
Groaned at 9 Times in 8 Posts
Not Ranked  0 score     
Default

Well the first thing i would do is get a meter out and test for continuity end to end on that CPS harness and the ecu harness. Next is if it says cps fault i would swap in a known good sensor for testing. Then i would check the infamous coil ground wire that is on the bracket in front of the HPFP. It grounds the coils.
__________________
MECP
2012 BM
PTE 5858 Vband .82ar // Tial EWG // CPE Mani // 3" Turboback // JBR Under route hot pipe // MD ST mani+spacer with PI // Siemens 60lb Injectors // Splitsecond inj controller // JBR 88 duro RMM/TMM // MD PMM // TWM Full replacement shifter // JBR CC // Autotech FP Internals // SP63 SB/Manley rods SP63 pro pistons // Treadstone FMIC TR824 // FoMoCo Tranny Jizz // South Bend Clutch Stage 3 enduro// GFB Respons // FJ 4" intake // WMI 100% VPM1 // Air Lift 1000 in rear // N2MB WOT BOX
Rfinkle tune in progress

The Brooklyn beater: 2005 1.8 Auto Sentra

5doorsoffury is offline   Reply With Quote
 Old 06-12-2018, 11:35 AM   #5
 
danb's Avatar
 
Join Date: Jan 2017
Location: Buffalo NY
Posts: 137   (View Stats)
iTrader: (0)
Rep Power: 29
danb is a splendid one to beholddanb is a splendid one to beholddanb is a splendid one to beholddanb is a splendid one to beholddanb is a splendid one to beholddanb is a splendid one to beholddanb is a splendid one to behold
Thanks: 82
Thanked 16 Times in 14 Posts
Groans: 3
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Which wire harness did you use?
__________________
2007 speed3 GT. gen 2 motor, cobb rmm, twm solid shifter bushings, AP3, Autotech, corksport turbo, catless depo dp, Turbosmart Kompact bpv, Corksport 3port,
Freektune 93 and e85 maps

2011 mzd6 88k. wifes ride
danb is offline   Reply With Quote
 Old 06-14-2018, 08:52 AM   #6
 
darkmx-6's Avatar
 
Join Date: Jun 2010
Location: Fort Worth, TX
Posts: 126   (View Stats)
iTrader: (0)
Rep Power: 104
darkmx-6 is just really nicedarkmx-6 is just really nicedarkmx-6 is just really nicedarkmx-6 is just really nice
Thanks: 26
Thanked 8 Times in 7 Posts
Groans: 0
Groaned at 3 Times in 2 Posts
Not Ranked  0 score     
Default

Make sure you used all the electronics from your car not the 2012. As there may be some unseen differences.
danb likes this.
darkmx-6 is offline   Reply With Quote
 Old 06-14-2018, 09:34 AM   #7
 
Polish_Eagle's Avatar
 
Join Date: Mar 2011
Location: Cambridge, Ontario, Canada
Posts: 401   (View Stats)
iTrader: (0)
Rep Power: 200
Polish_Eagle is the leader of the worldPolish_Eagle is the leader of the worldPolish_Eagle is the leader of the worldPolish_Eagle is the leader of the worldPolish_Eagle is the leader of the worldPolish_Eagle is the leader of the worldPolish_Eagle is the leader of the worldPolish_Eagle is the leader of the worldPolish_Eagle is the leader of the worldPolish_Eagle is the leader of the worldPolish_Eagle is the leader of the world
Thanks: 137
Thanked 212 Times in 117 Posts
Groans: 3
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

Are the camshaft trigger wheels the same on a 2012 and 2007? If not, you'll need to partially disassemble the engine and swap the camshafts.
__________________
2011 MAZDASPEED3 Hypnotic Tuned - Rob
CPE HPFP - CPE Catted Downpipe - CPE Catback Exhaust - 3" ETS TMIC - Cobb RMM - AEM Boost Gauge & Vent Pod - CANBus Triple - Corksport BPV - Corksport hood strut - Corksport RSB - Corksport Short Shifter - HTP 3.5" Intake - Damond TMM - Damond Vented CC - Vented Oil Cap - Tokay v2 Seals - GTX3067R - Damond PCV Plate - Built Engine (Manley Rods, 88mm Supertech 4032 Piston) -
Polish_Eagle is offline   Reply With Quote
 Old 06-14-2018, 09:59 AM   #8
 
Fstrnyou's Avatar
 
Join Date: Jul 2016
Location: Near Charlotte NC
Posts: 1,729   (View Stats)
iTrader: (0)
Rep Power: 273
Fstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the world
Thanks: 42
Thanked 461 Times in 347 Posts
Groans: 17
Groaned at 5 Times in 4 Posts
Not Ranked  0 score     
Default

Both cams have the same P/N from 2006-2013
danb likes this.
__________________
2006 MS6 GT - 158k Miles (Forged @ 157,116)
Manley 88mm Pistons & H-Tuff Rods, King Bearings
Stock Head/Cams, Stock Int/Exh Manifolds
Versatuner, 3-bar MAP, ITV22's, CP-e TMIC
CS Turbo/DP/RP/HPFP/BPV/R-DiffMount
White Widow F-DiffMount, Whiteline RSB
Russian Bushings in Back, Poly FSB Bushings, Magnaflow CBE
JBR Tru-3.5/3-port EBCS/EGR-D
Damond RMM/PMM/Stage 2 OCC/PCV Plate
AWR TMM on stand-by
Other rides:
2002 Tacoma ExtCab 2.4L 5spd 2WD - 355k mile Parts Getter
2004 Olds Alero ECOtec 2.2 - Broken (since Christmas 2015)
History:
2008 GSX-R 1000 - Stolen (With several runs past 180, I'd probably be dead by now if it wasn't stolen. So, in a way, I'm thankful.)
1988 RX-7 TII - Sold (Megasquirt, streetport, filter-on-turbo SRI, custom TBE, 20psi boost creep on OE turbo, OE TMIC on ice, 13.467 @ 105.44) apex seals said buh bye!
1985 Camaro - Sold (est. 265bhp 5.7 swap, Edelbrock intake & Hooker headers)
Fstrnyou is offline   Reply With Quote
 Old 06-14-2018, 10:35 AM   #9
 
Solarsurge's Avatar
 
Join Date: Apr 2016
Location: Richmond, VA
Posts: 368   (View Stats)
iTrader: (0)
Rep Power: 74
Solarsurge has a reputation beyond reputeSolarsurge has a reputation beyond reputeSolarsurge has a reputation beyond reputeSolarsurge has a reputation beyond reputeSolarsurge has a reputation beyond reputeSolarsurge has a reputation beyond reputeSolarsurge has a reputation beyond reputeSolarsurge has a reputation beyond reputeSolarsurge has a reputation beyond reputeSolarsurge has a reputation beyond reputeSolarsurge has a reputation beyond repute
Thanks: 22
Thanked 85 Times in 63 Posts
Groans: 0
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

P0335 Crank Position Sensor A Circuit Malfunction

There's literally a step by step diagnostic guide on the forums for this.
Solarsurge is offline   Reply With Quote
 Old 06-14-2018, 01:19 PM   #10
 
danb's Avatar
 
Join Date: Jan 2017
Location: Buffalo NY
Posts: 137   (View Stats)
iTrader: (0)
Rep Power: 29
danb is a splendid one to beholddanb is a splendid one to beholddanb is a splendid one to beholddanb is a splendid one to beholddanb is a splendid one to beholddanb is a splendid one to beholddanb is a splendid one to behold
Thanks: 82
Thanked 16 Times in 14 Posts
Groans: 3
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Originally Posted by darkmx-6 View Post
Make sure you used all the electronics from your car not the 2012. As there may be some unseen differences.
Yes, you must use the gen 1 harness on the gen 2 motor. I just did this swap a month ago
__________________
2007 speed3 GT. gen 2 motor, cobb rmm, twm solid shifter bushings, AP3, Autotech, corksport turbo, catless depo dp, Turbosmart Kompact bpv, Corksport 3port,
Freektune 93 and e85 maps

2011 mzd6 88k. wifes ride
danb is offline   Reply With Quote
 Old 06-21-2018, 03:39 PM   #11
 
jlr8185's Avatar
 
Join Date: Oct 2016
Location: Starkville, MS
Posts: 12   (View Stats)
iTrader: (0)
Rep Power: 0
jlr8185 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

if using tuning software or a AP, i would check the MAF voltages and make sure you didnt give voltages for too low a value. i know somewhere in the forums it talks about a minimum limit to which the MAF volts can go and anything voltages above 0 (zero) in that table below the minimum results in error code. happened to me a few times.
jlr8185 is offline   Reply With Quote
 Old 06-21-2018, 03:48 PM   #12
 
Fstrnyou's Avatar
 
Join Date: Jul 2016
Location: Near Charlotte NC
Posts: 1,729   (View Stats)
iTrader: (0)
Rep Power: 273
Fstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the worldFstrnyou is the leader of the world
Thanks: 42
Thanked 461 Times in 347 Posts
Groans: 17
Groaned at 5 Times in 4 Posts
Not Ranked  0 score     
Default

I want to say all MAF values below 0.9v should be zero.
__________________
2006 MS6 GT - 158k Miles (Forged @ 157,116)
Manley 88mm Pistons & H-Tuff Rods, King Bearings
Stock Head/Cams, Stock Int/Exh Manifolds
Versatuner, 3-bar MAP, ITV22's, CP-e TMIC
CS Turbo/DP/RP/HPFP/BPV/R-DiffMount
White Widow F-DiffMount, Whiteline RSB
Russian Bushings in Back, Poly FSB Bushings, Magnaflow CBE
JBR Tru-3.5/3-port EBCS/EGR-D
Damond RMM/PMM/Stage 2 OCC/PCV Plate
AWR TMM on stand-by
Other rides:
2002 Tacoma ExtCab 2.4L 5spd 2WD - 355k mile Parts Getter
2004 Olds Alero ECOtec 2.2 - Broken (since Christmas 2015)
History:
2008 GSX-R 1000 - Stolen (With several runs past 180, I'd probably be dead by now if it wasn't stolen. So, in a way, I'm thankful.)
1988 RX-7 TII - Sold (Megasquirt, streetport, filter-on-turbo SRI, custom TBE, 20psi boost creep on OE turbo, OE TMIC on ice, 13.467 @ 105.44) apex seals said buh bye!
1985 Camaro - Sold (est. 265bhp 5.7 swap, Edelbrock intake & Hooker headers)
Fstrnyou is offline   Reply With Quote
 Old 06-22-2018, 06:44 AM   #13
 
Djohns's Avatar
 
Join Date: Dec 2013
Location: Plainfield, IL
Posts: 3,914   (View Stats)
iTrader: (3)
Rep Power: 1340
Djohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the world
Thanks: 1,707
Thanked 2,489 Times in 1,355 Posts
Groans: 105
Groaned at 9 Times in 8 Posts
Not Ranked  0 score     
Default

Don’t forget the ground by the fuel pump. Everyone forgets that one.
__________________
2010 black mica speed3
The go: Depo racing: downpipe (100 cell count), custom: FMIC. HTP: 3.5" intake, under route piping. JBR: shortshifter, RSB. Autotech: HPFP internals. Go fast bits: hybrid BPV, VMR: 18x8.5 V710s, Bridgestone: potenza re760 245/40/18, KW: v3 coilovers,SPC: camber arms, freektuned, Damond Motorsports: dual OCC, PMM, PCV plate, RMM, TMM, EGR delete, FoSt mani, Corksport: battery box(fuck this thing), injector seals, Cobb: EBCS, AP v3. AEM: methanol. Seibon: carbon fiber hood. UR: catback. Bosch: 3bar. BNR: s4, DNP: EWG manifold, Tial: 38mm mvs EWG.

The show: 5% tint all around, 50% tint windshield, rally armor mudflaps, Sony XAV64BT touchscreen headunit, katskin leather interior, CPE relocation plate, Maisonvi weighted shift knob, Corksport hoodscoop, black housing headlights.

Soon:built motor
Djohns is offline   Reply With Quote
The Following User Says Thank You to Djohns For This Useful Post:
KiwiFlavor (06-22-2018)
 Old 07-17-2018, 01:19 PM   #14
 
ZoomZoomT's Avatar
 
Join Date: Jul 2017
Location: Washington
Posts: 23   (View Stats)
iTrader: (0)
Rep Power: 0
ZoomZoomT is an unknown quantity at this point
Thanks: 3
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

When i was replacing my vvt and timing chain, after I put everything back together i had same thing with the crank but no start and that engine code. Turns out i forgot to plug in my crankshaft sensor. lol
ZoomZoomT is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ms6 won't start no crank Kevopg MazdaSpeed 3/6 - Troubleshoot/Diagnostics 14 12-10-2016 04:58 PM
No crank, No start 570msp MazdaSpeed 3/6 - Troubleshoot/Diagnostics 4 10-23-2015 01:03 PM
Crank But No Start Pagan47 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 9 10-21-2015 07:32 PM
mazdaspeed 6 crank no start Mazdaspeedmike07 MazdaSpeed 3/6 - Troubleshoot/Diagnostics 6 10-11-2015 09:48 AM
Long Crank at cold start maikell77 2010 MS3 - Troubleshoot/Diagnostics 4 03-13-2013 07:54 PM


All times are GMT -7. The time now is 12:49 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.34247 seconds with 30 queries