register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
CX7FORUMS.ORG - 2007+ Mazda CX-7 Forums
> CX-7 > Issues & Troubleshooting


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 07-21-2013, 06:32 PM   #1
 
rickyb24's Avatar
 
Join Date: Jul 2013
Posts: 2   (View Stats)
iTrader: (0)
Rep Power: 0
rickyb24 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default '08 CX& Power loss and holwing

I have an 08 CX7, the other day while cruising at about 75mph, I lost what felt like the turbo? I went to pass a car and stepped on it and it was like the car had an anchor. No power. The engine started making and intermittent "howling" sound within minutes. Now it " howls" from about 1800rpm to around 2200rpm all of the time, but still no power. I can ( probably shouldn't) drive it and get up to highway speed , but it has hardly no acceleration. It's a VERY slow climb to speed. I've had some say it's the belt tensioner making the noise, but it doesn't explain the drop in power. I'm looking for ideas. I'm stumped. I'm a motor head ... but I'm an old school motor head. Not a tuner....yet THANKS for any help!
rickyb24 is offline   Reply With Quote
 Old 07-21-2013, 06:44 PM   #2
 
Payne Racing 67's Avatar
 
Join Date: Apr 2011
Location: Boynton Beach FL/Flanders, NJ
Posts: 4,483   (View Stats)
iTrader: (1)
Rep Power: 0
Payne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the world
Thanks: 8,007
Thanked 5,173 Times in 2,034 Posts
Groans: 101
Groaned at 64 Times in 49 Posts
Not Ranked  0 score     
Default

Sounds like a boost leak. Check either your intake, or tubes leading to the intercooler.
__________________
Badsnake 2003 Cobra: Ported Eaton, 2.93 upper, 4lb lower, Steeda intake, fuel system, LF Heat Excg, MGW Shifter, MM Coilovers, Billet Flow IRS Brace, Magnaflow O/R X Pipe/CBE, Fiore Clutch Quadrant/Adjuster, MT ET Street Radials 515rwhp/525rwtq.

#HAR Hidden Agendas Racing
Payne Racing 67 is offline   Reply With Quote
 Old 07-23-2013, 06:04 PM   #3
 
rickyb24's Avatar
 
Join Date: Jul 2013
Posts: 2   (View Stats)
iTrader: (0)
Rep Power: 0
rickyb24 is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Checked out both intercooler tubes, both OK. I used a buddies code reader and I got a P0101 for the MAF or VAF and then got a P0401 for the EGR valve. I guess I'll keep checking lines and clean the EGR. ANY other ideas would be great.
__________________
2008 CX7 Sport, BONE STOCK...for now.
rickyb24 is offline   Reply With Quote
 Old 07-23-2013, 06:15 PM   #4
 
m4tic's Avatar
 
Join Date: Mar 2008
Location: Foothill Ranch, CA
Posts: 4,922   (View Stats)
iTrader: (7)
Rep Power: 2690
m4tic is the leader of the worldm4tic is the leader of the worldm4tic is the leader of the worldm4tic is the leader of the worldm4tic is the leader of the worldm4tic is the leader of the worldm4tic is the leader of the worldm4tic is the leader of the worldm4tic is the leader of the worldm4tic is the leader of the worldm4tic is the leader of the world
Thanks: 766
Thanked 5,014 Times in 1,767 Posts
Groans: 12
Groaned at 24 Times in 22 Posts
Not Ranked  0 score     
Default

does it howl only while on the gas?

does it how constantly with wheel speed?

either you missed a boost leak (wastegate, boost control solenoid).. or something like the pto took a dump.
__________________

//2014 Mustang GT// Brembos - Bob's Can - SCT X4 - MGW - GT500 Quad-tip Axle back - Vorshlag Street Pro - Ford K Springs - BMR PHB


2007 MS6 w/ Cheez

// COBB V3 // SURE ID300 MAF // COBB TIP // CXRacing FMIC // PTP BSD // PTP Windage Tray // PTP TIG // KMD V2.1 CDFP Internals // HD Coil Packs //
Corksport DP // TurboXS RP // CP-e 3" Single Cat-back // Bilstein Shocks & H&R Springs // DSS Axle // TSW Interlagos 19x8 +35 // 235/35 Rubber
// Defi Red Racer // Block8head Defrost Pod // DDM 3k Fogs & 6k Lowbeams // Custom iPod Integration Hackjob //
m4tic is offline   Reply With Quote
The Following User Says Thank You to m4tic For This Useful Post:
Payne Racing 67 (07-25-2013)
 Old 07-25-2013, 12:33 PM   #5
 
Payne Racing 67's Avatar
 
Join Date: Apr 2011
Location: Boynton Beach FL/Flanders, NJ
Posts: 4,483   (View Stats)
iTrader: (1)
Rep Power: 0
Payne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the worldPayne Racing 67 is the leader of the world
Thanks: 8,007
Thanked 5,173 Times in 2,034 Posts
Groans: 101
Groaned at 64 Times in 49 Posts
Not Ranked  0 score     
Default

Did you check your intake? Where it connects to the turbo? That will affect MAF, and because it throws everything off, could cause the egr code as well


Sent from your moms phone
__________________
Badsnake 2003 Cobra: Ported Eaton, 2.93 upper, 4lb lower, Steeda intake, fuel system, LF Heat Excg, MGW Shifter, MM Coilovers, Billet Flow IRS Brace, Magnaflow O/R X Pipe/CBE, Fiore Clutch Quadrant/Adjuster, MT ET Street Radials 515rwhp/525rwtq.

#HAR Hidden Agendas Racing
Payne Racing 67 is offline   Reply With Quote
 Old 10-07-2016, 11:42 PM   #6
 
MAZDAUSA's Avatar
 
Join Date: Oct 2016
Posts: 1   (View Stats)
iTrader: (0)
Rep Power: 0
MAZDAUSA is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

I am having exactly the same issue. Dealer is asking to replace catalytic converter ..they are saying $2K for the replacement.
MAZDAUSA is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Loss of power at WOT Speeden6 MazdaSpeed 6 - Engine, Transmission & Driveline 49 04-09-2012 09:48 PM
WTF power loss and mpg loss ztnedman1 Gen2 MS3 General Discussion 10 11-07-2011 07:26 PM
Loss power kao_lor Mazdaspeed3/6 General Discussion 13 04-15-2011 01:43 PM
New to me MS3 08.5 Power Loss rtabagaboy MazdaSpeed 3/6 - Troubleshoot/Diagnostics 31 10-17-2009 01:22 PM
Loss of Power mleblond MazdaSpeed 3 - Engine, Transmission & Driveline 11 09-03-2009 07:16 AM


All times are GMT -7. The time now is 10:04 PM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.26605 seconds with 23 queries