register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
CX7FORUMS.ORG - 2007+ Mazda CX-7 Forums
> CX-7 > Issues & Troubleshooting


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Like Tree6Likes
  • 1 Post By Raider
  • 2 Post By Project_dog
  • 1 Post By robbspeed
  • 1 Post By robbspeed
  • 1 Post By kdxracer
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 11-16-2015, 02:20 AM   #1
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default Running issues

I dont know where to start. i did mine vvt. fucked up my valves. replaced all the bad parts. went and replaced the all the bad parts. upgraded my turbo, made my own dp, went to a grimmspeed 3 port, jbr 3.5 intake, 3 bar Tmap. got rid of the butterflies in the IM and went with a custom FMIC.

I got everything all back together today. I Tried starting it. It would start up. Then die right a way. Finally got it to run and idle at 2000 RPM. idle wouldnt come down. So I throttled up. 3000k. Then the it would surge from 3000 to 2500 rpm. and wouldnt stop. so I shut it off.

I rechecked all my clamps everything is tight.
Project_dog is offline   Reply With Quote
 Old 11-16-2015, 02:36 AM   #2
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Oh I'm not done with my dp yet. So I don't have my 2nd O2 sensor in yet.

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2007 Mazda CX-7: Custom FMIC, Forge V1 BPV, Grimmspeed 3 port EBC, BNR S3 turbo, 3 inch Catless DP, Muffler Delete, JBR 3.5 intake, Autotech HPFP Internals, JBR OCC, Vogland Springs. Stereo: Two Memphis 10" Subs, 2 Memphis 1.500 Amps. Memphis 4.50 Amp, Image Dynamics Components and Coaxials.
Project_dog is offline   Reply With Quote
 Old 11-16-2015, 03:05 AM   #3
6 mods and some Kool-Aid
 
Raider's Avatar
 
Join Date: Mar 2008
Location: Jax, FL
Posts: 28,879   (View Stats)
iTrader: (12)
Rep Power: 28966
Raider is the leader of the worldRaider is the leader of the worldRaider is the leader of the worldRaider is the leader of the worldRaider is the leader of the worldRaider is the leader of the worldRaider is the leader of the worldRaider is the leader of the worldRaider is the leader of the worldRaider is the leader of the worldRaider is the leader of the world
Thanks: 20,271
Thanked 57,009 Times in 14,590 Posts
Groans: 856
Groaned at 183 Times in 156 Posts
Not Ranked  0 score     
Default

Probably the tune.
Project_dog likes this.
Raider is offline   Reply With Quote
 Old 11-16-2015, 03:09 AM   #4
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Have you messed with versa tuner ?

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2007 Mazda CX-7: Custom FMIC, Forge V1 BPV, Grimmspeed 3 port EBC, BNR S3 turbo, 3 inch Catless DP, Muffler Delete, JBR 3.5 intake, Autotech HPFP Internals, JBR OCC, Vogland Springs. Stereo: Two Memphis 10" Subs, 2 Memphis 1.500 Amps. Memphis 4.50 Amp, Image Dynamics Components and Coaxials.
Project_dog is offline   Reply With Quote
 Old 11-16-2015, 07:51 AM   #5
Tachyonic Moderator

 
MS3Shadow's Avatar
 
Join Date: Nov 2013
Location: San Antonio, TX
Posts: 4,771
iTrader: (4)
Rep Power: 1960
MS3Shadow is the leader of the worldMS3Shadow is the leader of the worldMS3Shadow is the leader of the worldMS3Shadow is the leader of the worldMS3Shadow is the leader of the worldMS3Shadow is the leader of the worldMS3Shadow is the leader of the worldMS3Shadow is the leader of the worldMS3Shadow is the leader of the worldMS3Shadow is the leader of the worldMS3Shadow is the leader of the world
Thanks: 5,075
Thanked 3,693 Times in 1,891 Posts
Groans: 283
Groaned at 20 Times in 16 Posts
Default

Originally Posted by Project_dog View Post
Oh I'm not done with my dp yet. So I don't have my 2nd O2 sensor in yet.

Sent from my SAMSUNG-SGH-I337 using Tapatalk
2nd O2 sensor is not really necessary. it's only there to monitor the first cat.
__________________
2013 Crystal White Pearl Mazdaspeed 3 w/ Tech Package
BNR S4, XSPower v3 Exhaust Manifold w/ Tial 44mm EWG Cobb accessport V3, Dizzy Tune in progress CP-e stage2 rmm, tmic, hpfp JBR boost tubes, Tru-3.5in Intake inside a Corksport Cold Air Box, Catless Downpipe & Racepipe, bypass hose, hood scoop, BPV, hood struts, stubby antenna, Aluminum Skid Plate, EBCS, 3.5BAR MAP Sensor, Magnaflow Catback Exhaust DM Full EGR Delete, Passenger Motor Mount, Transmission Motor Mount., Coolant Bypass, VTCS Delete, NGK ILTR6A-7G ,G-LOC R6 Brake pads and Centric High Carbon brake rotors Looks: 25% tint front, 5% back, Heat-blocking front windshield film Escort Passport Max360, RGBW Halos/Demon Eyes 20'' LED Light bar

Use my Updated Custom Google Search to search this forum since the advanced search here is broken
MS3Shadow is offline   Reply With Quote
 Old 11-16-2015, 10:37 AM   #6
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

I don't have a first cat

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2007 Mazda CX-7: Custom FMIC, Forge V1 BPV, Grimmspeed 3 port EBC, BNR S3 turbo, 3 inch Catless DP, Muffler Delete, JBR 3.5 intake, Autotech HPFP Internals, JBR OCC, Vogland Springs. Stereo: Two Memphis 10" Subs, 2 Memphis 1.500 Amps. Memphis 4.50 Amp, Image Dynamics Components and Coaxials.
Project_dog is offline   Reply With Quote
 Old 11-17-2015, 01:13 PM   #7
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

well I went and changed my MAF tables. Still doing the same problem.
Project_dog is offline   Reply With Quote
 Old 11-17-2015, 05:13 PM   #8
 
blackms3_71's Avatar
 
Join Date: Apr 2012
Location: port orchard, w.a
Posts: 2,250   (View Stats)
iTrader: (1)
Rep Power: 492
blackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the world
Thanks: 655
Thanked 695 Times in 437 Posts
Groans: 2
Groaned at 15 Times in 9 Posts
Not Ranked  0 score     
Default

Spary carb cleaner on all gasket areas and vac lines. Do idle change? If so thats ur leak
__________________
COBB ACCESSPORT//TURBOXS CATLESS DP+RACEPIPE//3 BAR MAP//3.5" HTP INTAKE//NGK 1 STEP COLDER PLUGS//HKS CATBACK//AUTOTECH INTERNALS//COBB FMIC V2.0//HKS BOV BLACK EDITION IN VTA//RPF1 17x9//pilot super sport 245/45/17//ACT 6 PUCK//M.D OCC VTA//TOKAY SEALS//BNR S4//Hypnotic tuned
blackms3_71 is offline   Reply With Quote
 Old 11-25-2015, 02:53 AM   #9
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

well with a couple of days off. going to work on the car.
Project_dog is offline   Reply With Quote
 Old 11-25-2015, 05:18 PM   #10
 
torquemaniac's Avatar
 
Join Date: Jun 2012
Location: Montreal, QC
Posts: 730   (View Stats)
iTrader: (0)
Rep Power: 0
torquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the world
Thanks: 927
Thanked 754 Times in 269 Posts
Groans: 0
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

@Project_dog; record a log of the start-up and idle (start the log before you crank the engine)

Record : LTFT, STFT, MAF, load, rpm, ignition timing, MAP, actual lambda, desired lambda, relative throttle position, valve timing
__________________
2011 CX-7 AWD 2.3 turbo
Ported Holset HY35 // Custom top mount EM // Tial MV-S 38mm // Custom DP and catback // L2A intercooler with AMG CWA-100 pump// Perrin MBC // 3.25 Blow-thru MAF // Aquamist HFS-4 v.2 direct port injection // Eagle rods // Supertech 4032 pistons // Forge BPV v.2 // Perrin air/oil separator // Autotech HPFP // Custom RMM insert // TB coolant bypass // Full EGR delete // 3.5 bar MAP // Launch control with anti-lag // Derale remote transmission cooler // Upgraded transmission boost valve // Shimmed transmission accumulators // Adjusted transmission clutch control valve // Digital overboost protection system // Custom firewall heatshield // JKS rear spoiler // Painted VC and IM // BSD // Custom vent pod with boost and meth gauge // Tuned with Versatuner

"When the turbo spins the bull$hit ends" BOOST the replacement for displacement
torquemaniac is offline   Reply With Quote
 Old 11-25-2015, 09:40 PM   #11
 
mr.speedy3's Avatar
 
Join Date: Jun 2012
Location: Mesa, Arizona
Posts: 1,690   (View Stats)
iTrader: (5)
Rep Power: 0
mr.speedy3 is the leader of the worldmr.speedy3 is the leader of the worldmr.speedy3 is the leader of the worldmr.speedy3 is the leader of the worldmr.speedy3 is the leader of the worldmr.speedy3 is the leader of the worldmr.speedy3 is the leader of the worldmr.speedy3 is the leader of the worldmr.speedy3 is the leader of the worldmr.speedy3 is the leader of the worldmr.speedy3 is the leader of the world
Thanks: 1,244
Thanked 1,427 Times in 647 Posts
Groans: 10
Groaned at 5 Times in 3 Posts
Not Ranked  0 score     
Default

Can we get @Vansquish to make some grammatical corrections here? Jesus.

Did you check your timing after 'putting it back together'?

Who changed your valves?

Sounds like you have a giant leak at the least.. Pull a log for us.
__________________
Fastest GTX3076r, T3 twinscroll, built block, D14 meth spraying gen1 on the internet!
mr.speedy3 is offline   Reply With Quote
The Following User Says Thank You to mr.speedy3 For This Useful Post:
Vansquish (11-27-2015)
 Old 11-26-2015, 01:05 AM   #12
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

I will tomorrow.

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2007 Mazda CX-7: Custom FMIC, Forge V1 BPV, Grimmspeed 3 port EBC, BNR S3 turbo, 3 inch Catless DP, Muffler Delete, JBR 3.5 intake, Autotech HPFP Internals, JBR OCC, Vogland Springs. Stereo: Two Memphis 10" Subs, 2 Memphis 1.500 Amps. Memphis 4.50 Amp, Image Dynamics Components and Coaxials.
Project_dog is offline   Reply With Quote
 Old 11-26-2015, 05:03 PM   #13
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

well I have some logs. I noticed on part of my fmic pipe is hot, and the next pipe after it was not. i disconnected the fmic. Started right up.
Project_dog is offline   Reply With Quote
 Old 11-26-2015, 05:50 PM   #14
 
blackms3_71's Avatar
 
Join Date: Apr 2012
Location: port orchard, w.a
Posts: 2,250   (View Stats)
iTrader: (1)
Rep Power: 492
blackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the worldblackms3_71 is the leader of the world
Thanks: 655
Thanked 695 Times in 437 Posts
Groans: 2
Groaned at 15 Times in 9 Posts
Not Ranked  0 score     
Default

Originally Posted by Project_dog View Post
well I have some logs. I noticed on part of my fmic pipe is hot, and the next pipe after it was not. i disconnected the fmic. Started right up.

Open it up. Maybe a rag or something stuffed inside.
__________________
COBB ACCESSPORT//TURBOXS CATLESS DP+RACEPIPE//3 BAR MAP//3.5" HTP INTAKE//NGK 1 STEP COLDER PLUGS//HKS CATBACK//AUTOTECH INTERNALS//COBB FMIC V2.0//HKS BOV BLACK EDITION IN VTA//RPF1 17x9//pilot super sport 245/45/17//ACT 6 PUCK//M.D OCC VTA//TOKAY SEALS//BNR S4//Hypnotic tuned
blackms3_71 is offline   Reply With Quote
 Old 11-26-2015, 07:54 PM   #15
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Going too. I changed my map settings too.
Project_dog is offline   Reply With Quote
 Old 11-27-2015, 10:10 PM   #16
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Hoping tomorrow I'll get my dp done. 2nd o2 sensor put in.


uploadfromtaptalk1448690925228.jpguploadfromtaptalk1448690938569.jpg

Sent from my SAMSUNG-SGH-I337 using Tapatalk
__________________
2007 Mazda CX-7: Custom FMIC, Forge V1 BPV, Grimmspeed 3 port EBC, BNR S3 turbo, 3 inch Catless DP, Muffler Delete, JBR 3.5 intake, Autotech HPFP Internals, JBR OCC, Vogland Springs. Stereo: Two Memphis 10" Subs, 2 Memphis 1.500 Amps. Memphis 4.50 Amp, Image Dynamics Components and Coaxials.
Project_dog is offline   Reply With Quote
 Old 12-02-2015, 01:43 PM   #17
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

I got it all back together. still having a problem and i noticed when the car is idle (2000 rpm) my map is reading 11 psi. normal?

and P2188 code.

Last edited by Project_dog; 12-02-2015 at 01:43 PM. Reason: MSF Database - Automerged Doublepost
Project_dog is offline   Reply With Quote
 Old 12-05-2015, 08:09 PM   #18
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Well still no luck. A little better. I have attached a log file using versa tune.
Attached Files
File Type: zip VersaTuner Logs trying to start and idle.zip (13.6 KB, 5 views)
Project_dog is offline   Reply With Quote
 Old 12-06-2015, 09:58 PM   #19
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

worked on her today. I feel like a dumbass. But lesson learned. Well Found my PCV tube was not connected. I went ahead installed a new pcv valve and ran my OCC tubes. cleared codes, started right up. Idle at 1800 rpm then went down to 800 rpm. Took around the block. Ran like a rape ape. happy thats over. Thanks for all the advise and help.
lildisco and robbspeed like this.
Project_dog is offline   Reply With Quote
The Following User Says Thank You to Project_dog For This Useful Post:
robbspeed (12-07-2015)
 Old 12-07-2015, 06:07 AM   #20
 
robbspeed's Avatar
 
Join Date: Sep 2015
Location: Brick, NJ
Posts: 1,074   (View Stats)
iTrader: (0)
Rep Power: 0
robbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the world
Thanks: 1,356
Thanked 383 Times in 266 Posts
Groans: 50
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

Lol congrats man
Project_dog likes this.
__________________
2011 Mazdaspeed3 w/ tech package
Totaled/ R.I.P.
robbspeed is offline   Reply With Quote
 Old 12-07-2015, 07:06 AM   #21
 
torquemaniac's Avatar
 
Join Date: Jun 2012
Location: Montreal, QC
Posts: 730   (View Stats)
iTrader: (0)
Rep Power: 0
torquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the worldtorquemaniac is the leader of the world
Thanks: 927
Thanked 754 Times in 269 Posts
Groans: 0
Groaned at 2 Times in 2 Posts
Not Ranked  0 score     
Default

Any noticeable boost lag with the 3'' piping?
__________________
2011 CX-7 AWD 2.3 turbo
Ported Holset HY35 // Custom top mount EM // Tial MV-S 38mm // Custom DP and catback // L2A intercooler with AMG CWA-100 pump// Perrin MBC // 3.25 Blow-thru MAF // Aquamist HFS-4 v.2 direct port injection // Eagle rods // Supertech 4032 pistons // Forge BPV v.2 // Perrin air/oil separator // Autotech HPFP // Custom RMM insert // TB coolant bypass // Full EGR delete // 3.5 bar MAP // Launch control with anti-lag // Derale remote transmission cooler // Upgraded transmission boost valve // Shimmed transmission accumulators // Adjusted transmission clutch control valve // Digital overboost protection system // Custom firewall heatshield // JKS rear spoiler // Painted VC and IM // BSD // Custom vent pod with boost and meth gauge // Tuned with Versatuner

"When the turbo spins the bull$hit ends" BOOST the replacement for displacement
torquemaniac is offline   Reply With Quote
 Old 12-07-2015, 10:05 AM   #22
 
Project_dog's Avatar
 
Join Date: Jul 2013
Location: Spokane, WA
Posts: 333   (View Stats)
iTrader: (1)
Rep Power: 0
Project_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond reputeProject_dog has a reputation beyond repute
Thanks: 94
Thanked 61 Times in 42 Posts
Groans: 0
Groaned at 7 Times in 5 Posts
(Thread Starter)
Not Ranked  0 score     
Default

no i dont feel the lag. I drove it around for 10 mins.
Project_dog is offline   Reply With Quote
 Old 01-15-2016, 05:37 PM   #23
 
kdxracer's Avatar
 
Join Date: Dec 2015
Location: Columbus, GA
Posts: 10   (View Stats)
iTrader: (0)
Rep Power: 0
kdxracer is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Originally Posted by mr.speedy3 View Post
Can we get @Vansquish to make some grammatical corrections here? Jesus.

Did you check your timing after 'putting it back together'?

Who changed your valves?

Sounds like you have a giant leak at the least.. Pull a log for us.
What are you using to pull logs? I just got a cheap code reader device that syncs to 'OBD Car Doctor' (free version) app on my phone. I can see most of the standard info real time but honestly don't really know what some of the readings are supposed to be. I just cleaned the throttle body and intake, replaced pcv valve and hose to intake, and replaced thermostat (180 degree). The coolant temp is running between 200 and 210, which seems high to me. Does anyone know what is standard?
kdxracer is offline   Reply With Quote
 Old 01-15-2016, 05:50 PM   #24
 
robbspeed's Avatar
 
Join Date: Sep 2015
Location: Brick, NJ
Posts: 1,074   (View Stats)
iTrader: (0)
Rep Power: 0
robbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the world
Thanks: 1,356
Thanked 383 Times in 266 Posts
Groans: 50
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

Originally Posted by kdxracer View Post
What are you using to pull logs? I just got a cheap code reader device that syncs to 'OBD Car Doctor' (free version) app on my phone. I can see most of the standard info real time but honestly don't really know what some of the readings are supposed to be. I just cleaned the throttle body and intake, replaced pcv valve and hose to intake, and replaced thermostat (180 degree). The coolant temp is running between 200 and 210, which seems high to me. Does anyone know what is standard?
I'm guessing he uses Versatuner since it says Versatuner.
Project_dog likes this.
__________________
2011 Mazdaspeed3 w/ tech package
Totaled/ R.I.P.
robbspeed is offline   Reply With Quote
 Old 01-15-2016, 05:56 PM   #25
 
kdxracer's Avatar
 
Join Date: Dec 2015
Location: Columbus, GA
Posts: 10   (View Stats)
iTrader: (0)
Rep Power: 0
kdxracer is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Never heard of that. Obviously, I don't do a lot of tuning and changing codes...lol
kdxracer is offline   Reply With Quote
 Old 01-15-2016, 06:24 PM   #26
 
robbspeed's Avatar
 
Join Date: Sep 2015
Location: Brick, NJ
Posts: 1,074   (View Stats)
iTrader: (0)
Rep Power: 0
robbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the world
Thanks: 1,356
Thanked 383 Times in 266 Posts
Groans: 50
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

Originally Posted by kdxracer View Post
Never heard of that. Obviously, I don't do a lot of tuning and changing codes...lol
I don't know of any other options for a cx7. Can I ask what made you clean your throttle body? And how/why did u clean your intake?

As far as your coolant temp goes, is it 200° - 210° while cruising?


I just wanna add this isn't your or my thread so if you're having a problem you should create a new thread. I don't wanna be an accessory to thread jacking.
__________________
2011 Mazdaspeed3 w/ tech package
Totaled/ R.I.P.
robbspeed is offline   Reply With Quote
 Old 01-15-2016, 06:53 PM   #27
 
kdxracer's Avatar
 
Join Date: Dec 2015
Location: Columbus, GA
Posts: 10   (View Stats)
iTrader: (0)
Rep Power: 0
kdxracer is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

I was getting codes indicating not warming up to operating temp so suspected the thermostat. As for the throttle body and intake, it would barely idle and it would die shifting from reverse to drive and sometimes when stopping at the top of a small incline. The tb was terribly dirty as well as the inside of the intake. It was caked with oily carbon type deposits severely restricting airflow from vacuums. I had to take the intake off anyways to get to the hose between the pvc and intake as it had a 2" gash in it. While it was off I cleaned the blades on the block side. I pulled the cover the pcv goes into and cleaned similar debris out replacing the pcv when putting it back together.

It idles beautifully now!

Yes, it is running 200 - 210 while cruising.
kdxracer is offline   Reply With Quote
 Old 01-15-2016, 07:08 PM   #28
 
kdxracer's Avatar
 
Join Date: Dec 2015
Location: Columbus, GA
Posts: 10   (View Stats)
iTrader: (0)
Rep Power: 0
kdxracer is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Here is a pic of the throttle body...and intake
Attached Images
File Type: jpg 20151230_164124.jpg (4.63 MB, 9 views)
File Type: jpg 20151230_164238.jpg (4.60 MB, 8 views)
kdxracer is offline   Reply With Quote
 Old 01-15-2016, 07:10 PM   #29
 
robbspeed's Avatar
 
Join Date: Sep 2015
Location: Brick, NJ
Posts: 1,074   (View Stats)
iTrader: (0)
Rep Power: 0
robbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the world
Thanks: 1,356
Thanked 383 Times in 266 Posts
Groans: 50
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

Good shit. Maybe there's some air trapped in there from when you replaced your thermostat. How's your coolant level? Is there any shit or debris obstructing the radiators air flow? What type of coolant and what concentration did you use?

Originally Posted by kdxracer View Post
Here is a pic of the throttle body...and intake
Gross
__________________
2011 Mazdaspeed3 w/ tech package
Totaled/ R.I.P.

Last edited by robbspeed; 01-15-2016 at 07:11 PM. Reason: MSF Database - Automerged Doublepost
robbspeed is offline   Reply With Quote
 Old 01-15-2016, 07:15 PM   #30
 
kdxracer's Avatar
 
Join Date: Dec 2015
Location: Columbus, GA
Posts: 10   (View Stats)
iTrader: (0)
Rep Power: 0
kdxracer is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

hose...
Attached Images
File Type: jpg 20151231_150430.jpg (4.29 MB, 7 views)
kdxracer is offline   Reply With Quote
 Old 01-15-2016, 07:25 PM   #31
 
kdxracer's Avatar
 
Join Date: Dec 2015
Location: Columbus, GA
Posts: 10   (View Stats)
iTrader: (0)
Rep Power: 0
kdxracer is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

There is good air flow through radiator. I think there may still be an air bubble in the system. I tried a burping procedure but it didn't seem to drop yet. Level is good and I will keep an eye on it because if it does burp the air out it'll suck it in from the reservoir. I used the Asian formula coolant 50/50 diluted.

Clean parts!
Attached Images
File Type: jpg 20160106_105526.jpg (4.02 MB, 5 views)
File Type: jpg 20160106_105633.jpg (4.98 MB, 5 views)
kdxracer is offline   Reply With Quote
 Old 01-15-2016, 07:42 PM   #32
 
robbspeed's Avatar
 
Join Date: Sep 2015
Location: Brick, NJ
Posts: 1,074   (View Stats)
iTrader: (0)
Rep Power: 0
robbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the worldrobbspeed is the leader of the world
Thanks: 1,356
Thanked 383 Times in 266 Posts
Groans: 50
Groaned at 7 Times in 6 Posts
Not Ranked  0 score     
Default

How long has it been since you replaced it? You can try squeezing the radiator hose while its running when your burping it.

If all else fails it's possible but unlikely you got a bad new thermostat.
__________________
2011 Mazdaspeed3 w/ tech package
Totaled/ R.I.P.
robbspeed is offline   Reply With Quote
 Old 01-15-2016, 07:45 PM   #33
 
kdxracer's Avatar
 
Join Date: Dec 2015
Location: Columbus, GA
Posts: 10   (View Stats)
iTrader: (0)
Rep Power: 0
kdxracer is an unknown quantity at this point
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Not Ranked  0 score     
Default

Yeah, I know that can happen. I'll watch it real close for a while before going and replacing it again, or trade it off...lol I'll have to let my wife drive the Mustang, she won't mind...lol
robbspeed likes this.
kdxracer is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running mixed series tires - alignment issues? Flitzr951 Mazdaspeed3/6 General Discussion 4 07-02-2015 08:25 AM
Ford issues six recalls covering 101,000 vehicles for multiple issues Haltech Automotive News 0 07-08-2014 12:50 PM
AMR CO's..anyone running them shifter48 Auto-X / Road Racing / Time Attack 9 12-06-2012 10:24 AM
Who's running an occ? pwned 2010 MS3 - Engine, Transmission & Driveline 62 11-27-2012 05:01 PM
MS3's running VTA IshiKage MazdaSpeed 3/6 - Turbo Induction 32 01-23-2009 02:28 PM


All times are GMT -7. The time now is 07:51 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.48046 seconds with 28 queries