register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3 MZR Gen2 Forums (2010-2013)
> Gen2 MS3 General Discussion


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Like Tree1Likes
  • 1 Post By mitch11wmm
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 02-12-2018, 05:41 PM   #1
 
mitch11wmm's Avatar
 
Join Date: Dec 2017
Posts: 11   (View Stats)
iTrader: (0)
Rep Power: 0
mitch11wmm will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default Fog Lights Stuck On, Ugh

Hey everyone,
So I bought a 2012 Speed3 about a month ago and have loved it so far, however, today it started acting like a normal Speed3 lol.
I walked out to my car after class and my fog lights were on. I started the car and plugged in my AP and read the battery voltage to be 14v (previous owner bought a battery less than a week before I bought it), therefore, they must not have been on long.
I drove home and after shutting off my lights and locking my doors, my fogs were still on. I have pulled the fuse and it looks okay. I disconnected the battery for a minute or two and when I plugged it back in, the fogs immediately came on. I am trying to find out which relay controls the fogs now but cannot find a direct answer.

does anyone know which relay is the fog light relay or has anyone had this issue?

I have read it could be the body control module also. this weekend I am going to be tracing wiring and looking for a short however, since the fuse looks good I think this is highly unlikely.

TLDR: fog lights wont turn off. Can't determine which relay is the fog light relay.
mitch11wmm is offline   Reply With Quote
 Old 02-13-2018, 06:16 AM   #2
 
Djohns's Avatar
 
Join Date: Dec 2013
Location: Plainfield, IL
Posts: 3,932   (View Stats)
iTrader: (3)
Rep Power: 1348
Djohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the worldDjohns is the leader of the world
Thanks: 1,708
Thanked 2,502 Times in 1,362 Posts
Groans: 105
Groaned at 9 Times in 8 Posts
Not Ranked  0 score     
Default

Maybe the previous owner did the fog light mod to have them on with the parking lights and he spliced into the wrong wire.
__________________
2010 black mica speed3
The go: Depo racing: downpipe (100 cell count), custom: FMIC. HTP: 3.5" intake, under route piping. JBR: shortshifter, RSB. Autotech: HPFP internals. Go fast bits: hybrid BPV, VMR: 18x8.5 V710s, Bridgestone: potenza re760 245/40/18, KW: v3 coilovers,SPC: camber arms, freektuned, Damond Motorsports: dual OCC, PMM, PCV plate, RMM, TMM, EGR delete, FoSt mani, Corksport: battery box(fuck this thing), injector seals, Cobb: EBCS, AP v3. AEM: methanol. Seibon: carbon fiber hood. UR: catback. Bosch: 3bar. BNR: s4, DNP: EWG manifold, Tial: 38mm mvs EWG.

The show: 5% tint all around, 50% tint windshield, rally armor mudflaps, Sony XAV64BT touchscreen headunit, katskin leather interior, CPE relocation plate, Maisonvi weighted shift knob, Corksport hoodscoop, black housing headlights.

Soon:built motor
Djohns is offline   Reply With Quote
 Old 02-13-2018, 06:31 AM   #3
 
mitch11wmm's Avatar
 
Join Date: Dec 2017
Posts: 11   (View Stats)
iTrader: (0)
Rep Power: 0
mitch11wmm will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

I wouldn't think so, it's never stayed on before. When I went out to my car at first I figured i had left them on but I didn't.

Sent from my VS995 using Tapatalk
mitch11wmm is offline   Reply With Quote
 Old 02-13-2018, 08:58 AM   #4
 
g00s3y's Avatar
 
Join Date: Oct 2013
Location: Fort Myers, FL
Posts: 2,127   (View Stats)
iTrader: (7)
Rep Power: 0
g00s3y is the leader of the worldg00s3y is the leader of the worldg00s3y is the leader of the worldg00s3y is the leader of the worldg00s3y is the leader of the worldg00s3y is the leader of the worldg00s3y is the leader of the worldg00s3y is the leader of the worldg00s3y is the leader of the worldg00s3y is the leader of the worldg00s3y is the leader of the world
Thanks: 976
Thanked 2,165 Times in 964 Posts
Groans: 439
Groaned at 11 Times in 11 Posts
Not Ranked  0 score     
Default

Just remove them all together. Get a good set of 55w HID's for your low beams, and you won't need any other lights to see.

Plus weight loss, because racecar.
__________________
All good things must come to an end...
g00s3y is offline   Reply With Quote
 Old 02-13-2018, 09:01 AM   #5
 
mitch11wmm's Avatar
 
Join Date: Dec 2017
Posts: 11   (View Stats)
iTrader: (0)
Rep Power: 0
mitch11wmm will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

I like fog lights though :/
Plus I'm thinking the relay is stuck closed. I have the fuse pulled for now, so I'm good until I find the issue

Sent from my VS995 using Tapatalk
mitch11wmm is offline   Reply With Quote
 Old 02-13-2018, 05:03 PM   #6
 
JakeMS3's Avatar
 
Join Date: Mar 2013
Location: Accokeek MD
Posts: 1,160   (View Stats)
iTrader: (1)
Rep Power: 390
JakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the world
Thanks: 81
Thanked 623 Times in 381 Posts
Groans: 19
Groaned at 7 Times in 5 Posts
Not Ranked  0 score     
Default

You did turn them off inside the interior right? I know you can turn them on and they will turn on and off with the auto headlights, but have you popped that knob back in so they’re off?
__________________
2013 LSM w/tech

Cobb AP V3, CBE
CS Turbo tuned by PD
Corksport Catted DP/HPFP Internals
JBR FMIC Pipe Kit w/TR8
CP-E TIP/3.5" Intake
DM OCC/TMM
Forge V2 BPV
Bilstein B8 w/Swift springs
Wilwood 6 pot BBK
EBC RedStuff rear pads
Konig Hypergram 18x8.5"
JakeMS3 is offline   Reply With Quote
 Old 02-13-2018, 05:09 PM   #7
 
mitch11wmm's Avatar
 
Join Date: Dec 2017
Posts: 11   (View Stats)
iTrader: (0)
Rep Power: 0
mitch11wmm will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

No they are 100% off

Sent from my VS995 using Tapatalk
mitch11wmm is offline   Reply With Quote
 Old 02-13-2018, 05:14 PM   #8
 
JakeMS3's Avatar
 
Join Date: Mar 2013
Location: Accokeek MD
Posts: 1,160   (View Stats)
iTrader: (1)
Rep Power: 390
JakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the worldJakeMS3 is the leader of the world
Thanks: 81
Thanked 623 Times in 381 Posts
Groans: 19
Groaned at 7 Times in 5 Posts
Not Ranked  0 score     
Default

You could grab a flashlight and take a peek at the back of the fog lights and see what the wires are looking like. You can actually turn the wheels to the left, pull out the fender well portion on passenger side and peel it back a little which should give you enough room to look around. Repeat for drivers side turning wheel to the right. This is how I swapped out my fog lights.
__________________
2013 LSM w/tech

Cobb AP V3, CBE
CS Turbo tuned by PD
Corksport Catted DP/HPFP Internals
JBR FMIC Pipe Kit w/TR8
CP-E TIP/3.5" Intake
DM OCC/TMM
Forge V2 BPV
Bilstein B8 w/Swift springs
Wilwood 6 pot BBK
EBC RedStuff rear pads
Konig Hypergram 18x8.5"
JakeMS3 is offline   Reply With Quote
 Old 02-13-2018, 06:52 PM   #9
 
mitch11wmm's Avatar
 
Join Date: Dec 2017
Posts: 11   (View Stats)
iTrader: (0)
Rep Power: 0
mitch11wmm will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

I see. Any idea where that relay is? Im thinking it's stuck closed

Sent from my VS995 using Tapatalk
mitch11wmm is offline   Reply With Quote
 Old 02-14-2018, 01:20 PM   #10
 
nekret's Avatar
 
Join Date: Jan 2013
Location: Vancouver, WA
Posts: 419   (View Stats)
iTrader: (0)
Rep Power: 0
nekret is the leader of the worldnekret is the leader of the worldnekret is the leader of the worldnekret is the leader of the worldnekret is the leader of the worldnekret is the leader of the worldnekret is the leader of the worldnekret is the leader of the worldnekret is the leader of the worldnekret is the leader of the worldnekret is the leader of the world
Thanks: 130
Thanked 135 Times in 101 Posts
Groans: 0
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

relay is on the passenger side and is clipped on to the body just under the headlight. easiest access is by removing the fender liner on the passenger side and looking up. you should be able to follow the fog light harness right to it.

http://www.mazda3tech.com/front_fog_...ation-756.html
__________________
2011 Mazdaspeed3 non-tech package
Drivetrain
CorkSport 3.5" MAF & TIP | CP-E FMIC | Synapse BPV | CorkSport EBCS (Interrupt) | Bosch 3 bar MAP | CorkSport HPFP Internals | CP-E Catted Downpipe | CP-E Triton 3" CBE | JBR Stage 2 OCC | Kozmic Primary EGR Delete | JBR Secondary EGR delete | NGK 6510 | TB coolant Bypass | JBR IM & TB Gaskets | Damond RMM, PMM, & TMM | JBR light shift weight | TWM Full Replacement Shifter | Cobb AccessPort V3 | FreekTune

Chassis
JBR Front & Rear Sway Bars | JBR Billet Rear Sway Bar Brackets | Whiteline Adjustable Front&Rear sway bar links | JBR Coilovers | Corksport BBK | Corksport Lower Tie Bar | Corksport Mid Chasis Brace

Rice
LED bumper reflectors | Morimoto LED Fog lights | VLEDs LED Highbeams | Independent Fogs | AP Engine & HPFP cover | CorkSport Pulleys | Corksport Leather Shift Knob | Corksport Steering Wheel | Damond front plate mount | Lukas LK-9750 2ch dashcam | Eonon GA7163 | thespeedline.com blue mirrors | thespeedline.com hood dampers

nekret is offline   Reply With Quote
 Old 02-16-2018, 06:17 PM   #11
 
mitch11wmm's Avatar
 
Join Date: Dec 2017
Posts: 11   (View Stats)
iTrader: (0)
Rep Power: 0
mitch11wmm will become famous soon enough
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
(Thread Starter)
Not Ranked  0 score     
Default

UPDATE: thanks to nekret I found the relay and replaced it, everything works fine as of now. If it messes up again I'll post another comment with the fix. As for the issue, the car was in an accident before I bought it and I guess the repair shop did not put the relay in it's correct place, instead it was just inside that area on the inside of the bumper, loose. I pulled it out and it leaked water. The contacts were all corroded to hell as well. I picked up the relay from AutoZone with part number "20928" and replaced the old one with this. I also replaced the fuse just for good measure. Finally, there were some prongs along the wires to the relay, I pushed these into the clips on the back of the coolant tank and then, just for good measure, ziptied the relay to the top clip so that it won't fall down and be exposed to water again.


Hopefully this helps someone. I got tired of seeing threads about an issue with no update so I figured I would break the cycle!!

Sent from my VS995 using Tapatalk
nekret likes this.
mitch11wmm is offline   Reply With Quote
The Following User Says Thank You to mitch11wmm For This Useful Post:
kTaLgsTo (02-16-2018)
 Old 02-16-2018, 06:22 PM   #12
 
kTaLgsTo's Avatar
 
Join Date: Dec 2017
Location: Idaho
Posts: 566   (View Stats)
iTrader: (0)
Rep Power: 121
kTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the worldkTaLgsTo is the leader of the world
Thanks: 84
Thanked 213 Times in 146 Posts
Groans: 10
Groaned at 1 Time in 1 Post
Not Ranked  0 score     
Default

Good job, forums live and breathe on people following through
__________________
2011 MS3 Tech - 2008 Jeep Grand Cherokee CRD - 1989 Crown Vic LTD LX - 1985 Lincoln Town Car Signature
The key to happiness is owning a car ridiculously slower than your 'fast' car.
kTaLgsTo is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tail lights/trunk lights options z28forlife Exterior 6 10-28-2017 08:16 AM
led interior lights and license plate lights cocoleveo7686 MazdaSpeed 3/6 - Appearance 1 11-25-2013 12:25 PM
wiring fog lights to the parking lights exftw MazdaSpeed 6 - How-To's 16 02-10-2013 09:23 PM
MS6 Painted Fog Lights and Tail lights rrussell50 MazdaSpeed 3/6 - Appearance 1 10-10-2012 04:55 PM
HIDs, Reverse lights, Liscence Plate lights Franconemo Exterior 31 06-12-2010 02:25 AM


All times are GMT -7. The time now is 01:10 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.31647 seconds with 25 queries