register gallery
 

Go Back   Mazdaspeed Forums >
MAZDASPEED SECTION
>
Mazdaspeed 3 MZR Gen2 Forums (2010-2013)
> Gen2 MS3 General Discussion


Welcome to Mazdaspeed Forums .

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

*When you join MSF as a registered user, there will be No Ads.

*Registered Members get access to the Off Topic Area of the Forum

*Registered Members have an opportunity to upgrade their accounts to VIP, which brings a host of goddies for supporting MSF such as Raffles, Additional Forum Access, More PM Storage, The ability to upload more Images and many other enhancements.

*Registered members also get access to the live chat box!
Reply
 
Bookmark and Share LinkBack Thread Tools Search this Thread Display Modes
 Old 07-20-2018, 11:07 AM   #1
BMC
 
BMC's Avatar
 
Join Date: Mar 2014
Location: Atlantic Canada
Posts: 170   (View Stats)
iTrader: (0)
Rep Power: 0
BMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond repute
Thanks: 204
Thanked 79 Times in 44 Posts
Groans: 0
Groaned at 4 Times in 3 Posts
(Thread Starter)
Not Ranked  0 score     
Default Fuel pressure problems

I've got a 2013 speed3 that began showing intermittent fuel pressure drop to in-tank-pump pressure (approx 75). This was early last year. I went through the narrowing-it-down process to find the problem (spill valve, fuel pressure relief valve, O-rings, loose connections etc.) It looked like it was the relief valve so I replaced it. Wrong. I tended not to think it was the Autotech internals as they so rarely fail. I then purchased a new pump and installed the Autotech internals in it. Still had the problem. I then sent the internals back to Autotech for inspection. They said they were off spec a bit and sent a new set. I installed them and had trouble free motoring since May of 2017. That's about 10,000 miles ago. Now I've got the same symptoms. Before starting the same bullshit process all over again, I was wondering if anyone else has had issues like this or any thoughts on it. Thanks in advance.
__________________
Black 2013 w/tech - initial installs - all COBB; FMIC, Accessport V3, SF Cold Airbox, Short Ram Intake, Turbo Inlet Hose, 3" SS Downpipe, 3" SS Cat-back Exhaust, Rear Motor Mount, XLE BPV, Polyurethane Exhaust Hangers. Autotech Fuel Pump Internals, Greddy catch can, Freektune,

Most recent installs/swaps; BNR S4 , HTP 3" intake kit, , TIG intake to head, CPE EGR delete, Swift lowering springs, rear camber arms, CPE 75 duro driver and passenger mounts, ProMeth Tank, Aquamist HFS-4 V-3 w/m injection kit (to combat our absolutely garbage, 91 octane), (.8 & 1.0 jets), vent gauge pod, Nitto NT05s
BMC is offline   Reply With Quote
 Old 08-05-2018, 12:00 PM   #2
BMC
 
BMC's Avatar
 
Join Date: Mar 2014
Location: Atlantic Canada
Posts: 170   (View Stats)
iTrader: (0)
Rep Power: 0
BMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond reputeBMC has a reputation beyond repute
Thanks: 204
Thanked 79 Times in 44 Posts
Groans: 0
Groaned at 4 Times in 3 Posts
(Thread Starter)
Not Ranked  0 score     
Default

Not much interest in this thread but to finish it off, it turned out to be the in-tank-fuel-pump. After revisiting the usual suspects (spill valve, relief valve, HPFP etc.), I dropped the fuel tank and replaced the entire pump unit. For whatever reason it's cheaper to buy the complete assembly than the pump by itself. Big job (see earlier thread re disconnecting green quick release connector at the tank), problem fixed.
__________________
Black 2013 w/tech - initial installs - all COBB; FMIC, Accessport V3, SF Cold Airbox, Short Ram Intake, Turbo Inlet Hose, 3" SS Downpipe, 3" SS Cat-back Exhaust, Rear Motor Mount, XLE BPV, Polyurethane Exhaust Hangers. Autotech Fuel Pump Internals, Greddy catch can, Freektune,

Most recent installs/swaps; BNR S4 , HTP 3" intake kit, , TIG intake to head, CPE EGR delete, Swift lowering springs, rear camber arms, CPE 75 duro driver and passenger mounts, ProMeth Tank, Aquamist HFS-4 V-3 w/m injection kit (to combat our absolutely garbage, 91 octane), (.8 & 1.0 jets), vent gauge pod, Nitto NT05s
BMC is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Low fuel pressure brandonnicholson MazdaSpeed 3/6 - Troubleshoot/Diagnostics 49 Today 07:24 AM
Fuel Pressure Problems at Idle CJones1225 MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection 2 06-03-2018 08:49 AM
FUEL PRESSURE HELP riflex MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection 5 02-14-2018 12:00 PM
Fuel Pressure Qual1ty MazdaSpeed 3/6 - Fuel, Nitrous & Water Injection 48 10-13-2013 10:28 AM
0 Fuel Pressure/0.0 Volts HPFP Voltage...but I do have fuel pressure?? AFcadet MazdaSpeed 3/6 - Troubleshoot/Diagnostics 24 08-02-2012 11:12 PM


All times are GMT -7. The time now is 11:30 AM.
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
SEO by vBSEO ©2011, Crawlability, Inc.
vB.Sponsors
Template-Modifications by TMS
©Copyright 2008 ; 2018 Cymru Internet Services LLC | FYHN™ Autosports HQ
Ad Management plugin by RedTyger
Page generated in 0.22223 seconds with 20 queries